Windows 10: Issues with ethernet connection - internet slower than on WiFi


  1. Posts : 5
    Windows 10 Education 64-bit
       26 Aug 2015 #1

    Issues with ethernet connection - internet slower than on WiFi


    I have a desktop pc in room 1 which up until now has been connecting fine to the internet via WiFi from the router (DrayTek Vigor2710ne) in room 2.

    I was getting acceptable speeds using WiFi but in an effort to see if I could get a faster connection I decided to run an ethernet cable (30m cat5e) from the router up through the ceiling and down into my room. This was the result I got when checking the speed over the ethernet. (I was testing throughout the evening so pay no attention to the fact that they're an hour apart).

    When I checked the WiFi speed I had all the other network adapters disabled apart from the WiFi (Realtek 8185 Extensible 802.11b/g Wireless Device) and when I checked the ethernet I disabled everything but the ethernet (Realtek PCIe GBE Family Controller). The drivers are the latest from Realtek.
    Was just curious as to if I am doing something wrong or what sort of results I should be/could be getting with the ethernet because I'm pretty sure something's wrong here.

    Any help would be appreciated and I can post logs/configurations/more info/etc if needed.
    Thanks in advance, cheers guys.
      My ComputerSystem Spec


  2. Posts : 119
    Windows 7 (reverted back)
       26 Aug 2015 #2

    Stupid question.... what kind of wiring did you use?
    Was the cable terminated by yourself or came pre terminated?
      My ComputerSystem Spec


  3. Posts : 5
    Windows 10 Education 64-bit
    Thread Starter
       26 Aug 2015 #3

    Came ready to go in standard commercial type plastic casing like you'd buy in a tech store. I can probably dig it up if you need more details about it. Bought online from China but as far as I know it should be fine. :s
      My ComputerSystem Spec

  4.    26 Aug 2015 #4

    Can you run a ping test to your router. Here's how just in case

    Microsoft Corporation

    If you see lost packets, I'd suspect the cable. I've seen it from poorly crimped cables and occasionally interference along the path of the cable.
      My ComputerSystem Spec


  5. Posts : 5
    Windows 10 Education 64-bit
    Thread Starter
       27 Aug 2015 #5

    sciencegeek said: View Post
    Can you run a ping test to your router. Here's how just in case

    Microsoft Corporation

    If you see lost packets, I'd suspect the cable. I've seen it from poorly crimped cables and occasionally interference along the path of the cable.

    Doesn't seem to be a problem. :s
      My ComputerSystem Spec

  6.    27 Aug 2015 #6

    Solax said: View Post

    Doesn't seem to be a problem. :s
    That's the loopback test. It tests a loopback card whose IP is set to 127.0.0.1. Don't believe the loopback tests actually leaves the system. You need to test the response from the router, which is more likely to have an IP like 192.168.xxx.xxx. To find the Ip address of your router, right click on the Start button, select Command Prompt, type "ipconfig /all" (without the quotes). Look for something that says something like "Ethernet Adapter Local Area Connection" and beneath it should be something like "Default Gateway". That should be the IP address of your router and then redo the ping test using those numbers instead of 127.0.0.1.
      My ComputerSystem Spec


  7. Posts : 5
    Windows 10 Education 64-bit
    Thread Starter
       27 Aug 2015 #7

    sciencegeek said: View Post
    That's the loopback test. It tests a loopback card whose IP is set to 127.0.0.1. Don't believe the loopback tests actually leaves the system. You need to test the response from the router, which is more likely to have an IP like 192.168.xxx.xxx. To find the Ip address of your router, right click on the Start button, select Command Prompt, type "ipconfig /all" (without the quotes). Look for something that says something like "Ethernet Adapter Local Area Connection" and beneath it should be something like "Default Gateway". That should be the IP address of your router and then redo the ping test using those numbers instead of 127.0.0.1.
    Ahh, my mistake.

    Still looks good I think.
      My ComputerSystem Spec

  8.    27 Aug 2015 #8

    Solax said: View Post
    Ahh, my mistake.

    Still looks good I think.
    Yeah, looks fine.

    There's a thread here

    Solved LAN/Ethernet problem (DNS Client Events 1014,Realtek/Clean W10 install - Page 9 - Windows 10 Forums

    Dealing with the same realtek Ethernet card.
      My ComputerSystem Spec


  9. Posts : 5
    Windows 10 Education 64-bit
    Thread Starter
       28 Aug 2015 #9

    Drivers, my favorite. I'll look into it.

    I did a speedtest of WiFi v the ethernet on my laptop running Windows 8.1 and they both ended up about the same. :s

    For curiosity I did another test too on my Pc:
    Desktop pc with just WiFi
    Pc with just WiFi adapter enabled but Ethernet cable plugged in (unexpected result)
    So for some reason internet is slower even when the cable is plugged in but the adapter is disabled and all internet should be coming though WiFi.

    I also read in some other thread that Cisco vpn could cause issues. I had Cisco installed but I installed it after upgrading to Windows 10 as opposed to installing it in Windows 7 or 8 and upgrading with it. Uninstalled it anyway but saw no difference.

    Something else, not sure if important or not:
    This is what my network connections look like on my Pc.

    Wireless Network 2 is my WiFi (disconnected here)
    Local Area Connection is what the ethernet to my router is coming up under. I thought it was weird that it was coming through there and not 'Ethernet' but even though it was slow there was internet access coming through so I figured it was working (badly) as intended.
    Ethernet on the left doesn't do anything. When I enable it it just says "Network cable unplugged" - even when my cable is plugged in. There's only one ethernet port on the back of my pc so I have no idea what its purpose is.


    And this is what network connections looks like on my laptop.

    Again, WiFi is obvious.
    Local area connection 2 doesn't do anything as far as I know.
    Same with Local area connection.
    Ethernet on my laptop is where the internet connection comes under when I connect it as opposed to coming under "Local Area Connection" like it does in my Pc.

    So yea, not sure if it's significant or not but it's something I noticed.
      My ComputerSystem Spec

  10.    28 Aug 2015 #10

    The network connections described with TAP - Windows Adapter or TAP - Win32 Adapter are virtual adapters for VPN software or virtualization software. Assuming you are running neither of these types of software, just right click on icon and select disable if they are already not disabled. If you're absolutely certain you're not running either types of software, you can delete them, but it's safer just to leave them disabled. The network connection described with Realtek PCIe GBE Family controller is the connection tied to your actual physical Ethernet card. There may be a slight chance that the Cisco VPN software may have messed up your network card settings, but right now, I'm more inclined to believe the Realtek driver for Windows 10 is the issue.
      My ComputerSystem Spec


 

Related Threads
WiFi and ethernet together in Network and Sharing
I was wondering if it's possible to utilize both WiFi and ethernet in tandem. I'm pretty sure some of you are going to tell me that I can only access the internet through one of these, up to my bandwidth limit, but that's not what I mean. I'd...
Basically what happened before: After updating to Windows 10, my computer was not showing any network options. (The icon says "Not connected - No connections are available) Going into Control Panel/Network and Internet/Network Connections, it then...
Debug report attached. 27187
need to set Internet to metered connection in Windows home with ethernet connection. only seems to be an option for WIFI....I don't connect using WIFI but have a metered connection, so can't afford windows to auto download.... is is there a...
After I upgraded to windows 10, I started having problems with my lan connection. My speed was fine but after 10 minutes of use, the Internet connection just stopped. The shutdown and startup of the computer was also effected by this issue. Whenever...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:04.
Find Us