Problem when setting up remote printer access


  1. Posts : 1,406
    X
       #1

    Problem when setting up remote printer access


    From my desktop PC I use a remote printer attached to a laptop. It worked for months, but not anymore.

    So on the desktop PC I removed that printer, intending to recreate it. But I cannot.

    From the Printers & scanners control panel, when I click on Add a printer or scanner it searches but cannot find the printer.

    So then when I click The printer that I want isn't listed I get this error:
    Windows cannot access the specified device, path, or file.
    You may not have the appropriate permissions to access the item.

    When I click on Print server properties I get the same error.

    In the Bluetooth & other devices section when I click on Send or receive files via Bluetooth I get that same error.

    In the Bluetooth & other devices section when I click on More Bluetooth options I get that same error.

    For all of these situations there must be some file/program that cannot be accessed, presumably because of permissions.

    Note that the title bar of the error popup says: C:\WINDOWS\system32\rundll32.exe

    So I guess that rundll32.exe is being given a file name (a dll ?) that it cannot access.

    But what file is that? How do I fix this?
      My Computer


  2. Posts : 1,406
    X
    Thread Starter
       #2

    Update: If I log in as Administrator, I don't get that error.
    And if I log in using my wife's account, I don't get that error.
    Does that help pinpoint the problem?

    Anyway ... logged in as either Admin or wife's account I can try to create the printer. But no luck.
    I tried \\xxx.xxx.xx.xxx\Canon MX470 (that's the IP and printer name). Windows cannot find it.
    I checked the laptop ... and this printer **is being shared** on a private network.
    (I checked: both the desktop and laptop are on the "private" network profile.)

    So now that's two problems.
      My Computer


  3. Posts : 1,406
    X
    Thread Starter
       #3

    Anybody?
      My Computer


  4. Posts : 8
    Win10 Pro
       #4

    Okay when you deleted the printer did you do it in the window that shows all network devices? The reason I ask is I was trying to share and though I could see the other PC in the window when I would click on it I got a message about "Credentials". Finally, the only way I could get the shared folder to show up in the window was go to the sidebar and right-click the icon for the PC. Have you tried right-clicking on the side bar? I know, this seems ridiculous. I mean if you can see it in the side bar you should be able to see it in the window. After I would right-click the icon and click "Open" then the window would show shared folders in the PC that had been there all along.
    Reason I mention this is when you deleted the printer from the window it may still be hanging around and you can't tell.
    I'm pretty much a newb here so don't get your hopes up. :)
      My Computer


  5. Posts : 1,406
    X
    Thread Starter
       #5

    I tried once again to create the printer ... and it worked.

    Why now and not before? Dunno. Another case of spooky Windows nonsense.

    Anyway ... case closed.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:36.
Find Us




Windows 10 Forums