Hi All,

I've only recently migrated to Win10 and have found a bug that's really...bugging me!

I can't seem to delete some files on network shares.

This morning I created three files in the same folder. I can delete two of them, but the third one just won't go. It appears to be deleted, but when I refresh (F5), it's still there!

This isn't the first time this has happened, but it's the first time a restart of the machine hasn't fixed it.

I've tried:

1. Restarting Explorer/the whole machine.
2. sfc /scannow reveals no problems.
3. Disabled all 3rd-party context menu add-ins.
4. Disabled Quick Access in File Explorer.
5. Tried to delete it using command prompt (Access Denied) and an elevated command prompt (Access Denied).
6. Logged-on to the NAS where the files are and checked their permissions; all identical.

To be honest File Explorer has been quite troublesome ever since I switched to 10, with it running very slow and taking ages to create new folders, mounted ISO images getting "stuck" (ejected but unable to delete the ISO files), unable to mount ISO images without copying them to another folder first etc etc, but this failure to delete is something I can't live with.

I could probably delete the file by logging-on to the NAS OS directly and deleting it there, but that's not something I'm prepared to put up with having to do every time this happens.

Can anyone help?


Windows Version 21H1 (OS Build 19043.1110)

- - - Updated - - -

Further news...

I copied the file, then deleted the copy - no problem. Then, as if by magic, I was also able to delete the original file.

Colour me confused