Windows 10: USB Wi-Fi adapter not showing on tray Solved

Page 1 of 2 12 LastLast
  1.    21 Aug 2015 #1

    USB Wi-Fi adapter not showing on tray


    Latest driver installed, StarTech USB300WN2X2D, Mediatek/Ralink RT3572L

    Click image for larger version. 

Name:	wifi 2-001.JPG 
Views:	3 
Size:	46.4 KB 
ID:	32971
    Last edited by LarryWind; 21 Aug 2015 at 10:50.
      My ComputerSystem Spec

  2.    21 Aug 2015 #2

    Is this a driver for Windows 10? I am waiting for one from D-Link for my USB Wi-Fi adapter.
      My ComputerSystem Spec

  3.    21 Aug 2015 #3

    alkaufmann said: View Post
    Is this a driver for Windows 10? I am waiting for one from D-Link for my USB Wi-Fi adapter.
    no, the driver it's for windows 8 but it works, the only problem is can't connect/switch from tray list
      My ComputerSystem Spec

  4.    21 Aug 2015 #4

    When I upgraded from Windows 8.1 Pro my driver and the Wi-Fi management software seemed to work too. My system works much better since I uninstalled the software and remove that device. I know D-Link is working on a Windows 10 driver and I will wait for it.
      My ComputerSystem Spec

  5.    18 Dec 2015 #5

    November version fixed this
      My ComputerSystem Spec

  6.    18 Dec 2015 #6

    Just tried to install my DWA-182 adapter on the latest Windows 10 Pro build, the D-Link driver install program got stuck in the middle of the install. I had to end that task and now whatever it did won't uninstall. :-(
      My ComputerSystem Spec

  7.    18 Dec 2015 #7

    alkaufmann said: View Post
    Just tried to install my DWA-182 adapter on the latest Windows 10 Pro build, the D-Link driver install program got stuck in the middle of the install. I had to end that task and now whatever it did won't uninstall. :-(
    As a fellow Canadian, I assume you are going to the D Link Canada support site to get the driver for the DWA - 182. For some strange reason the U.S. site has driver 3.03 B04 while the CDN site has 3.05. That's the driver as long as you have firmware C (not A) on your adapter, which you can read from the box it came with.

    That 3.05 driver is a Windows 10 driver, at least that's what D Link told me and if you unzip the driver files you will see a directory for Win 10 x64, x86. But you are right, the driver won't install. Why? Because it's not digitally signed. I explained this to D Link in a 35 minute chat. Finally they started to listen and said they would investigate and get back to me. Still waiting.

    What does work (all the time) are Brinks Windows 10 tutorials. If you search, he has one somewhere on how to install a digitally UNSIGNED driver. You restart in trouble shoot mode and select the option (7 maybe) to install an unsigned driver. I did that to see if the 3.05 would install. I didn't want the software, just the driver and wanted to make sure the files from the d link windows 10 X64 driver got installed. I unzipped the driver files, device manager, have disk and pointed to the unzipped win 10 x64 d link driver. It took a while, but it installed. So now it says I have D Link driver 1030.0.505, 2015 installed and to no surprise to me it says "not digitally signed". Thank you Brink.

    The driver works but I find it flakey. It causes slow shut down as "Switch USB 2.0/3.0" often hangs at shutdown. My system only supports 2.0 so in the advanced driver options I set it to USB 2.0 instead of automatic. That helped a bit but I still find shutdown/restart slow with the d link driver.

    My laptop (older that my Alienware) has wireless on the motherboard. No issues at all. I find Windows 10 drivers for USB wireless to be a nightmare. Microsoft needs to have a chat with these manufacturers. Nothing about Windows 10 can be enjoyed when one constantly has connectivity issues because of poor or no wireless USB drivers released by the manufacturers.
      My ComputerSystem Spec

  8.    18 Dec 2015 #8

    Yes I went to the CA d-link website and got the latest driver for my "A1" adapter. What I will try is connect the laptop with an Ethernet cable and then connect the adapter. Maybe Microsoft will just install the driver.
      My ComputerSystem Spec

  9.    18 Dec 2015 #9

    Oh, firmware "A". That's unfortunate. I had an Asus N53 adapter. It was causing me problems, very slow downloads. I bought the D Link DWA-160. I asked D link when a Win 10 driver would be available. Kept getting "No ETA" from them. Not good. I asked them what adapter has windows 10 drivers as I can still return the DWA -160. They told me DWA-182 but get the adapter with firmware C, which is what I have.

    That CDN site has a floating chat window. I assume you have or will ask them when a Windows 10 driver for firmware A will be out. Honestly hope you won't or didn't get the "No ETA" response. No drivers or drivers where the digital signature has expired. Man, Microsoft needs to give D Link a tutorial.
      My ComputerSystem Spec

  10.    18 Dec 2015 #10

    DWA-182 Adapter


    Yeah, I got A'd by D-Link.

    I just plugged in the adapter and then went into the device manager to update the driver. I browsed to the location where I had unzipped the driver and selected the Win8.1 x64 folder. Windows installed that driver and I got a 866.5 Mb/sec connection. I rebooted a couple of times and it seems to be working. Maybe the latest Windows build 11082 changed something. Right now the only thing I don't have is the D-Link management software and I don't care about that.

    As usual after working for several re-starts it worked fine and then it stopped working. No reason why.

    Ak
    Last edited by alkaufmann; 19 Dec 2015 at 11:01. Reason: Stopped working
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I have grown accustomed to having the day show in the system tray with the time and date... Now, I've been an IT guy now for going on about 15 years just about, so I DO know my way around... And I know it makes me sound like an old man who maybe...
Please explain to me how to do the following. I have hidden all the icons on the system tray but I want to permanently remove the small arrow that is pointing upwards and also the small vertical bar that is next to it. Thankyou, Gavin Gilbert
I just upgraded to windows 10 via windows updater tool (available on microsoft's official website). I'm using an external adapter i.e. TP-LINK-WN722N to connect to the wifi network because apparently, the router is located far off from where I use...
Solved Windows Defender Not Showing In Tray in AntiVirus, Firewalls and System Security
Everytime i restart or power on my computer i always have to manually show windows defender on my system tray icons, how do i turn it on so it's always there?
Hello, Well as you can see in the screenshot Vuze is running, up 5 times apparently! It isn't obviously, and I can only right click on the icon on the lower right, but this is annoying. Any ideas of how to resolve it? 28067
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:03.
Find Us