I can't download anything with browsers

Page 1 of 13 12311 ... LastLast

  1. Posts : 52
    Microsoft Windows 10 Pro 64 bit 19042 Multiprocessor Free
       #1

    I can't download anything with browsers


    Hi
    I can' t download anything from browsers, everytime the download starts after few second the speed drops to 0 and it says "Download Failed- Network Error".
    i'm on Ethernet and i've already updated the drivers.
    i can download games with steam, i have this problem only with browsers
    I can download the same files on other devices with the same connection

    Does anyone know how to fix this?

      My Computer


  2. Posts : 15,958
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #2

    Hello @JustSnooze,
    Welcome to TenForums.

    JustSnooze said:
    I can' t download anything from browsers, everytime the download starts after few second the speed drops to 0 and it says "Download Failed- Network Error".
    i'm on Ethernet and i've already updated the drivers.
    i can download games with steam, i have this problem only with browsers
    I can download the same files on other devices with the same connection.

    You haven't set the download location in the Browser to an external HDD or USB that isn't attached have you?
      My Computer


  3. Posts : 52
    Microsoft Windows 10 Pro 64 bit 19042 Multiprocessor Free
    Thread Starter
       #3

    Paul Black said:
    Hello @JustSnooze,
    Welcome to TenForums.




    You haven't set the download location in the Browser to an external HDD or USB that isn't attached have you?
    i just tried it, i set the download location to my external HDD but it doesn't work. The download start and after few seconds the speed drop to 0 b/S and i can't complete the download
      My Computer


  4. Posts : 15,958
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #4

    Hello @JustSnooze,

    JustSnooze said:
    i just tried it, i set the download location to my external HDD but it doesn't work. The download start and after few seconds the speed drop to 0 b/S and i can't complete the download

    [1] What are you using for the download?
    [2] Is it a Torrent?
    [3] Can you download other things from the same site or do you have the same problem.

    Depending on the size of the file that you are downloading, some Torrents take a while to kick in and actually start the download.

    I hope this helps.
      My Computer


  5. Posts : 52
    Microsoft Windows 10 Pro 64 bit 19042 Multiprocessor Free
    Thread Starter
       #5

    Paul Black said:
    Hello @JustSnooze,




    [1] What are you using for the download?
    [2] Is it a Torrent?
    [3] Can you download other things from the same site or do you have the same problem.

    Depending on the size of the file that you are downloading, some Torrents take a while to kick in and actually start the download.

    I hope this helps.
    [1] i'm using Chrome but i have the same problem with every browser
    [2] no i have no problem with torrents
    [3] i can download only small files because the download ends before the speed drop. This happens on every site
      My Computer


  6. Posts : 5,169
    Windows 11 Home
       #6
      My Computer


  7. Posts : 52
    Microsoft Windows 10 Pro 64 bit 19042 Multiprocessor Free
    Thread Starter
       #7

    TairikuOkami said:
    I tried with jdownloader 2, i can download all the files but the speed is very low
    Same with a VPN.
      My Computer


  8. Posts : 15,958
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #8

    Hello @JustSnooze,

    JustSnooze said:
    I tried with jdownloader 2, i can download all the files but the speed is very low
    Same with a VPN.

    [1] Are your Network Settings on the computer the SAME as on the other devices?
    [2] Have you changed ANY Network Settings?
    [3] What have you tried BEFORE you posted the problem?
      My Computer


  9. Posts : 52
    Microsoft Windows 10 Pro 64 bit 19042 Multiprocessor Free
    Thread Starter
       #9

    [1] Yes
    [2]i've changed only the DNS to see if it works.
    [3] i tried to update the LAN drivers, uninstall the antivirus, reset the network settings, reinstall the browsers, changed the ethernet cable,with CMD i tried to do"/Flushdns", " netsh winsock reset","net interface Ipv4 and ipv6 reset" and " sfc /scannow" but nothing worked
      My Computer


  10. Posts : 15,958
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #10

    Hello @JustSnooze,

    JustSnooze said:
    [1] Yes
    [2] i've changed only the DNS to see if it works.
    [3] i tried to update the LAN drivers, uninstall the antivirus, reset the network settings, reinstall the browsers, with CMD i tried to do"/Flushdns", " netsh winsock reset","net interface Ipv4 and ipv6 reset" and " sfc /scannow" but nothing worked

    Pretty thorough.

    [1] What were the results of running SFC, were there ANY violations?
    [2] You could try running the following Command from an Elevated CMD Prompt . . .

    Code:
    
    Dism /Online /Cleanup-Image /RestoreHealth

    I hope this helps.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:20.
Find Us




Windows 10 Forums