Can only read not write to external drives connected to Linksys router  

  1. Posts : 1
    Windows 10 Home

    Can only read not write to external drives connected to Linksys router

    I've been putting off trying to get this fixed since August but I can't write to either of the 2 external drives that I have connected to my Linksys router. It worked fine until then and I still am baffled why it changed to read-only.

    If I go to the security tab on the properties of either drive "Everyone" only has "special permissions" checked. Below that is "root (Unix User\root)" and "root (Unix Group\root)". Just like "Everyone", "special permissions" is the only option selected. I'm unable to change the permissions on the drives. I get the error, "Failed to enumerate objects in the container. Access is denied."

    I've tried downloading a CMD based application that is supposed to allow you to take ownership of a drive but it fails.

    If I disconnect one of the drives and hook it directly to the USB 3.0 port on my laptop it shows the option to change the permissions but then I have to remap the drive when connecting back through the router.

    Does anyone have any idea on what might be the cause and resolution of this?

    Many thanks in advance for the help.

      My Computer

  2. Posts : 494
    Win 10 Pro x64 versions

    My guess is that you have unauthenticated access to these drives and the August Windows 10 upgrade has decided they pose a security threat therefore SMB security as marked them as read only.

    If this sounds likely you may wish to review the link below for information about how to setup the disks for secure use on your network. Another item you might check is to see if sharing of the disks is enabled in Windows Network settings. If that has been disabled, enable it and see if that solve it.
      My Computer

  3. Posts : 77
    Windows 10 Pro

    I have this same problem on Windows 10 Pro, but not on Home Edition, nor on Windows 7.

    For the past few years, I've been running Windows 7 in Hyper-V and using that environment to update media on my Linksys NAS drive. It's a pain and consumes a lot of resources. I've been trying to crack this problem of using Win 10 directly for years. The Microsoft help forum only tells me to update my LAN drivers. That did nothing.

    Your description of the reason makes more sense.

    I can access the NAS drive as read only. But some of the filenames are replaced with lengthy string of numbers in some folders but not all. In Windows 7, all files have their real names in all folders and I have read AND write access under Hyper-V on Windows 10 Pro.

    I've updated the firmware on the router today and now Windows 10 cannot even see it as read only--it's completely gone from the explorer.
      My Computers


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 13:51.
Find Us

Windows 10 Forums