Ethernet Connection gets broken at certain times


  1. Posts : 22
    Windows 10
       #1

    Ethernet Connection gets broken at certain times


    Hi guys,

    I've been experiencing a lot of different ethernet issues since the start of this week. Sometimes it shows "Ethernet' doesn't have a valid IP configuration", sometimes it shows "your computer appears to be correctly configured but the device or resource DNS server is not responding" . Sometimes it tells me to unplug my modem and replug it back in.

    I tried resetting network adapter, change DNS to google's DNS, disable IPV6, disable power management but it still doesn't work. While sometimes it working really well but at certain time of the day, the ethernet connectivity becomes slow or even broken.

    Hence I need your kind advice on resolving this issue. Any feedback appreciated. Thank you.
      My Computer


  2. Posts : 4,473
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Cybersecurity Specialty.
       #2

    Hi @ern815 -

    Welcome to Windows Ten Forums!

    Could you please try these (again) and post back with your results?

    Reset Network Adapters in Windows 10
    Delete Wireless Network Profile in Windows 10

    Unplug any connected hardwired LAN connection before proceeding.
    Do not modify the DNS just yet.

    HTH,

      My Computer


  3. Posts : 6,979
    windows 10
       #3

    It sounds like a DHCP problem try setting a static IP that should stop the problem
      My Computer


  4. Posts : 4,473
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Cybersecurity Specialty.
       #4

    Samuria said:
    It sounds like a DHCP problem try setting a static IP that should stop the problem
    It's a band-aid. How do you know that the OP can get a static IP, anyway?

      My Computer


  5. Posts : 22
    Windows 10
    Thread Starter
       #5

    Hi both,

    Thanks for the suggestions.

    I tried resetting the network adapter and remove some wifi profiles. The ethernet connection is working now but not too sure if the problem will return later. Will post some updates later.

    At the same time, I connect another ethernet cable to my playstation 4 and the connection was weak too. I'm not too sure whether or not it could be my router instead?

    I'm currently using TP Link AV500 with 2 cables. One connects to my laptop while the other connects to my playstation.

    - - - Updated - - -

    Further update: the internet seems to lag again an hour later. Hence, I decided to unplug the cable cord between my TP link 500 adapter and the router and plug it into another port in my router. Turns out all are good now and the speed has seemingly improved. I will monitor again on this tomorrow and see if all are resolved.

    Thanks for your help guys.
      My Computer


  6. Posts : 4,473
    Windows 10 Pro x64, Various Linux Builds, Networking, Storage, Cybersecurity Specialty.
       #6

    ern815 said:
    Further update: the internet seems to lag again an hour later. Hence, I decided to unplug the cable cord between my TP link 500 adapter and the router and plug it into another port in my router. Turns out all are good now and the speed has seemingly improved. I will monitor again on this tomorrow and see if all are resolved.
    I would switch it back and see if it lags again. Just curious.

    Let us know.

      My Computer


  7. Posts : 22
    Windows 10
    Thread Starter
       #7

    Hi all,

    Updated as of today: Thanks for the tip Compumind! I switch it back on and all has been rather smooth over the past 2 days with little connectivity issues (There was at 1 point which my computer has diagnosed that the internet connection is broken but after a few minutes, the connection well smooth again) My case is seemingly resolved.

    Thank you for your kind advice. Have a great weekend!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:18.
Find Us




Windows 10 Forums