Quick Assist not working

Page 1 of 2 12 LastLast

  1. Posts : 84
    Windows 10 Pro 1909
       #1

    Quick Assist not working


    If anyone can offer any help is solving this problem I would be very grateful !!

    Has anyone figured out why Quick Assist will load and run just fine on some PC's while on others a rotating animated "loading" symbol just spins and spins but never displays the get help / give help interface???

    I'm in Montreal and we're still quite locked down because of COVID-19. I've been helping a number of folks with their PCs using Quick Assist as I'm reasonably tech savvy.

    I run five PC's running the same version of Windows 10 and only two of them will load Quick Access. Yesterday I tried to help someone (another isolated senior) remotely and her Win10 PC has the same problem so I cannot help her. Yet I've recently helped three other seniors with their Windows 10 computers as Quick Assist load and runs without any problem.

    I've tried pretty well everything I can think of to find the cause and I'm stumped.

    Here's what I've tried that does NOT work:

    - Privacy settings are the same on working vs not working systems.

    - disabled Windows firewall (there is no AV software other than Windows Defender)

    - ran System File Checker (SFC)

    - disabled 3'd party background apps

    - connected w/ wireless and Ethernet cable

    Here's what I've tried that DOES work:

    I created a new user on the same computer on the same network and when I loged in as that new user Quick Assist loads and works as it should. But WHY !!!

    This is not a good solution as it's their own user configuration that I need to help someone with.

    Is there something I could use to monitor the behaviour of Quick Assist while it's trying to load to help determine what's blocking it? It would be great to just find out what's going on that seems to be common to all these systems. I've been all over the Web and found others with the same issue but so far there's been no solution except creating a new user.

    Sorry for the long post ... but it's better to say what's worked and what's not to avoid folks suggesting solutions that have already been tried.

    RP in Mtl
      My Computers


  2. Posts : 43,242
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #2

    I created a new user on the same computer on the same network and when I logged in as that new user Quick Assist loads and works as it should. But WHY !!!
    Good diagnostic step.

    You've tried disabling 3rd party program startups, but there could be more things starting beyond those listed in the task manager startup list, if that's what you used.

    Ideally you would have hands on access to both PCs... but that's not so. All credit to them for creating a new user account etc.

    If you wished to disable more startups on the problem account you could use Autoruns (free from MS). But that seems asking a bit much of someone else remotely.

    Of course, the problem could have nothing whatsoever to do with startups... you might want to check all services are default, for example, in particular those necessary for this.

    Presumably it's not been blocked by the firewall:
    Block Quick Assist Access via Firewall: Another computer-level solution is to block Quick Assist via firewall. Quick Assist is an executable, which is found at %windir%\system32\quickassist.exe. By creating a Windows Firewall or Applocker rule blocking access of that executable to the internet, you effectively block Quick Assist.
    Get and Give Remote Assistance with Quick Assist app in Windows 10
    - some unfinished discussion as to whether both accounts had to be MS accounts or not.

    I found this:
    In a nutshell, Windows 10 Quick Assist allows you to view or control another user’s computer. All you need is a Microsoft account, such as Hotmail or Outlook.com. It is important to note that, the user requesting help via Quick Assist does not need a Microsoft account to get help via Quick Assist.
    Windows 10 Quick Assist: Helpful Remote Assistance App or Potential Vulnerability? — Steeves and Associates


    https://4sysops.com/archives/remote-control-windows-10-with-quick-assist/


    This gives useful detail on how it works. For example, it uses port 443, so you need to check that's not blocked.
    It also indicates how to block it- so you can check that doesn't apply.
      My Computers


  3. Posts : 84
    Windows 10 Pro 1909
    Thread Starter
       #3

    dalchina said:
    Ideally you would have hands on access to both PCs... but that's not so. All credit to them for creating a new user account etc.
    Actually it was me who created the new user on one of my systems that doesn't work with QAssist. That was a suggestion I found on a Microsoft support forum. But unfortunately I suspect the people who respond in those MS help forums are either using 'canned responses' or are simply support robots doing the same.

    Note that the MS account requirement is only for the person giving assistance and is not required by the person receiving it and Quick Assist will not even load to the point where I can enter my account details. One curiosity is that if I unplug the Ethernet cable and try to load QA I get a message saying "Network not found" (or something like that) before it gets stuck in the 'spinning dot' stage (does that have an official name?).

    I have 2 systems (including the laptop I'm on now) that work fine and can easily compare either of them with any of the three systems I own that do not work with QA. I was going to go through all the services running (or not) to see if there are any differences there. I will also go through the various links and other suggestions in your reply.

    It's too bad this is not a known issue with a known solution that would avoid all the work trying to fix this. But I'm stubborn ;-)

    Thank you for your suggestions! If I do find the answer I will be sure to post it here.

    RP in MTL

    - - - Updated - - -

    Well I spent quite a bit of time today comparing my laptop (that works fine with Quick Assist) with my desktop system (that Quick Assist does not work with) and I have found no differences that might explain what's blocking it.

    - compared all the privacy settings
    - compared network share settings
    - compared the services (Standard + Extended)
    - checked the startup apps (as best as I'm able)
    - checked all the Network Adapter settings
    - compared the Windows Features that are installed
    - checked all the Firewall settings I could find
    - tried using Autoruns but I'm not sure if there things I should do with it that I'm unaware of.
    - compared the quickassist.exe version on each system and they're identical as are their permissions.

    I found no clue whatsoever to why Quick Assist will not load and is stuck on its blue UI w/ a spinning circle of dots.

    So, as I did with my other system which had the exact same problem (remember I have 5 systems; 3 do not work + 2 that do work) I created a new User and when I logged in as that new User and on that same computer Quick Assist loads right away without a problem. I used Autoruns to compare the settings of the 2 users on the same system and cannot see anything that might be the cause.

    Rather than keep the new user named "test" I might delete it and create a user with a name I can live with and then replicate my preferences, settings and general configuration from the one User to the other and as I proceed I'll keep checking Quick Assist to see if something happens along the way that breaks it. If I end up with a new user that's pretty well identical to the old one but works fine with Quick Assist then I'll keep using it and delete the old one without ever solving the mystery.

    RP Mtl
      My Computers


  4. Posts : 43,242
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #4

    I respect your determination. Unfortunately it's not a feature with any means I can see for removing or reinstating (e.g. as a Windows feature) so no way to 'reset' it somehow.

    Clearly related to a user profile setting.. I mentioned the firewall possibility. The curious thing is it must be something that's quite easy and trivial to do.

    Here are some ways to block it - so you can check if one has been applied: I mentioned this before.
    Windows 10 Quick Assist: Helpful Remote Assistance App or Potential Vulnerability? — Steeves and Associates

    Is there something I could use to monitor the behaviour of Quick Assist while it's trying to load to help determine what's blocking it?
    You could use MS's Process monitor (Procmon) - but this captures every single event and its filters are very technically detailed.

    This appears to confirm there's no way to reset Quick Assist somehow:
    https://answers.microsoft.com/en-us/...4-e02674625fa7
      My Computers


  5. Posts : 84
    Windows 10 Pro 1909
    Thread Starter
       #5

    Yes I've read the various reports that there's no real way to 'reset/reinstall' Quick Assist. For now I'll just switch users on my desktop system when I want to help someone remotely. For that I don't need any of my own apps/files/settings so working as a different User will have no impact. But it's unfortunate for the person I'm trying to help if they are unable to load Quick Assist if they need help and are isolated (such as a senior in a residence that cannot let any outsiders in).

    I'll try using Procmon to compare the working User1 with the broken User2. It's a shame that Microsoft does not take more responsibility in fixing their tools/features that have become much more essential during the global COVID-19 crisis. They have resources that could probably solve this mystery very quickly.
      My Computers


  6. Posts : 43,242
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #6

    The problem here is that an in-place upgrade repair install (general repair of the O/S) will not help you, as the problem is some configuration setting in your user profile.

    That could be made by a 3rd party program, a tweak tool, a registry hack, a setting - e.g. the firewall block I mentioned above- did you check that?

    Now, for most of those, you could not blame MS. You could blame MS for not providing a specific fix for each and every problem that could ever arise- yet in a way they have - with feature upgrades and in-place upgrade repair, for the O/S in general.

    Further, MS make System Restore available. Thus, if you have a restore point avaiable created before the problem arose, you can use the restore point. But if you don't know when the problem started, that's tough.

    tenforums members tirelessly recommend the routine use of disk imaging, thus you can have different points in time to which you can restore Windows or any imaged partition - but that, unlike system restore, affects any personal data on the restored partition.



    **** I just came across this- although it's not listed in the relevant tutorial here with respect to this command, you could still try it:

    Quick Assist not available?

    For more experienced user, you may be able to fix it (it should bring back accidentally removed options) in PowerShell (run as Administrator) with the following statement (in case you manually removed it at some time):
    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    Tweaking4All.com - Windows 10 Quick Assist - Troubleshoot a Friend’s PC Without Any Extra Software

    - note it can be removed using Powershell too (just for completeness)
    The handy Windows feature you should probably turn off! - Curatrix Technologies

    And remember to check port 443 is open:
    Quick Assist communicates with a central Microsoft server on port 443, so it will not be blocked by default on most firewalls
      My Computers


  7. Posts : 84
    Windows 10 Pro 1909
    Thread Starter
       #7

    Thank you Dalhchina for your suggestions

    How can I check if port 443 is open?


    fwiw I already tried the Powershell Get-AppXPackage thing a long time ago without success. I do have updates of my system that I could restore if it was something really worth doing (I image the whole OS/Apps M.2 drive every few months when all is working and also back up my 'data/files' sata SSD drive on a continuous basis) . My solution will be to just switch user accounts when giving assistance.

    Unfortunately asking an 80-90 year old to perform a system restore while talking to them on the phone through their hearing aid isn't practical. If there was some simple cause that could be found and fixed (with the help of MS) then the instructions could be sent by email or perhaps Microsoft could issue a patch. I've come across so many posts online with this exact same problem that remains unresolved I cannot imagine that every one is being caused by something different ...
      My Computers


  8. Posts : 43,242
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #8

    Quick Assist not working-1.png

    I suppose another possibility might be that some related service is not configured correctly...

    E.g. Tweaking.com's repair tool includes a repair to set services to default.

    I suggest you look at affected PCs and check installed programs to see if there are any that are common only to those and not others, especially 3rd party security programs with firewalls.

    I saw a note somewhere that there's no relevant group policy.

    Is this idea relevant?
    1. Press Windows key + I to open Settings.
    2. On Settings, choose Apps & features.
    3. On the left pane, choose Programs and Features.
    4. Then, look for Quick Assist and click on it.
    5. Choose Advanced options, then Repair.


    or this:
    Method 2: Check the Internet Explorer’s settings.


    A few settings within Internet Explorer affect the way the applications behave within the system. Please follow the steps below and check if the settings are intact.


    1. Press the Windows key and R key, this will open the Run dialogue box for you.
    2. Type inetcpl.cpl and press Enter. This will open Internet Properties.
    3. Click on the Advanced tab, under Settings, scroll down to find Do not save encrypted pages to disk.
    4. Uncheck it. Click on Apply and then OK.
    5. Restart the system and check if the issue still persists.
    - this helped some people
    https://answers.microsoft.com/en-us/...1-3a46fe1fd0a6
      My Computers


  9. Posts : 84
    Windows 10 Pro 1909
    Thread Starter
       #9

    IT'S FIXED - IT'S FIXED - IT'S FIXED - IT'S FIXED !!!!

    Port 443 is apparently the one that all https secure web traffic goes through, so even though I did check if it was open (thanks for hitting me on the head with -> don't ask -> do a search) it was NOT the problem.

    I have now applied the following fix to 2 of my own systems as well as via a phone call with the elderly lady I wanted to assist and it works like a charm. So ..... without further adieu ... here is the FIX:

    --------------------------------------

    Launch Internet Explorer and click on it's Tools icon (gear in top right).
    Select -> Internet Options -> Advanced pane -> Reset Internet Explorer settings section at the bottom
    Press the "Reset..." button in that section and then confirm to reset in the next pop-up menu.
    --------------------------------------
    That's it, that's all. Do the Happy Dance

    I have no clue whatsoever what this did and how it fixed it. But it works. What's incredibly great about this is that it's a simple procedure that can be explained to pretty welll anyone while speaking on the phone and requires no technical skill (no Regedit, no Command prompt, no DOS commands, etc..).

    Needless to say I'm quite proud of myself. I just read somewhere along the way that there might be some connection with Internet Explorer (who uses that anymore??) and went through every pane in the options and pressed any resets I could find while trying to launch Quick Assist along the way --- and then I hit the jackpot with the one above.

    Thank you for your help in keeping my nose to the grindstone. I hope this fix helps others who are facing the same issue.

    Cheers (too bad I don't drink anymore...)

    Russell

    PS: I have yet to restart my computer to confirm that the solution sticks. But even if it doesn't it's OK as it will at least allow a Quick Assist session to proceed.
      My Computers


  10. Posts : 43,242
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #10

    Good. Ref. IE- see the suggestion about that in Method 2 of my last.

    You've reset all-- that one's specific.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:17.
Find Us




Windows 10 Forums