Hello all.

After the upgrade my wireless adapter wasn't working. Reinstalled driver, problem solved. About 30 minutes later it was no longer working.

Under device manager there were 3 instances of my adapter. Opened them up and it said device not migrated. Windows kept trying to reinstall the driver. Tried everything I could think of.

After deleting the driver and reinstalling, it kept installing as number 3 and wouldn't work. Some registry entries were being retained. Got the guid, went into the registry and deleted everything to do with that guid to do a fresh driver install. I may have accidentally deleted everything for network adapters.

Tried to install wireless adapter and it said no class id. Played with some settings and got it to install. All I had to do was switch ports, oops. All adapters are back and working. However, I noticed some registry entries are still missing under that guid. Also, now under device manager, network adapters doesn't have an icon, just a piece of paper with a gear in the center as icon.

Anyways, internet is working. But should I be worried since some of the properties keys are still missing?