Ethernet keeps disconnecting


  1. Posts : 29
    Windows 10 Pro, Ubuntu 20.04, Mint 19.3
       #1

    Ethernet keeps disconnecting


    Since upgrading to Win10 (1903 then 1909) I have had frequent disconnections on my broadband. I use a standard CAT 5 ethernet cable connected to my router, and after about 10 minutes or so of internet connectivity my broadband drops. I can still connect to the router which shows the signal apparently still going with my IP address, but pinging any website (eg Google) using cmd just gives a blank, not even a disconnected or error message. Meanwhile the internet icon in the system tray shows no internet connection.

    A reboot will return my internet connection back to normal until the next drop which could be 10-20 minutes later. I should add I do not have this issue with Win 7 or Linux. I have an onboard ethernet chip on my motherboard, but clearly there's nothing wrong there, so this issue does seem Win 10 related. Any ideas on resolving this would be welcome.
      My Computer

  2. Caledon Ken's Avatar
    Posts : 24,242
    Windows 10 Pro x64 Version 2004
       #2

    Go into device manager, find adapter, right click, then properties, then power management tab. Shut off "Allow the computer to turn off this device to save power". Test.


    I would also look to see if you have the most recent driver for NIC.



    Ken
      My Computer

  3. Matthew Wai's Avatar
    Posts : 5,101
    Windows 10 Home 20H2
       #3

    bendipa said:
    A reboot will return my internet connection back to normal
    Have you tried restarting Network Connections and the network adapter?
      My Computer


  4. Posts : 29
    Windows 10 Pro, Ubuntu 20.04, Mint 19.3
    Thread Starter
       #4

    Caledon Ken said:
    Go into device manager, find adapter, right click, then properties, then power management tab. Shut off "Allow the computer to turn off this device to save power". Test.
    Already unchecked.

    I would also look to see if you have the most recent driver for NIC.
    Update in Dev Manager says 'best drivers for device already installed'.
      My Computer

  5. Matthew Wai's Avatar
    Posts : 5,101
    Windows 10 Home 20H2
       #5

    Minutes ago, my Ethernet failed due to "Error 651". Then, I restarted Network Connections. Now, I can access the Internet.
      My Computer


  6. Posts : 29
    Windows 10 Pro, Ubuntu 20.04, Mint 19.3
    Thread Starter
       #6

    Do you mean disabling 'Local Area Connection' then enabling it?
      My Computer

  7. Matthew Wai's Avatar
    Posts : 5,101
    Windows 10 Home 20H2
       #7

    I mean restarting the "Network Connections" service by running this command: net stop "Netman" & net start "Netman" via an elevated Command Prompt.
      My Computer


  8. Posts : 1
    windows 10
       #8

    did you find a fix ?
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:32.
Find Us




Windows 10 Forums