Hi All. I run a Quad Boot Menu. Windows XP Home, Windows 7 Home Premium, Windows 8.1 Pro and Windows 10 Pro. All 3 previous OS versions worked fine from the menu till I added the Windows 10 OS to that same menu. When restarting or rebooting FROM Windows 10 I found that the Realtek\Netgear GA311 Network Adaptor was being disabled or turned off by Windows 10 and then upon entering XP via the menu I had no connection. Funnily enough the versions W7 and W8.1 were fine after starting either OS via the menu and they restarted the connection to the adaptor. It seemed to have been caused by the most current driver in Windows 10 for the Realtek PCI GBE Family Controller - driver version 9.1.401.2015..it seems the older driver is a better choice in this instance.
I replaced the driver with the Windows 7 driver version 7.046.0610.2011 and XP had no further connection issues when starting it from my menu. As you can see the W7 driver is an older one but it cured the problem. I have always run a dual boot menu in the past with XP and Windows 7 so dual booting is something I have always done for the past 20 years back as far as window 95 and 98 etc.
I'm not sure if this info is of any use to anybody unless they have Windows 10 and XP using a dual boot menu plus that same Netgear GA311 Gigabit Ethernet Adaptor. (XP reports the adaptor correctly as a Netgear GA311 Gigabit Ethernet Adaptor while W7, W8.1 and W10 report it as a Realtek PCI GBE Family Controller.)
ps. The menu was created using the well known and respected EasyBCD 2.2