Ethernet Can't Obtain an IP Address from My Router

Page 1 of 3 123 LastLast

  1. Posts : 62
    Windows 10
       #1

    Ethernet Can't Obtain an IP Address from My Router


    Just recently, and seemingly out of the blue, my Windows 10 desktop PC's Ethernet adapter lost its ability to obtain an IP address from DHCP (i.e., from my router.) My PC's WiFi adapter has no such problem - only Ethernet has the problem.

    Here is a complete list of everything I have tried to solve the problem - nothing worked:

    * re-seated the Ethernet adapter
    * disabled and re-enabled the Ethernet adapter in the Network Connections control panel
    * uninstalled and re-installed the Ethernet adapter in Device Manager
    * re-booted the computer multiple times
    * power cycled my router and modem multiple times
    * used a different Ethernet cable
    * checked that the Ethernet adapter was using the most recent driver - see below
    * checked that my router had the latest firmware
    * assigned a static IP address in my router
    * plugged my Ethernet cable into a different Ethernet connector on my router
    * reset Winsock
    * removed 'hidden' network adapters from Device Manager
    * temporarily disabled my security software (Kaspersky)
    * restored a backup image from the day before the trouble first began

    Regarding drivers: Since my Ethernet adapter comes from Intel, I ran the Intel Driver & Support Assistant to "identify your products and get driver and software updates for most of your Intel hardware." The utility recognized my Ethernet adapter ("This device is working properly") but "Sorry, no software updates are available."

    Windows Event Viewer shows:

    "Your computer was not assigned an address from the network by the DHCP Server for [my Ethernet adapter.] The following error occurred: 0x79. Your computer will continue to try and obtain an address on its own from the network address (DHCP) server."

    I haven't yet found an explanation of error 0x79. (It's probably something generic.)

    Admittedly, my (Asus RT-N56U) router is several years old, and has not had a firmware update for several years. Still, it worked perfectly well with Ethernet until just a few days ago.

    One final test: I have a Chromebook (love it.) I ran the Ethernet cable from my router to an Ethernet-to-USB C adapter and plugged the USB C cable into my Chromebook. I had no trouble getting on the internet!

    So:
    * It's not the Ethernet adapter - it works fine when plugged directly into my modem.
    * It's not the Ethernet cable - it also works fine when plugged directly into my modem, and it works fine with my Chromebook.
    * It's not the router - it works fine when I connect it to my Chromebook.

    There's something about the combination of my Ethernet adapter and router that doesn't work ... the adapter can't get an IP address from the router.

    Now I'm really worn out. (And if you've read this far, you must be too.) WiFi works fine, but I would really like to find out why Ethernet stopped working. I am out of ideas so I'll be very grateful to hear your ideas.
      My Computer


  2. Posts : 1,604
    Win 10 home 20H2 19042.1110
       #2

    See this about error code 0X79 Solved: DHCP Error 0x79 - Help & Support Forums
      My Computers


  3. Posts : 6,916
    windows 10
       #3

    Set a static IP see if that works. It's possible it's your av as that runs a network adapter it's self disabling it won't stop the adaptor
      My Computer


  4. Posts : 62
    Windows 10
    Thread Starter
       #4

    Jacee said:
    Thanks very much for your help. The OP in the link you provided had previously setup a static IP address, whereas I have not done so. However, I may decide to experiment with a static IP address.

    - - - Updated - - -

    Samuria said:
    Set a static IP see if that works. It's possible it's your av as that runs a network adapter it's self disabling it won't stop the adaptor
    Thanks very much for your help. I'm going to experiment with a static IP address. At the moment, my Ethernet adapter has assigned itself an APIPA address (169.254. etc.) so I'll have to setup the static IP address in Windows and in my router.

    At the same time, I am quite interested in the possibility that my security software is what started the problem. The loss of connectivity happened 'out of the blue' and may possibly have been caused by an update to my security software.

    I'll keep the thread posted on results.
      My Computer


  5. Posts : 6,916
    windows 10
       #5

    Its their secure connection that gives problems and often it also sets a proxy https://support.kaspersky.com/13623
      My Computer


  6. Posts : 1,604
    Win 10 home 20H2 19042.1110
       #6

    I'll keep the thread posted on results.
    Thanks!
      My Computers


  7. Posts : 62
    Windows 10
    Thread Starter
       #7

    Regarding Kaspersky Internet Security: I posted a question in their community forum and am waiting for a reply. I do not use Kaspersky Secure Connection (their VPN) and it is not installed.

    My Ethernet adapter was only too happy to accept the static IP address I setup for it in my router, as you can see:

    Ethernet Can't Obtain an IP Address from My Router-capture1.png

    But it made no difference at all:

    Ethernet Can't Obtain an IP Address from My Router-capture2.png

    My Ethernet adapter absolutely refuses to connect to my router!
      My Computer


  8. Posts : 11,176
    Windows / Linux : Arch Linux
       #8

    Hi folks

    1) uninstall any AV software while trying to get the router to work.
    2) switch off any other devices temporarily -- sometimes a silly device or even a mobile phone has "grabbed" an IP address that DHCP thinks its assigned to your PC so no connection.
    3) Turn off any firewalls.
    4) re-boot the router
    5) Now see if you can connect to the router either via wireless or ethernet to its login page -- usually 192.168.0.1 or 192.168.1.1

    Set DHCP lease times as not to expire, check also if IVP4/IVP6 required and active. Some older gear won't support IPV6 addressing so you'll probably need both on your local LAN.
    check routers firewall / security that your devices aren't blocked etc and check also that WAN (connection to ISP) is working from the status line which should be in the routers menu.

    restart computer again and see if you have internet connection. If so then start other devices and add relevant level of security.

    Another test also is to boot up a Linux live distro --you don't need to understand Linux just boot it up from a USB stick and if the network connection is enabled then problem is in your Windows network somewhere.

    Usually switching off all devices for a short time (to the under 25's -- yes Mobile phones do actually have a power off switch on them !!!! probably never used by the majority !!) and resetting the DHCP lease times in the router usually works in these cases.

    BTW Netbios is deprecated these days --you shouldn't really need it if DHCP is doing its job properly -- but that's another issue.

    Cheers
    jimbo
      My Computer


  9. Posts : 8,632
    Mac OS Catalina
       #9

    Uninstall everything Kaspersky, uninstall the Network device and driver then reboot. Use the Kavremover tool from Kaspersky to git rid of it. https://support.kaspersky.com/common/uninstall/1464. Once you reboot, you will run this tool Download NetAdapter Repair All In One. Also reset your router to clear out IPTables and try a different cable and port on the router.
      My Computer


  10. Posts : 62
    Windows 10
    Thread Starter
       #10

    I really appreciate everyone's ideas!

    I'm working through the suggestions, and here's an update:

    I removed my Kaspersky software using Kaspersky's own uninstaller (kavremover.) This did not solve the problem, unfortunately.

    Next step: Restoring my router to default settings.

    - - - Updated - - -

    I performed two final steps:

    I booted my computer from a live Linux distro; Linux detected my Ethernet controller but could not obtain an IP address for it from DHCP (demonstrating that the problem is not caused by Windows.)

    I reset my modem to factory defaults - no help.

    Therefore, it seems very clear to me that my problem - I am unable to obtain an IP address for an Ethernet connection - can only be caused by the router hardware. My router is 7 years old, and nothing lasts forever ... I accept that. Still, it does seem mysterious to me. My router consists entirely of electrical components - there's nothing to wear out or break. As long as I don't abuse it, it should probably last forever and the only reason I would have to replace it is because newer equipment is so much better.

    My final step was to contact the router manufacturer (ASUS) who assigned me a case number. I can't imagine what incentive they have to assist me with a 7-year old router, but I'll give it a shot.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:51.
Find Us




Windows 10 Forums