Can only connect one way on networking


  1. Posts : 28
    Windows 10
       #1

    Can only connect one way on networking


    [EDIT : See very bottom update 3 for my solution, however I would still be interested to hear from people to know why this happened]

    Okay, an interesting situation here. Up until recently I could connect via my ethernet networking fine, between 2 PCs, both ways. Both my PCs recently upgraded to 1903, approx 1 week apart. I have zero idea if it is coincidence, but now I can only access one of the PCs, not the other way around. So for instance I have a Ryzen and Intel PC, I can now connect to the Ryzen fine, but the Ryzen can not connect to my Intel. Yet last week everything was fine. Whether the update is relevant or not I am unsure, as it worked okay when one was updated. I can ping both PCs IP address fine from each other.

    I have checked all IP4 / IP6 settings, all are set to automatic, etc. I have been through most guides online. I have also rebooted my router and waited 10 seconds, I have also reset both PCs multiple times. I have disabled firewalls on both PCs (they both use ESET). The Intel PC is Windows 10 Pro and the Ryzen is Windows 10 Home. Both via 1gbps wired ethernet. Ryzen PC is Realtek NIC and Intel PC is Intel NIC. I have tried ipconfig/ flushdns and ipconfig /renewdns and ipconfig/ registerdns to no help.

    Now here is the interesting bit, if I use the ipconfig /release command on the Ryzen PC then I can suddenly access the Intel PC fine, as though it suddenly unlocks, BUT, it disconnects me from the internet and up comes the "no connection" world grid icon in the tasktray (which used to be the monitor and exclamation mark on older windows versions) and says "Unidentified Network". If I ask windows to rectify the problem using the network troubleshooter, it then gets me back to the normal network (upon fixing it says "Ethernet doesn't have a valid IP configuration - Fixed *green tick*"), but it then stops me accessing the Intel PC on the network again. I have no idea what this means. Oh and just to mess with my mind more, when I use the /release command on the Ryzen PC I can now no longer access the Ryzen PC from the Intel PC (like I normally can) until I rectify the issue on the Ryzen with the network troubleshooter (which then as mentioned stops me accessing the Intel PC again, arggghhhh).

    Not sure if this is related but my Epson wireless printer beeped at me at 4am last night saying "IP already in use" on the small LCD printer screen, not sure why. Also yesterday afternoon I was having internet speed issues so I tried another router modem I had in the shed as a spare and also tried the 2nd NIC (atheros) on my Intel PC motherboard. However I changed back to my existing router and the Intel NIC within minutes when I noticed the speed wasn't helped, so was purely a temporary change which shouldn't have altered anything as everything went back to how it was.

    Any ideas ? Thanks.

    EDIT UPDATE : So I downloaded some software called Advance IP Scanner and ran it on the Ryzen PC (the one that can see the Intel PC name but can't connect to or see the shared drives), I scanned the network and it found the Intel PC okay and when I clicked on the IP of the PC it managed to connect to the shared drives fine, so in the Network section of File Explorer I now have the direct IP of the computer, which connects fine, and the name of the computer "IntelPC" which still doesn't connect. Weird, very odd. Do I presume this is all PC name related even though both PCs are within Workgroup and the names check out okay ?

    UPDATE 2 : So I decided to ping the PC name instead of the IP, and for some reason when I ping the PC name it is unreachable but it also seems to be directing to the wrong IP address. It is going for one that ends in 107 instead 109. So this seems to be a case of the Ryzen Windows looking for the wrong IP address when trying to access the PC name, which is why connecting to IP shows the Intel shared folders, but just an error when connecting to the PC name. Any ideas ?

    UPDATE 3 : So when I went to the WINS section of the IP4 in Windows I changed it from default for the NetBIOS to Enabled, and reset my PC and now everything works. Also I realised I could probably change the Hosts file to manually make the name go to the correct IP if needed, however I have not tried that yet given the NetBios option seemed to do the trick. No idea why changing from default to Enabled made any difference though. Phew, I just hope it stays working !!!
    Last edited by BlizzardUK; 4 Weeks Ago at 01:40.
      My ComputerSystem Spec


 

Related Threads
Networking How to in Network and Sharing
I am finding so much conflicting information about Windows 10. I had no problems with Win 7 and Work Group. I will not use Home Group so don't even bring that up. Reading about conflicts with Home Group services causing problems with Work Groups. ...
Hello, I am trying to use the new Windows 10 Connect App. I have a Window 10 PC and tablet, both on the latest AU build. I also have a phone with Window 10 Mobile. On the PC, I connect to my Wifi network, ensure settings are setup...
Ok, just upgraded to Windows 10 this week and been bashing my head bloody for two days on networking issues. What on the green Earth are my networking credentials in Win10? I have a Microsoft account I'm logging into Win10 pc with (which I hate but...
I know I am getting on everyone's nerves with all of these posts, but this is my only way to get things resolved. Safe Mode with Networking: Networking doesn't work. Any help or suggestions would be appreciated!
My windows 2003 server stopped working in normal mode, but working in "safe mode with networking" and giving reply from all peers, and reaching all remote locations. in Normal mode not even ping to peer and giving error "destination host...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:52.
Find Us