Windows 10: Can't reliably access my router setup screen after W10 Solved

Page 1 of 2 12 LastLast
  1.    07 Aug 2015 #1

    Can't reliably access my router setup screen after W10


    I have three computers wired to my D-Link DSL-504T modem/router.

    Since upgrading two of my PCs to Widows 10 Pro (activated, clean install) I can no longer get reliable access to my routers configuration screen (192.168.1.1) through these PCs, although my third computer that is still running WinXP has no problem at all. Internet access on all three computers is unaffected and works perfectly.

    The two W10 computers get to the router login screen, accept my username and password and then try and display the next status page whereupon the following happens:

    Firefox: Stops with 'The connection was reset' error
    Edge and Internet Explorer: Sit waiting forever (or as long as I'm prepared to wait!)
    Chrome: Occasionally displays part of the status page, but mostly just sits there waiting.

    The WinXP PC just sails along, displaying every page instantly and putting two fingers up to its more modern brethren!

    I've reset the router and that makes no difference. I've turned off the Windows firewall and that makes no difference. It can't be my AV software (NOD32) as that is only running on one of the W10 PCs. I've flushed the DNS and tried just about everything I can think of and still the two W10 machines fail.

    A google search reveals that other people have experienced this problem with other OS's, but no-one has come up with a definitive solution and all the many suggestions that I've tried have made not the slightest difference.

    Any of you wise people have any ideas? Pretty please!

    Tim
      My System SpecsSystem Spec


  2. Posts : 22
    Win 7 x86_64 Enterprise, Win 10 Pro
       07 Aug 2015 #2

    Hey there,

    two fast ideas:

    a) Have you tried setting a static IP (same subnet as router) and then trying to acces the router again?
    b) Is your network a private or public network? Win10 seems to like defaulting networks to public, maybe there are some bugs (you surely saw all the threads and posts about "no connection"). I would try to change it to private and try it again.
      My System SpecsSystem Spec

  3.    07 Aug 2015 #3

    Thanks for the suggestions Skalli.

    Same problem with a static address .

    My network profile if PUBLIC... not too sure how to force it to PRIVATE (I've refrained from setting up a Homegroup/Workgroup or sharing any devices until this problem is sorted).

    Tim
      My System SpecsSystem Spec

  4.    08 Aug 2015 #4

    Well I set up a Homegroup which changed my network profile from PUBLIC to PRIVATE but still no luck.

    What's so weird is that the opening login screen of my router setup loads instantly and correctly and the fields accept my username and password (which at the moment are the default admin/admin), but it won't progress any further.

    It's as if something is stopping the script from running. I've changed all manner of permissions and what-not but still the problem persists...

    It's doing my head in!

    Tim
      My System SpecsSystem Spec

  5.    14 Aug 2015 #5

    same problem
    d link 2540 t
    can not open some setting page
    router runing good
    from any pc log in without any problem
    jsut pc run with win10
    in ie 11 blank page
    in google chrome some page run
    but some pages no like status and wan setting
    please helpppppppppppppppp
      My System SpecsSystem Spec

  6.    15 Aug 2015 #6

    Sorry man, can't help!

    The problem still exists with my system and nothing I try resolves the issue.

    Contacting D-Link was a waste of time... same old "you've forgotten your password" (I haven't) / "reset you router" (I have).

    Tim
      My System SpecsSystem Spec

  7.    21 Aug 2015 #7

    emailing d link 2 time no answr
    try many amny option no way
    no body have idea
    only wan setting page not working (chrome)
    ie 11 all seting pages not loaded
      My System SpecsSystem Spec

  8.    22 Aug 2015 #8

    I believe dlink routers require java enabled browsers, so maybe check if java plugin is working properly in your browsers.
      My System SpecsSystem Spec

  9.    22 Aug 2015 #9

    sciencegeek said: View Post
    I believe dlink routers require java enabled browsers, so maybe check if java plugin is working properly in your browsers.
    thank you
    yes try both 32 and 64 java plug in
    it work fine with many site base on java
    only this pag which load wan setting

    just can read page no update values
    os setting

    any anothe idea please
    thank for response
      My System SpecsSystem Spec

  10.    23 Aug 2015 #10

    Man, at least you're able to access some of your setup pages . Both my W10 systems still wont get beyond the login screen (well, they try to draw and display the next page, but fail in the process).

    I too have the Java plugin installed but I'm assured by D-Link that it's unnecessary and not required to run the router setup scripts.

    Head-scrathching....

    Tim
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I did an in-place upgrade from Win 7 Ultimate to 10 Pro with no apparent problems...at least until my wife tried to watch Netflix on our wi-fi connected Roku. My computer is connected to my router with an ethernet cable. There is no wi-fi...
Hello everyone, I use the window snapping feature a lot, but mainly for maximizing windows. I have a dual screen setup and when I drag a window along the top edge of the screen onto the second screen, it becomes stuck. This is very annoying,...
Black screen while in Windows 10 setup in Installation and Upgrade
I was in Windows 10 setup using the Media tool. I have reached the step where it restarted then a big circle came up with three parts under saying like "Copying Files" and other two things. Then, suddenly it restarted and only a black screen was...
Router Extender in Network and Sharing
I am going to upgrade to Windows 10 in the near future. I am in need of a WiFi extender. Does it make any difference on the OS? Compatible with Windows 10? Thanks in advance.
Try to use Spartan browser on Win10 build 10056 to access my home Router but unfortunately it canot pop up the login page.so I cannot do any configuration with my router when use Spartan browser. does anyone meet the same problem? thanks.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:43.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums