Cannot find and delete share


  1. Posts : 23
    Windows 10 Pro 64 bit
       #1

    Cannot find and delete share


    This is a strange problem. I have two Win 10 Pro 1903 PCs on my home network. The first is a laptop named Bill4. The second is a desktop named Desktop2. Both are logged into my Microsoft account. On Desktop2 in File Explorer under This PC is an entry labeled C on Bill4. Clicking on this entry does provide full access to the root of C: on Bill4. This entry is not a mapped drive because it has no drive letter assigned and when I right click there is no Disconnect entry.



    1) How do I remove the C on Bill4 entry from File Explorer in Desktop2.



    The second problem is that the C: drive on Bill4 is not shared. Therefore, I do not understand how Desktop2 can have any access to the C: drive on Bill4. The Sharing tab in the Properties dialog for C: on Bill4 shows that the drive is not shared. In File Explorer on Desktop2 expanding the Network entry shows Bill4 but double clicking the Bill4 entry does not show any shared resources on Bill4.



    2) How can I find the setting on Bill4 that allows Desktop2 to have access to the root of C: on Bill4 and disable it. This must be fixed since it is a huge security hole. Deleting the admin share C$ did not help.



    I have had both Bill4 and Desktop2 for a long time. Both originally came with Win 7 Pro and have been upgraded over the years to Win 10 Pro 1903. I am sure that I created this problem sometime in the far past, probably when both machines were running Win 7 Pro, but I don't know how or when. Desktop2 has been unused for several years and I just set it up as a file and media server and discovered the problem. I don't know what to do next to solve the problem so any help or suggestions will be appreciated. I have tried to provide a detailed explanation but pleas ask questions if I have not been clear. Thanks.
      My Computer


  2. Posts : 8,131
    windows 10
       #2

    Open a cmd prompt type

    net share

    That wil w you what shares are set do it on all pcs
      My Computer


  3. Posts : 23
    Windows 10 Pro 64 bit
    Thread Starter
       #3

    net share shows C$ even though I deleted it earlier today in Computer Management. I deleted it again using
    net share C$ /delete but I can still access the root of C: on Bill4 from Desktop2 using the C on Bill4 entry in Explorer.
      My Computer


  4. Posts : 8,131
    windows 10
       #4

    If your logged in on both pcs with the same account it will know it you test with another account thats not on the target pc
      My Computer


  5. Posts : 23
    Windows 10 Pro 64 bit
    Thread Starter
       #5

    This is really embarrassing. Desktop2 is headless so I was using Remote Desktop and my local C: drive was shared in Remote Desktop. I just thought of that. Problem solved. Thanks for your response.
      My Computer


  6. Posts : 265
    Windows 10 Enterprise
       #6

    I love it when the light bulb turns on...I just wish it would do it before we asked for help! LOL! Glad you resolved your issue.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:39.
Find Us




Windows 10 Forums