WIN 1903 REMOTE DESKTOP FAILS. Works fine in 1809 Solved


  1. Posts : 9
    Windows 10 Enterprise x64
       #1

    WIN 1903 REMOTE DESKTOP FAILS. Works fine in 1809


    Hi folks,

    I need some help/guidance.

    I have a home network with 8 workstation/PC's and two domain controllers. All but one of the PC's are at 1903 and the DC's are Server 2012 R2.


    I RDP from my desk into 4 of the PC's which are headless. It has always worked flawlessly.... until now.

    The PC's are fairly old. One of the PC's, after upgrading (upgrade was offered by MS!) from 1809 to 1903, locked up when I RDP'd into it (from my 1903 machine). I read somewhere that this was a known issue with certain older onboard video chipsets. This particular machine used G43/G45 Express Chipset onboard video . . . and that was supposedly one of the offending chipsets. So, I installed an Nvidia 1050 video card with 1903 approved drivers in the PC (first I restored 1809... then re-upgraded to 1903). I also disabled the onboard video in bios. Windows 1903 ran just fine...…. until I RDP'd in... same problem... box locks up after a short period of time. Requires hard reset. As long as I don't RDP in, the PC runs 1903 just fine.

    What am I missing here? When I RDP into the PC, is it using some other RDP video driver that is still "bad" in 1903? I did also try deleting the G43/G45 device in device manager and using generic PC video and that DID work.... but every time I rebooted, it re-loaded the G43/G45 device-drivers (that's when I went the Nvidia route). I have upgraded and then downgraded back to 1809 three times in the last month hoping some driver got updated.... no luck.

    Any advice is appreciated.

    Charlie
      My ComputerSystem Spec

  2.    #2

    Exact same issue. I also need advice.
      My ComputerSystem Spec


  3. Posts : 9
    Windows 10 Enterprise x64
    Thread Starter
       #3

    Problem solved!

    As you might recall installing 1903 (WIN 10) on an older PC with certain chipsets resulted in a black screen while using RDP. This is a known issue, discussed by Microsoft as late as July 12th and still awaiting the fix (promised for July-August). The black screen issue has to do with a new display driver (WDDM) used in 1903. The “fix” forces the old XDDM driver to be used. From what I understand it isn’t just the display adapter that causes the issue with affected chipsets, so putting a new video card in the machine won’t help (and it didn’t for me).



    Easy fix! Use GPO to force use of XDDM rather than WDDM. In Group Policy Editor under Remote Desktop Session Host -> Remote Session Environment ... set the policy “Use WDDM graphics display driver for Remote Desktop Connections” to DISABLED.


    Worked for me on three machines. No side affects that I see. Once MS issues an update you can reverse the fix and use WDDM.
      My ComputerSystem Spec

  4.    #4

    Blogged about this yesterday. It's a known issue for some older graphics circuitry, especially integrated GPUs. See Win10 1903 RDP Connection May Provoke Black Screen – Win10.Guru. Also, see this other TF thread on the same topic for some interesting potential fixes: Remote Desktop broken on Windows 10 1903, but only on one PC....
    HTH,
    --Ed--
      My ComputersSystem Spec


 

Related Threads
Basically I have a headless Windows 10 server that I use RDP to access. Up until 1903's installation it's been fine but after installing 1903 I was only able to log into a black screen with a cursor until the system forcibly disconnects. I tried a...
1903.116 remote desktop problems in Network and Sharing
All computers are same specs: HP Elite 8000 4GB RAM - with SSD. Client machines that I'm having problems with are both running WIN10 1903.116. (Fresh install not Upgrade) If I try and RDP (over VPN or LAN) to computer I get a connection, can...
Remote desktop connection fails due to authentication error “CredSSP encryption oracle remediation", I couldn’t figure out why I’m getting the message in the screenshot below as I applied “Remote desktop connection”. The resources and...
Hi folks. I've been noticing that RDP is a toss up on my Windows 10 machines. It hangs and I have to close the connection, then try again and get an error stating it's not available because it's busy, then try a third time after a few minutes and...
Hi there After "de-regionalising" and decrypting DVD's / Blu Ray's I convert these to MKV for my media servers. Handbrake on latest W10 build seems to miss some episodes when trying to encode DVD's with multiple episodes. I've used Handbrake for...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:57.
Find Us