OK this one is driving me crazy.

I have an acer laptop with built in wifi. I purchased a USB wifi adapter which looked like an upgrade.
I plugged it in and attempted to connect to my home wireless network (this was working as recently as yesterday). I keep getting the "can't connect". This laptop will connect to my phone when I turn on the hot spot and other devices in the house can connect to the home wireless network. It almost seems like for whatever reason that particular home network has become "corrupted" for lack of a better term, on my laptop.

Things I have tried that have not worked:

Removed the new USB wifi adapter and gone back to the one in the laptop that worked yesterday.
Selected to forget the network and then attempted to reconnect to it fresh.
Uninstalled the network adapter and rebooted.
Rebooted the wireless router ATT gateway
Changed network adapter drivers.

It is really odd that this is the only network it can't connect to where as every other device in the house can and the laptop connects fine to other wifi hot spots? Could there be some other location where that network info is stored in Win 10 and could be "corrupted" or something that I can delete? It almost seems like me plugging in that new USB wifi adapter somehow did something that messed everything up? Or maybe just a coincidence?

- - - Updated - - -

I have since gotten the new USB Wifi adapter to work. Unsure what specifically I did. It came with its own app for wifi connections. I killed that and just used the native Win 10. Maybe there was some contention.