Cannot access any secure sites with my mobile hotspot Solved

  1.    #1

    Cannot access any secure sites with my mobile hotspot

    I don't know what happened suddenly, my WiFi stopped working and I was unable to visit any secured sites. I tried to connect to other WiFi and it worked and I was able to visit secured websites! I tried pinging Google and results were good(got the output).

    I had recently installed Kali Linux(dual boot). I thought that could have caused the problem, actually it all started after installing the Kali Linux, when I went back to Windows 10 I was unable to search secure sites with my own mobile hotspot!

    I can search and visit every secured and unsecured websites through my mobile. Even other devices(mobiles) connected to my mobile hotspot can access secured and unsecured websites but my PC can't

    I used VPN and I was able to visit secured websites. But that's the temporary solution, I think it's related to DNS but didn't know what really is causing it!

    I don't know if there is any relation between this or not but:
    I even bought a WiFi adapter after installing Kali Linux (dual boot) at the time of buying the adapter there was no problem surfing the internet. I tried to install the driver in Kali Linux and led to error so I returned it. Maybe I was installing it in the wrong way.

    I tried changing the settings in network adapter settings. This is not the problem of WiFi driver as I can search with other WiFi's.

    Any help will be appreciated!
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 14,309
    Windows 10 Pro x64 Build 1809

    Hi Just A Noob. Welcome to the TenForums @Just a Noob

    I would run these commands in Windows and see if it clears.

    Run the following five bolded commands. Use a Command Prompt(admin) or Powershell(admin)

    Do not key in info in brackets, there for your information.

    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refresh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    netsh interface ip delete arpcache (reset Address Resolution Protocol cache)

      My ComputerSystem Spec

  3.    #3

    Thanks for the help!

    But it didn't work out!
    When I turn on VPN I can search every single website I want to visit!

    The problem vanished as I reset the phone! I connected my laptop to my mobile hotspot and it worked, so the next morning I tried to connect again but i started facing the same problem as before!

    It gets stuck on connecting secure connection!
    Is there any option that I may be hacked or something like that!

    If I can't establish secure connection that means the private key is not reaching the server or isn't reaching me! I think it's something like man in the middle attack! I don't know exactly, I am just guessing!
    BTW thanks for the help!
      My ComputerSystem Spec

  4. Caledon Ken's Avatar
    Posts : 14,309
    Windows 10 Pro x64 Build 1809

    Not sure if this is a windows error or a phone error.

    You said you reset phone and it worked.

    Then it stopped working. I assume you had disconnected from hotspot and then reconnected.

    Did you use VPN after it worked. Maybe it is setting up condition.

    Think it would be worth doing more analysis to determine where / what is causing problem.

    Might reset phone and try see if it works. If so disconnect from hotspot and then reconnect. Is it still working? ( above you said next morning). On my iPhone I can reset just network components, do you have such an option.

    Can you connect another device to hotspot when it is not working and see results. Maybe a friends laptop.
      My ComputerSystem Spec

  5.    #5

    Thanks, but the problem is solved now!
    I changed my APN protocol to IPV4 in APN settings! (It was IPV4/IPV6). And everything worked like a charm!
    Thanks by the way for helping! Got to know many things!
    Thank you for helping!
      My ComputerSystem Spec

  6. Caledon Ken's Avatar
    Posts : 14,309
    Windows 10 Pro x64 Build 1809

    Glad you got sorted. Please mark your thread solved.
      My ComputerSystem Spec


Related Threads
I may have some incorrect windows 10 security settings I am experiencing problems on some secure sites (but not all) that require login with password. They fail to log me in with my credentials using Chrome, but when I try the same with e.g. Edge I...
When I use wifi on my PC to connect to my router/modem, internet works fine. But when I connect to my Android phone's access point (tethering) I don't get internet access. You might think it's a problem with the Android phone, but other Android...
How to Turn On or Off Mobile Hotspot on a Windows 10 Mobile Phone You can create a mobile hotspot with your Windows 10 Mobile phone to share your cellular data connection with other devices. This tutorial will show you how to setup and turn...
OK, I'm on the second day of this. I CANNOT connect to any secure site, nor can the built-in stuff like signing into my Microsoft account, using the Media Creation Tool or anything that would go through an HTTPS connection. I CAN get to Windows...
I have a 1 year old i5 desktop on that I upgraded from Win 7 to 10 a week ago. Ever since I have been unable to land secure sites (https) “Establishing secure connection” or others that just sit on or “Waiting for” or “Waiting...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:14.
Find Us