Unable to see networked devices but can on other machines

  1.    #1

    Unable to see networked devices but can on other machines


    Hi all!

    I wouldn't normally ask for help as I'm usually pretty damned good at sorting issues myself but this has got me stumped.

    I've got 2 PC's and a laptop. Laptop behaves the same way as PC2 so I'll discount that for now.

    The issue:

    PC1 appears to have an issue with the network in that it cannot see (many) devices and cannot be accessed by devices.

    PC1 1809 when browsing the network can only see itself and PC2. It's on 1.3
    PC2 1803 when browsing the network can see everything, routers, NAS, laptop and PC1

    If PC2 tries to view shares on PC1 I get a 'network path is not found' error
    If PC1 tries to view shares on PC2, it works fine.

    If I ping PC1 from PC2 I can ping both by name and IP address so it is visible on the network.

    I've done the usual, reset network, reset IP, reset firewall, reset everything of reasonable importance and likewise, disabled firewall, turned off password protected sharing. Enabled all relevant services for file browsing, upnp, dns and so on.

    Presently, I'm pulling my hair out and short of flattening the whole machine and starting again, which I really don't want to do, I'm lost for ideas!

    Thanks so much in advance!
      My ComputerSystem Spec

  2.    #2

    I have the same problem and it constantly comes and goes. Yesterday this computer would only see 1 out of 5 computers on the work group. Today it sees them all. One of the others saw all of them an hour ago and now sees 3. All the windows 10 machines do the same thing. The 1 Vista computer can see them all every day. I've been fighting with this since windows 10 came along.
      My ComputerSystem Spec

  3.    #3

    Run this on all pcs NetBScanner - NetBIOS scanner can they all be seen and note the master browser this scan will often kick it back into life
      My ComputerSystem Spec

  4.    #4

    Thank you Samuria. I will try that.
      My ComputerSystem Spec

  5. Compumind's Avatar
    Posts : 736
    Windows 10 Pro x64, Various Linux Builds, Internet Security Specialty.
       #5
      My ComputerSystem Spec

  6.    #6

    Yeah forgot to mention I've tried NetBIOS scanner and PC1 could not be seen.

    I had a bit more of a play around last night, disabled PC1 masterbrowser and a few windows updates and it seems to have sorted itself out.
      My ComputerSystem Spec

  7.    #7

    dazmatic said: View Post
    Yeah forgot to mention I've tried NetBIOS scanner and PC1 could not be seen.

    I had a bit more of a play around last night, disabled PC1 masterbrowser and a few windows updates and it seems to have sorted itself out.
    Ok, that was a Lie. PC1 can now see the entire network so at least network discovery is working.

    PC2 and the laptop however cannot access PC1's shares. PC1 has a label printer and various shares and when trying to open it I get a 0x80070035 Network path was not found error.

    Adding PC1 details to the hosts file doesn't appear to work.
    Netbios is enabled too

    So a little bit more work to be done it would seem.
    Last edited by dazmatic; 2 Weeks Ago at 03:25.
      My ComputerSystem Spec

  8. jimbo45's Avatar
    Posts : 6,740
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #8

    Hi there
    @Samuria

    That piece of software doesn't work on my system !!! (current W10 with latest fixes) -- I don't have problems seeing Network - in this case 2 computers, 1 Windows and one NAS (linux) both physical (not Virtual) machines but was just testing the software

    Click image for larger version. 

Name:	nwj.png 
Views:	1 
Size:	186.2 KB 
ID:	225646

    Problem with the software might be that it expects Windows to be the local master browser and not the Linux NAS system.

    Click image for larger version. 

Name:	snapshot2.png 
Views:	1 
Size:	443.7 KB 
ID:	225647

    cheers
    jimbo
      My ComputerSystem Spec

  9.    #9

    Master browser was broken in 1709, worked in 1803, broken again in 1809. If you have a fairly recent model router, pop a thumb drive in it and configure the router to share it. That will start the router's samba server which can provide a master browser. Then disallow the master browser on all your Windows machines so the router is always master browser. Use the registry tweak below. After that you'll have reliable network browsing.
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
    "MaintainServerList"="No"
    There's some other things that can give you trouble as well. Enable smb1 client and server in features under control panel programs and features. Check Function Discovery Resource Publication service is set to auto start.

    For some background on why these issues are happening, MS wants to deprecate smb1 for smb2 because it's "not secure". Unfortunately they want to take network browsing with it requiring users to enter specific network paths. Network browsing is a pretty critical capability for a lot of people, including myself. Fortunately we can undo that nonsense for now. Hopefully MS will see the error of their ways and deal with it in a way that does not kill off network browsing.
    Last edited by CraigHB; 2 Weeks Ago at 07:56.
      My ComputerSystem Spec

  10.    #10

    CraigHB said: View Post
    Master browser was broken in 1709, worked in 1803, broken again in 1809. If you have a fairly recent model router, pop a thumb drive in it and configure the router to share it. That will start the router's samba server which can provide a master browser. Then disallow the master browser on all your Windows machines so the router is always master browser. Use the registry tweak below. After that you'll have reliable network browsing.
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
    "MaintainServerList"="No"
    I've done that on both machines and no luck, did it before you mentioned it but thanks nonetheless.

    It's a weird thing. I can open C:/users on PC1, but when I open PC1 in network browser to then open users, the shared folder, I can't access it, network path cannot be found.

    A sharing issue maybe? network sharing is enabled but doesn't appear to be working.
      My ComputerSystem Spec


 

Related Threads
unable to access any lan devices in Network and Sharing
I am running windows 10. I am not able to reach any lan devices, for example, the pihole website, or ping my gateway. I temporarily turned off windows firewall, which did not help. It seems that other devices on the network are able to see the...
I recently installed (3) new Windows 10 workstations at an office that is using Workgroup. The new PC's are Dell Optiplex 3050's and the Network and Sharing Center shows as Private network. All of the other PC's are Windows 7 64bit and their...
I recently installed Windows 10 on a laptop. I have a bunch of computers on the network to include a WD MyCloud and a shared printer. The Win 10 computer can 'see' the devices in Network file explorer. When I attempt to open a computer or the...
I have two Windows 10 PCs (call them PC-A and PC-B) on a hard-wired home network which includes two DLNA devices, a music player and a TV. Both PCs were recently upgraded from Windows 7 Ultimate x64 to Windows 10 Pro x64 and both are set up to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:48.
Find Us