Can't copy files to network usb drive


  1. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
       #1

    Can't copy files to network usb drive


    I can't copy files to network usb drive. I can copy from the network drive to the computer. Plus I can't make a new folder in windows 10 too on the network drive. It is almost like the drive is in like ready only state in windows 10.

    I have no problems with windows 7. I can copy and paste all day long. Plus I connected another windows 7 computer no problems.

    In windows 7 the drive shows up in the network as readyshare. In windows 10 it shows up in This pc and is name ReadyDLNA:R6250. There is nothing on the Network page.

    I have one computer that is windows 7 & one that is windows 10. Now could that be a problem? I even reset the network to the default settings just to make sure and it is the same.
      My Computer

  2. Bree's Avatar
    Posts : 22,032
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #2

    For the benefit of other readers, Readyshare is a feature of a Netgear router that allows sharing of a usb drive that's plugged into the router.

    ReadySHARE: Your Router Can Do Everything | NETGEAR

    The 'ReadyDLNA' you see is most likely intended for media streaming, an optional feature of Readyshare.

    DLNA stands for Digital Living Network Alliance, the trade group founded by Sony in 2003 to define the interoperability guidelines...
    How to use DLNA | TechHive


    @dmdilks, I too have a usb HDD shared on my router (though not a Netgear). My router only supports the SMB1 protocol so I have to enable it in Win10 to be able to see and connect. Looks like your Netgear may need you to use SMB1 too. In Win7 SMB1 is enabled by default, which may be why it can connect without problems.


    Can't copy files to network usb drive-smb1-client.png


    This thread in the Netgear Community suggests that you need to enable the SMB1 client on the Win10 PC, as I have had to do in the screenshot above.

    Solved: SMBv1 disabled - Readyshare unavailable - NETGEAR Communities
    Last edited by Bree; 02 Feb 2019 at 19:24. Reason: added screenshot
      My Computers


  3. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
    Thread Starter
       #3

    I have no problem see or getting to the drive. It is that I can't copy to the drive.

    All these have a check mark in the box

    SMB 1.0/cifs File sharing support
    SMB 1.0/cifs Client
    SMB 1.0/cifs Server

    Plus I setup everything on the windows 10 computer first before I did everything from the windows 7 computer. When I first connected the drive to the router it didn't see it. I then connected it to the windows 10 computer and formatted it. Then it seen the drive through the router.

    The only problem I'm having is that I can't copy to it from the windows 10.
      My Computer

  4. Bree's Avatar
    Posts : 22,032
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #4

    Sounds like a permissions problem but as I said, I don't have a Netgear router. Let's hope someone with a Netgear will join the thread and offer advice.
      My Computers


  5. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
    Thread Starter
       #5

    I just tried another computer with windows 10 on it. Just to make sure it wasn't something with windows 10 on the computer. I'm going to try to do some research on that router using windows 10.
      My Computer


  6. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
    Thread Starter
       #6

    Ok did some research and found the problem. It is windows 10 pro that is the problem. You ready for this I connected my Laptop that has windows 10 home on it and everything works great.

    I'm working on a new build to replace that computer and it will have windows 10 home on it. Now why doesn't Pro work with it. It should really be the other way around you would think.

    Netgear Readyshare Solved - Page 2 - Windows 10 Forums
      My Computer


  7. Bree's Avatar
    Posts : 22,032
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #7

    dmdilks said:
    Now why doesn't Pro work with it. It should really be the other way around you would think.
    Do you have Pro version 1809 and do you use Hyper-V? If so, what build is it?

    I have experienced problems in 1809 Pro copying TO a network share (but not FROM one). This was a networking problem in the Hyper-V WiFi network switch. While the host machine worked perfectly on the Internet and with two-way communication with its VMs, the host machine couldn't write to shares on other physical machines on the network (but it could read from them perfectly). With Hyper-V removed it had no problems though.

    This problem only occurred after I upgraded from 1803 to 1809 and was fixed in 1809 build 17763.194, the December 11th cumulative update.

    Bree said:
    I have just tried upgrading that machine again now that 17763.194 is out. This build seems to have fixed the virtual switch issue for me...
    Windows 10 October 2018 Update version 1809 Now Re-Released - Page 79 - Windows 10 Forums
      My Computers


  8. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
    Thread Starter
       #8

    I'm running 1803 on that computer. The reason for that is that computer is a work computer. So with that I shouldn't be having any problems. It is only used when I need something when I'm working on another computer. Most of the time it sits in sleep mode.

    Hyper-V WiFi network switch
    The computer is hard wire and not using WiFi.

    Let me check with a another computer that has 1809 and is up to date. Plus I did run another with build 11763.292 and same thing. Plus all computers are not running Hyper-V too.

    Plus on the laptop If I try to run it wireless it does the same thing as Pro. If hardwire it runs fine no problems. So at this point I'm going to install Home 10 on the new build. Plus I'm not going to jump hoops to make it work too.

    Everything working the way it should Hyper-V disabled, SMB 1.0/cifs File sharing support, SMB 1.0/cifs Client are set right, & windows credentials are setup. With home all I have to do is plug in the network cable and I'm good to go.

    Plus I have always said from the start Windows 10 is still in Beta Mode and it will be till they come out with something new. If you can think of anything else I'll try it.
      My Computer


  9. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
    Thread Starter
       #9

    Well i got my new machine up and running with Home and everything is working great. Thanks for the help too. Plus one of these days I will try windows 10 pro again and figure it out why I can't do with Pro.
      My Computer


  10. Posts : 24
    Win 7 Ult-64 bit / Windows 10 Pro 64 bit
    Thread Starter
       #10

    I went over to the Microsoft Community. To see if somebody over there had anything that would help. I did find a link that maybe it could help. Well it didn't really change anything.

    Ok I followed the steps on that link "See this thread for further tips:" I did #1 first nothing change. Then I did #2 went into control panel to programs & features. In there I click on turn on or off features. Went down to SMB and found them all uncheck. Put a check mark in all of them and everything works.


    #1

    All PC's: Set Start type to Automatic and start following services that allow PC's to be visible on Network. (Reboot.)

    Push Win Key and type "Services", locate these services.
    - Function Discovery Provider Host
    - Function Discovery Resource Publication
    - SSDP Discovery
    - UPnP Device Host

    #2

    Scroll down to SMB 1.0/CIFS File Sharing Support
    Tick the SMB 1.0/CIFS Client
    Untick SMB 1.0/CIFS Automatic Removal and
    Untick SMB 1.0/CIFS Server

    Now the thing is I done another computer with windows 10 pro. with everything with check marks on the SMB and it didn't work. So I thought that maybe it was because I had change the settings on the 4 services. I thought that maybe it made it so it could work.

    On the machine I was doing all these changes on I went back into services and set all 4 back to manual. That didn't make a difference. It still work with them set to manual. Now I'm still not happy because the other computer I first tried with windows 10 pro. It had all the SMB's with check marks and didn't work. So I'm going to go back to the computer and do some playing around. To see if I can get that one to work too.

    I went back to that one and again everything was check on the SMB. So I thought that I would uncheck them rebooted and check the network still the same nothing. So I went back in and put the check marks back on all the SMB's. Rebooted and this time everything showed up on the network. Why I don't know???? But now everything works on both Home & Pro no matter what computer I use.

    So with the old computer there could have been something on there stopping it to connect right. The SSD had seen a lot of different computers over the years and many upgrades too. It did have windows 7 on it till about yr ago. I had to upgrade to 10 because with all the different computers the SSD had seen windows 7 was having a lot of problem that is why I went to 10.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:01.
Find Us




Windows 10 Forums