Netbios WINS browsing doesn't work after hardware upgrade ?

Page 1 of 2 12 LastLast

  1. Posts : 24
    Windows 10 Pro

    Netbios WINS browsing doesn't work after hardware upgrade ?

    Well, this is a real head scratcher...

    While I know that you really should do a completely clean installation when upgrading your motherboard, I was going from a pretty recent Asus mobo and Intel CPU to a newer one so I thought I would see how it goes in case I could save myself the huge amount of time it will take me to completely rebuild and reconfigure everything on my Win10 x64 system (I have *a lot* of utilities and specialty apps installed/configured for work purposes).

    Anyways, it has actually gone remarkably well and my system appears to be working perfectly fine except for this one issue.

    I simply cannot browse or connect to other samba / CIFS / windows network shares like I did pre-upgrade. I can connect if I use the IP address, but I can't discover and see anything by it's WINS / Netbios names.

    I know about the deprecation of SMB 1.0 in 1809 (or whatever it was) and I have that re-enabled with no effect.

    I've done all the major and typical things like ensure netbios is enabled in IPv4 stack, manually re-activating all the services like:

    • Network Location AwarenessNetwork Connections / Connectivity Asst
    • Network List ServiceUPnP Device HostDNS ClientFunction Discovery Resource PublicationSSDP Discovery
    • TCP/IP Netbios Helper
    • (and a few others that are slipping my mind at this moment, but I pretty much checked every possible service)
    • set the Local Security Policy on the Lanmanager with no results.
    • Windows Credentials via control panel has been cleared.
    • All shares turned off.
    • Full Network Reset via Windows 10 settings
    • Removed hidden adapters
    • Tried WLAN versus LAN adapters
    • ipconfig /flushdns
    • ipconfig /registerdns
    • ipconfig /release
    • ipconfig /renew
    • netsh int ip reset
    • netsh winsock reset
    • sfc /scannow and DISM restore health

    No matter what I try, I cannot find local SMB shares by calling out their computer / WINS names (e.g. "\\mediaserver"). Only by calling it via IP (e.g. "\\")

    When I do a 'diagnose' it always throws an 0x80070035 error.

    Interestingly I ran nirsoft's netbios scanner and it doesn't even see the netbios shares that I can connect to via IP address.

    I've also tried changing and leaving the workgroup and turning on/off all the network discovery settings.

    I'm totally stumped.

    Possible clues/weirdness:

    I see my own computer appear twice in the network browser and one iteration has an active share from my D drive, but I have no such share listed via NET SHARE or in the management console?

    The WINS/Netbios name of my Synology NAS appears, but when I open it, it is empty. If I enter the IP address of my NAS, I can access it fine though.

    Occasionally, I can see my laptop, but I get the 0x80070035 when i try to connect to it. My laptop never sees this computer and it cannot connect to it even via it's IP address.
      My Computer

  2. bro67's Avatar
    Posts : 8,359
    Mac OS Catalina

    NETBios is no longer used with Windows 10, DirectSMB used. You can place in the host file the "Netbios" name for the IP. What model of Synology NAS are you using and have you upgraded it to the latest OS?
      My Computers

  3. Posts : 24
    Windows 10 Pro
    Thread Starter

    bro67 said:
    NETBios is no longer used with Windows 10, DirectSMB used. You can place in the host file the "Netbios" name for the IP. What model of Synology NAS are you using and have you upgraded it to the latest OS?
    I understand what you are saying about the deprecation of SMB1, in Win10, but every other SMB device and Windows 10 device on my network can still see and search for each other except my desktop that I upgraded my motherboard. So it was 100% working for me prior to the hardware upgrade. My laptop with Win10 has no problem seeing the other SMB shares on my network.

    The Synology is a 418play and is running latest DSM - but this issue is not tied to just my Synology. I have two different linux mini-computers (e.g. raspberry pi) with SMB shares and those were visible to my desktop by their 'common' network names and remain visible/searchable by my laptop.

    Again, something funky has happened with my network stack / SMB / netbios that has come up only after a motherboard upgrade.
      My Computer

  4. bro67's Avatar
    Posts : 8,359
    Mac OS Catalina

    If you did not reinstall Windows, yes you can run into these types of problems. You can also try flushing the IP tables in the router by clearing them and turning it off and back on. The same with the NAS. Try the host fix after resting the network by uninstalling it and the driver in Device Manager, then reboot.

    If all machines are up to date and the Linux machines are running the latest SaMBA, it comes down to doing the Host file trick on the Windows machines.
      My Computers

  5. Samuria's Avatar
    Posts : 6,110
    windows 10

    The error means there is no share enter \\mediaserver\sharename
      My Computer

  6. Posts : 24
    Windows 10 Pro
    Thread Starter

    When using the host file trick, do you mean lmhosts or hosts...or both?
      My Computer

  7. bro67's Avatar
    Posts : 8,359
    Mac OS Catalina

    Hosts file is in c:\Windows\System32\Drivers\etc\hosts same as lmhosts. You can put the info in both. lmhosts is a holdout from the old NT version days. Left for backwards compatibility, because some enterprises are still using XP. Some have found that changing the workgroup and computer name, then rebooting works. Do that on all machines and the NAS.
      My Computers

  8. bro67's Avatar
    Posts : 8,359
    Mac OS Catalina

    Now another trick that you may not know about the Synology NAS's, is that you can use WinSCP and Putty to access. See this about root access with those tools. How do i get root access again, step by step? - Synology Forum I had to use it to fix things when PLEX Server was having problems. Also upgraded the RAM on mine that I had to 8GB. I had the DS-216+II.
      My Computers

  9. Posts : 24
    Windows 10 Pro
    Thread Starter

    Finally solved this one thanks to the following thread I stumbled across below. Nothing else worked and one the one clue was that I noticed that ipconfig kept reporting NetBIOS over Tcpip as Disabled even though I had it set to Enabled over TCP/IP in the IPv4 Advanced options on the Network Adapter. That's what made me realize that even though the Windows UI suggested NetBIOS was enabled, it really wasn't

    Netbios over TcpIP broken since upgrade to creators upgrade or - Microsoft Community

    Essentially the linkages entries either got deleted from (or perhaps I just had to manually create them since I was doing a pretty extreme hardware upgrade and windows was incapable of self-healing these kinds of entries):


    It would be interesting to know if there is a microsoft fix-it tool or some other 3rd party tool that or technique to get windows to truly rebuild the network stack and correct those linkage entries? Manually editing them was tedious and required editing 12 different keys with up to 6 strings per it's quite a few entries to make (if you have to do it, use notepad and copy/paste/search/replace to make your life easier).
      My Computer

  10.   My Computers

Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:49.
Find Us

Windows 10 Forums