Windows 10: Changing RDP port after upgrade

  1.    02 Aug 2015 #1

    Changing RDP port after upgrade


    I had my port set to 443, and it worked. I cannot seem to RDP on that port, or the default port. The firewall is OFF. Any ideas? The port was changed in registry already when I went to double check, rebooted a few times, still no luck. Does the new smart filter thingy block something?

    Did some quick troubleshooting. I disabled remote desktop, and watched netstat -a, and it stopped listening on 443. I then enabled it on 443, and it started listening again, so I know the port is indeed open on the box, and not in use. I am trying to RDP over the LAN, not internet too! The box responds to pings.
    Last edited by vivithemage; 02 Aug 2015 at 21:47.
      My ComputerSystem Spec

  2.    02 Aug 2015 #2

    I assume you're setting it to 443 in order to bypass firewall rules at work or school so you can remote to your home PC. This is a lot easier to set in your internet gateway/router if it supports it. Many GW/Firewalls have an option to specify the external and internal port of forwarded ports.

    Have you verified that Remote Desktop is enabled? By default, it's off in 10 after an upgrade.
      My ComputerSystem Spec

  3.    02 Aug 2015 #3

    I've enabled and disabled a few times. It is clearly registering the change as netstat showed listening on 443. I've tried default as well with no luck.
      My ComputerSystem Spec

  4.    03 Aug 2015 #4

    To add, I am running Windows 10 pro. Do I need to have remote assistance checked? If I recall, it was not, but I never thought that was a requirement before.
      My ComputerSystem Spec

  5.    03 Aug 2015 #5

    If you can see 443 is listening, and your windows firewall is off, then your problem is with your router. Perhaps your IP address changed (internal IP) and your router is no longer forwarding to the right IP.
      My ComputerSystem Spec

  6.    03 Aug 2015 #6

    Mystere said: View Post
    If you can see 443 is listening, and your windows firewall is off, then your problem is with your router. Perhaps your IP address changed (internal IP) and your router is no longer forwarding to the right IP.
    It responds to pings, resolves on hostname though. I have tried connecting based on IP and hostname for fun.
      My ComputerSystem Spec

  7.    03 Aug 2015 #7

    That's your external router responding to the ping, not your internal computer.
      My ComputerSystem Spec

  8.    03 Aug 2015 #8

    Mystere said: View Post
    That's your external router responding to the ping, not your internal computer.
    Hmmm, what? I checked my router's mac list, it is showing the right box still. This only started right after the upgrade to win 10.
      My ComputerSystem Spec

  9.    03 Aug 2015 #9

    vivithemage said: View Post
    Hmmm, what? I checked my router's mac list, it is showing the right box still. This only started right after the upgrade to win 10.
    What does your mac list have to do with anything? I'm talking about the port forwarding.
      My ComputerSystem Spec

  10.    03 Aug 2015 #10

    Mystere said: View Post
    What does your mac list have to do with anything? I'm talking about the port forwarding.
    You said that was my external router responding to pings, and not my computer? My external router is hooked directly up to the computer in question. I unplug the ethernet, and it does not respond to pings. I said the MAC list on the router is correct, because I assumed you thought my router 10.10.5.1 didn't know where my server was, 10.10.5.20 (static).
      My ComputerSystem Spec


 

Related Threads
Hey, I live in Finland but use English OS's only. Currently running w7 Pro OEM Eng. I just tried to update to W10...BUT it simply opens up the install dialogs in FINNISH and says I can only perform a clean install and not keep my settings and...
I have just updated my PC to Windows 10, but my Sitecom USB 7 port is not recognized anymore by the OS. Could be a driver issue, but I cannot find any drivers on the internet. Anyone else with the same problem and/or a solution? Thanks Arjan
Windows 10 HDMI Port in Windows Updates and Activation
Hello all you experts I am not a very technical person I have upgraded to Windows 10, 2 days ago and it generally works fine so far, however my HDMI Port will not link with my Television as it did 2 days ago. when I plug into the port it...
Ok i have a laptop with a USB 2.0 Charge port that can charge even if the laptop is powered off and i was just how much mA does that output. i have checked the device manager and i guess it maybe puts out 500mA but theres different ports and im not...
I don't think that Build 10041 and my AMD gaphics driver are the best of friends. I have a 2550*1440 Viewsonic screen attached to an HD 5670 graphics card using display port. Quite often when I am using Thunderbird email the screen blinks a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:31.
Find Us