Problem with accessing network shares on Win10 pc from Win10 laptop

Page 1 of 2 12 LastLast

  1. Posts : 10
    Windows 10 x64
       #1

    Problem with accessing network shares on Win10 pc from Win10 laptop


    So I'm having a problem that appeared fairly recently (about a week ago).
    I have shared some directories on my PC that I use as a file server, and I have mounted those as network drives on my laptop.
    This allows me to play my entire Steam library from the server, which has quite a bit of storage space.

    Suddenly, I can't connect to my server anymore via the network.
    I reset the network adapters via Windows Settings on both my server and laptop, temporarily disabled the firewall on both and tried solutions provided online. No dice.

    When I try to open my network drive, I get the following message: "An error occurred while reconnecting X: to \\Powerhouse\Media. Microsoft Windows Network: the network path was not found."
    Powerhouse is the Windows name of my server.

    If I try to access my server directly as "\\powerhouse", I get the option to diagnose the problem.
    The result of that is: "file and printer sharing resource (powerhouse) is online but isn't responding to connection attempts."

    If I look under network, I don't see my server showing up, which it did before.
    Network discovery is, of course, turned on on both machines.

    Now I have read other forum posts about this issue, of course, but I haven't seen one person for whom a suggested solution for the problem actually worked.
    That's why I'm asking here.

    I really hope someone has an idea about what the problem is here.
      My Computer

  2. Samuria's Avatar
    Posts : 6,195
    windows 10
       #2

    Welcome to the forum. Have you been using homegroup as on the latest update its now been removed. Can you ping the server and can you connect via its IP ie \\IP\media?
      My Computer


  3. Posts : 10
    Windows 10 x64
    Thread Starter
       #3

    I've not been using homegroup, no. Funny thing though, although my laptop doesn't have homegroup options anymore, my server still does.
    Both have been updated to the latest Win10 version available during my troubleshooting.

    I can ping my server from my laptop and vice versa.
    I cannot connect to my server using \\IP\map. It takes a while, and then spits out the Network Error: "Windows cannot access \\192.168.2.119\media".
    The same thing happens if I just try "\\192.168.2.119".

    I'm seeing some new available Win10 updates on my server now, so I'll install them and give it another try.
      My Computer


  4. Posts : 10
    Windows 10 x64
    Thread Starter
       #4

    My server has been updated to the latest Win10 version, but it's still showing Homegroup options under Settings > Network & Internet > Status. Strange.

    Just a note: reinstalling Windows on my server is basically impossible. There's too much data on there for me to back up. I've not got enough external storage for that.
      My Computer


  5. Posts : 10
    Windows 10 x64
    Thread Starter
       #5

    I just found out that with another PC, I can't connect over the network to my PC or laptop. I can see them both under the Network part of Windows Explorer. I also can't connect to my laptop over the network from my server.
      My Computer

  6. Eagle51's Avatar
    Posts : 1,471
    Win10 Home x64 - 1809
       #6

    Hey AnswerSeeker,
    1. Think you've already double checked this stuff, but might not hurt to check this tutorial - Share Files and Folders Over a Network in Windows 10 | Windows 10 Tutorials
    2. You can run the following script on your Win10 PC's and we can take a look at the settings.

    Note: The following script ....
    1. Makes NO changes to your PC
    2. Does NOT reveal any personal info, only PC NAME
    3. It creates a .txt file on your Desktop (Assumes your Desktop Folder has NOT been moved)
    4. Upload the .txt files in your post

    Open PowerShell as Admin. Copy/Paste the following, making sure to hit enter after the last line.

    $(
    write-output "CHECKING LANMAN/TCPIP/SMB FOR COMPUTER $($env:computername) @ $(get-date -format g)"
    write-output "==============="
    write-output "LANMAN SERVER"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    write-output "==============="
    write-output "LANMAN WORKSTATION"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
    write-output "==============="
    write-output "TCPIP4"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    write-output "==============="
    write-output "TCPIP6"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
    write-output "==============="
    write-output "SMB CLIENT CONFIGURATION"
    write-output "==============="
    Get-SmbClientConfiguration
    write-output "==============="
    write-output "SMB SERVER CONFIGURATION"
    write-output "==============="
    Get-SmbServerConfiguration
    write-output "==============="
    write-output "SERVICE CHECK"
    write-output "==============="
    sc.exe query fdphost | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc fdphost | FINDSTR "START_TYPE"
    sc.exe query fdrespub | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc fdrespub | FINDSTR "START_TYPE"
    sc.exe query ssdpsrv | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc ssdpsrv | FINDSTR "START_TYPE"
    sc.exe query upnphost | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc upnphost | FINDSTR "START_TYPE"
    sc.exe query dhcp | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc dhcp | FINDSTR "START_TYPE"
    sc.exe query dnscache | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc dnscache | FINDSTR "START_TYPE"
    sc.exe query iphlpsvc | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc iphlpsvc | FINDSTR "START_TYPE"
    sc.exe query lmhosts | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc lmhosts | FINDSTR "START_TYPE"
    sc.exe query lanmanserver | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc lanmanserver | FINDSTR "START_TYPE"
    sc.exe query lanmanworkstation | FINDSTR "SERVICE_NAME STATE"
    sc.exe qc lanmanworkstation | FINDSTR "START_TYPE"
    write-output "==============="
    write-output "IPCONFIG ALL"
    write-output "==============="
    ipconfig /all
    ) > "$($env:userprofile)\Desktop\$env:computername-LANMAN-TCPIP-SMB-CHECK.txt"
      My Computers


  7. Posts : 10
    Windows 10 x64
    Thread Starter
       #7

    I've read through the article you linked, and yeah, all that stuff's configured right.
    For clarity: Power-To-R2D2 is the name of my laptop, Powerhouse is the name of my server.
    My server has four network adapters. Normally they're teamed for redundancy, but now that's disabled to make troubleshooting potentially easier.
    Problem with accessing network shares on Win10 pc from Win10 laptop Attached Files
      My Computer

  8. Eagle51's Avatar
    Posts : 1,471
    Win10 Home x64 - 1809
       #8

    Couple of things jump out at me ...

    1. On the PowerHouse PC > Lanman Server has AdjustedNullSessionPipes : 3 and the Power-to-R2D2 > Lanman Server doesn't have that setting. I've not seen AdjustedNullSessionPipes before, so not sure exactly what it does.

    2. NetBIOS over TCP/IP appears to be disabled on some of your adapters. Did you disable it for a reason ?

    3. Lets see if NetBIOS over TCP/IP is actually disabled or IPCONFIG /all just thinks it is.

    Open PowerShell as Admin and run the following command on each PC ... Copy/Paste output in post.

    Get-ChildItem -Path HKLM:SYSTEM\CurrentControlSet\Services\NetBT\Parameters\Interfaces -Recurse
      My Computers


  9. Posts : 10
    Windows 10 x64
    Thread Starter
       #9

    I've found this forum thread, the answer of which actually works for me.
    I'm trying to find a way to run the Powershell commands as admin on startup, but it's kind of a pain to get working.
    For now, I'll just execute the command manually every time I restart my server.

    I wouldn't call it a solution, more a workaround. But... it works for now.

    I'm still very interested in trying to find the actual problem, though.

    EDIT: I thought I'd just paste the Powershell commands that temporarily fix the problem (until reboot) here for convienence:
    Code:
    Disable-NetAdapterBinding -name "adaptername" -ComponentID ms_server
    Enable-NetAdapterBinding -name "adaptername" -ComponentID ms_server
      My Computer


  10. Posts : 10
    Windows 10 x64
    Thread Starter
       #10

    1. No clue what that's for, either.

    2. I haven't disabled that on purpose, no.

    3. Output from Powerhouse: Powerhouse - Pastebin.com and output from Power-To-R2D2: Power-To-R2D2 - Pastebin.com
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:21.
Find Us




Windows 10 Forums