Help! File sharing broken, have tried everything!

  1.    #1

    Help! File sharing broken, have tried everything!


    File sharing is broken on my “Theater” computer which is my home theater and multimedia server machine with all my music and videos on it. It’s been broken for a couple of weeks now, and I have spent countless hours troubleshooting with no success.

    I consider myself to be quite computer literate. I’ve worked in the computer biz for over 40 years including networking and IT, engineering, and software development.

    The machine shows up in “Network” in File Explorer, and its 2 shares “Music” and “Videos” show up when you double-click or open the “Theater” machine.

    However, when you try to open a share, you get the message that “Windows cannot access the share”. “Details” returns an error 0x80070035, “The network path was not found”. “Diagnose” detects the problem that “The remote device or resource won’t accept the connection”. This happens even when the Theater machine attempts to open its own shares.

    I have:
    • Pinged all machines, NAS, router, and switches from all other machines to this one, and from this one to all others. No problems. Reply always 4ms or less.
    • Verified, and re-verified and verified again the IPv4 addresses, subnet mask, gateway, DNS, and DHCP settings (IP: Static 10.3.7.137, Mask: 255.255.248.0, GW: 10.3.7.1, DNS: 1.1.1.1 and 8.8.8.8. MAC: D4:3D:7E:55:83:1D has DHCP reserved IP of 10.3.7.137) (All machines normally used fixed IPs, but also have their IP reserved in DHCP based on MAC as a fallback)
    • Remote desktop works to and from the Theater machine. The Plex Server at port 32400 is available to all other machines on the network.
    • I have turned off windows firewall and defender anti-virus. No 3rd party firewall or anti-virus is installed. Controlled folder access is off.
    • Even though the Firewall is turned off, I have carefully looked through all the rules (in and out) and allowed anything and everything that seems like it might apply.
    • Windows Update is up to date. All device drivers including for the NIC are up to date.
    • I have liberalized sharing permissions. “Everyone”, “Users”, “Administrators”, and “Wizard” (That’s me!) all have full access in sharing security and file security. No-one has any “Denies”.
    • I have reset TCP/IP and Winsock and flushed DNS from administrator command prompt, and then rebooted, on all machines.
    • NetBIOS is enabled over TCP/IP (in Network Adapter -> IPv4 -> Advanced -> WINS) on all machines.
    • "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks" is installed and enabled for the NIC.
    • The “Reliable Multicast Protocol” has been added and enabled to all machines.
    • Windows “Server”, “Workstation”, and “Computer Browser” services are all running. Network discovery and file sharing are turned on in the “Network and Sharing Center”.
    • “Network Security: LAN Manager authentication Level” is set to “Send LM & NTLM – use NTLMv2 session security if negotiated” in security policies on all machines.
    • Cleared all credentials from the credentials manager on all machines.
    • Most machines are on Window 10 Pro release 1803. (Note that Homegroups were removed by Microsoft starting with release 1803.)
    • The network mode/location is set for “Private” (Home).
    • Most of the machines, including Theater, are hardwired with ethernet cable.
    • The Theater machine shows up in a SoftPerfect NetScan of the network, but NetScan does not see or list any available shares on that machine (unlike other machines on the network, where it does see/list the shares).
    • All machines are on the workgroup “WORKGROUP”.
    • There is no domain or domain controller/server.
    • I HAD Ivacy VPN client installed on that machine. I have uninstalled it. It’s still on one of my other machines though, and is not interfering with its shares.
    • IPv6 is installed/enabled on all machines. IPv6 address set for obtain automatically, All IPv6 addresses start with FE80:: DNS set to 2606:4700:4700::1111 (CloudFlare) and 2001:4860:4860::8888 (Google)
    • Shares on other machines can be opened without any problem, including from the Theater machine.
    • I have dug all through the event logs in event viewer and I can only find one error that seems relevant:


    Clues: in the Event Viewer -> Application and Service Logs -> Microsoft -> Windows -> SMBClient -> Connectivity there are errors:
    “Failed to establish a network connection.
    Error: The transport connection attempt was refused by the remote system.
    Server name: THEATER
    Server address: 10.3.7.137:445
    Instance name: \Device\LanmanRedirector
    Connection type: Wsk
    Guidance:
    This indicates a problem with the underlying network or transport, such as with TCP/IP, and not with SMB. A firewall that blocks TCP port 445, or TCP port 5445 when using an iWARP RDMA adapter, can also cause this issue.”

    (Note, as previously mentioned, the Windows Firewall is turned OFF)

    So what I have missed or overlooked? What further tests or diagnostics should I run?
      My ComputerSystem Spec

  2.    #2

    You don't mention either of the Function Discovery items. Make sure both of these are set either to Automatic or Automatic (Delayed) in the Startup field:

    Click image for larger version. 

Name:	image.png 
Views:	3 
Size:	31.3 KB 
ID:	203445

    I have 9 PCs on my LAN, of which 4 run various Insider Preview releases (Skipahead [1], Fast Ring [2], and Slow Ring [1]). I have to repeat this setting from time to time, because upgrades sometimes reset this to the Manual default. Mucks with network visibility for some unfathomable reason.
    HTH,
    --Ed--

    PS: Function Discovery Provider Host and Function Discovery Resource Publication are both easily accessed through Services.msc. If you need further instructions for making the suggested settings changes, please ask, and I'll find a tutorial that shows a how-to.
      My ComputersSystem Spec

  3.    #3

    EdTittel said: View Post
    You don't mention either of the Function Discovery items. Make sure both of these are set either to Automatic or Automatic (Delayed) in the Startup field:
    Discovery publication was running. Discovery host was stopped. I started the host, but it did not help, still the same error and symptoms. I also rebooted and checked again, both services still running after reboot, but still can't access shares.

    Thank you Ed, any more suggestions?
      My ComputerSystem Spec

  4.    #4

    You dont say the version of windows number ie 1803 as home group was removed so its worth removing ipv6 as its not used. there are some solutions here Error code: 0x80070035. The network path was not found. [Solved] - Driver Easy

    People have found with windows changes re making shares often sorts it
      My ComputerSystem Spec

  5.    #5

    Samuria said: View Post
    You dont say the version of windows number ie 1803 ...
    Actually, I did mention that it is 1803 without homegroups. And I have deleted and recreated the shares (multiple times) and I have seen the page you mention on DriverEasy which clued me in to the Lan Manager change in Security Policies and installing the Reliable Multicast Protocol. And I've tried disabling, re-enabling, re-disabling IPv6.
    In fact, I suspect that disabling IPv6 to begin with may be what triggered the problem (I had disabled IPv6 because my real 6-IP was showing on the other end (web) despite using a VPN and I was looking for "sensitive" content and didn't want to be tracked.)
    Thank you very much for your response though!

    Any other ideas? Perhaps a diagnostic to narrow in on the source of the problem?
      My ComputerSystem Spec

  6.    #6

    Hey DrWizard,
    Sounds like you've been thru all the usual checks ... You can use the script below to help you compared all the Lanman Server/Workstation, TCPIPv4, TCPIPv6, and SMB Client/Server registry settings between a working PC and the non-working PC to see what/if any differences there might be.

    Note: The following script ....
    1. Makes NO changes to your PC
    2. It creates a .txt file on your Desktop (Assumes your Desktop Folder has NOT been moved)

    Open PowerShell as Admin. Copy/Paste the following, making sure to hit enter after the last line.

    $(
    write-output "CHECKING LANMAN/TCPIP/SMB FOR COMPUTER $($env:computername) @ $(get-date -format g)"
    write-output "==============="
    write-output "LANMAN SERVER"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
    write-output "==============="
    write-output "LANMAN WORKSTATION"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
    write-output "==============="
    write-output "TCPIP4 PARAMETERS"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    write-output "==============="
    write-output "TCPIP6 PARAMETERS"
    write-output "==============="
    Get-ItemProperty -Path HKLM:SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
    write-output "==============="
    write-output "SMB CLIENT CONFIGURATION"
    write-output "==============="
    Get-SmbClientConfiguration
    write-output "==============="
    write-output "SMB SERVER CONFIGURATION"
    write-output "==============="
    Get-SmbServerConfiguration
    ) > "$($env:userprofile)\Desktop\$env:computername-LANMAN-TCPIP-SMB-CHECK.txt"
      My ComputersSystem Spec


  7. topgundcp's Avatar
    Posts : 2,445
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       #7

    In addition to what @EdTittel suggested above, try:
    Suddenly sharing not working Solved - Windows 10 Forums
      My ComputerSystem Spec


 

Related Threads
Solved Sharing Broken in Network and Sharing
OK, here's the details of my little home network: Desktop PC: Name - RAVEN OS - Windows 10 Pro 64-Bit (1803 17134.228) Network - Ethernet connection to WiFi router IP - Static 192.168.0.100 Laptop PC:
I have Windows 10 Pro 1703 Build 15063.483. About 2 weeks ago, after restarting my PC, I got 0x80070035 when accessed shared folder. It was fine the day before I restarted my PC. I tried most of things mentioned about 0x80070035, like checking...
hi guys, so I was searching for the past 3 hours for a concrete solution for this... here's the scenario, I have one win10 PC and 2 win 7 PCs over Ethernet, all working decently, until today I noticed that the other win 7 comps cannot see the win...
This is a weird one... Just installed Win 10 1709 on a laptop and everything went fine until I got to the point where I wanted to share drives on the laptop (the data partition - D:) with other machines on my home network. Right-clicked on D:...
Hey everyone. First let me blow some steam by stating that Microsoft Account is a convoluted feature that is very poorly thought out and integrated. /end rant That being said, here is my situation. I fresh installed Windows 10 on my laptop and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:58.
Find Us