SMB v1.0 on Windows 10 - The Parameter is Incorrect

  1.    #1

    SMB v1.0 on Windows 10 - The Parameter is Incorrect


    Alright.. Got another one kicking my butt here. First, let me start by saying, I know that 1803 has disabled SMB 1.0 by default. I have re-enabled it and this problem started prior to 1803. Best I can tell, the first time it happened was in KB4015217.. Back then, we could remove that update and it would work again.

    So.. With that out of the way.. A brief description of the problem. We use a version of RTOS that supports SMB 1.0 only. we're upgrading to the latest version that will support SMB 3.0, I believe, but.. We're not there yet, and right now, we cannot SMB to it on any Win10 machine. Though, SMB via XP, 7 or 8 and older versions of Win10 are fine.

    The way we access the share is by entering the IP address. So, in windows explorer, enter in \\192.168.1.101\posfiles and it will prompt you for username and password. The username is hardcoded as admin, the password is GENERALLY not set, but since the problem started, I've tried with and without a password, and the same result is obtained.

    On Win10 systems that have the KB4015217 patch or later or any machine with 1803.. When you attempt to do this, even after re-enabling SMB 1.0 if it happened to be disabled.. You will get a message of "The Parameter is Incorrect"

    Well.. Lovely, Microsoft. What parameter and what's incorrect about it?

    I've nosed around in Wireshark a little today, and.. I can't really find anything wrong. It gets to a Query Path Info and just seemingly dies there.

    Not the strongest on SMB under the hood because.. Well.. It generally just works. So, I'm doing quite a bit of reading trying to figure out how to troubleshoot it and.. Not having a whole lot of luck. Any thoughts?

    I should note here.. If I point to a SPECIFIC file.. It will open the file. So, for example, using

    \\192.168.0.54\POSFiles\Data\test.txt

    If I go to that address... It will open the text.txt file. So, it seems that perhaps this is something in the directory/file browsing..
      My ComputerSystem Spec

  2.    #2

    As I'm finding more things out here.. My problem I can workaround now, though I'd like a full solution to it..

    I originally thought the problem was in authentication, however, the Wireshark data showed that authentication was completing successfully. Once I saw that the issue seemed to be in directory listing in some way.. I wondered.. Well, what if I went old school and tried things from the command prompt? So, I used windows explorer to authenticate, got the "Parameter is Invalid" error and then noticed, if I typed the address in again, such as \\192.168.0.54\posfiles\data\ then I had a dropdown open that showed all the files there.. So.. Went to a command prompt and did

    dir \\192.168.0.54\posfiles\data

    and that gave me a directory listing. Tried copying a file from and to the share.. Worked.. Tried deleting a file from the share, all through command prompt, and it all worked.

    So.. I have a workaround that at least allows me to use it, though not quite as simply as through Windows Explorer. But.. Hey, worst case, I can say that it keeps the old stuff that I rarely use anymore fresh in my brain.

    This also seems to mean that the problem is somehow, someway in windows explorer itself and not SMB 1.0.
      My ComputerSystem Spec

  3.    #3

    I cant answer for your problem specifically but SMB 1 was removed from a recent build of Windows 10 for security reasons and if you can you should consider using a newer version.
      My ComputersSystem Spec

  4. storageman's Avatar
    Posts : 734
    Windows 10 Pro 1903 18362.267
       #4

    I to don't have an answer on where the original problem really lies. I had initially turned SMB1 on after the upgrade to 1803. It was more for expedience until I would have enough time to research the problem. Well since then, I discovered the same workaround as you have. I've turned off SMB1, and implemented it as you have. However there is one draw back that I haven't found a solution, my NAS box goes to sleep if there is no activity. If I have to re-boot or start another system while is sleeping, explorer can't find it. It necessitates a manual operation where I have to disconnect & re-connect it.
    Attached Thumbnails Attached Thumbnails SMB1_Issue.jpg  
      My ComputersSystem Spec


 

Related Threads
Hello, My Bluetooth was not detecting any devices. I started Bluetooth User Support Service and it seemed to work. My PC said it's discoverable. But the problem is I need to restart my PC for it to work but when I do, it just shuts off again! I...
Could someone tell me specficially what is wrong with the following command? It looks to me to be concordant with the instructions I'm trying to follow: C:\Windows\system32>netsh interface ip add dns name="Ethernet" static 8.8.8.8 index=2 The...
It all began when I was trying to get Firefox to open a downloaded Word .doc file. Firefox absolutely refused to realize that I had Word installed. So I did what I usually do when Firefox is obstinate about opening a file; I tried to locate...
Bitlocker - The parameter is incorrect in AntiVirus, Firewalls and System Security
I have one data drive that is Bitlocker protected and it has always worked fine. Now it seems to unlock, but when I try to access the drive I get "The parameter is incorrect". The am running Windows 10 Pro 1607 14393.105. Does anyone have any...
This popped up after I d/l 10158, under settings, advanced options, notice that my microsoft account requires attention to get insider builds, FIX ME says that I could not sign in, parameter is incorrect. I am downloading 10159 at present. What...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:47.
Find Us