Local shared hosts in workgroup not found in discovery Solved

Page 1 of 2 12 LastLast
  1.    #1

    Local shared hosts in workgroup not found in discovery


    I am trying to share a printer (HP Deskjet 1110) which is usb connected to a PC which is connected via wireless to my home Netgear router. The other host in my house is connected to the router via RJ45.

    I have set "sharing" on the target printer as well as the network card in each local host. I have "discovery" set on each host as well. The both hosts are in the same workgroup although not the default Windows "workgroup".

    I'm not able to install the printer because it fails discovery and cannot find it if I manually enter the hostname and printer share name either.

    I'm not really surprised that I cannot find the printer through the network since I do not even see the host listed in the network viewed from either host.

    Is there a setting that I missed? I would like to see the hosts on my local network from each host to the other.

    What am I, or Microsoft, doing wrong? This used to be quite simple and I'm guessing it still should be. HELP!

    I see the wireless host listed in the media servers which makes it all the more confusing to me. They connect to the Internet with no problems and have coexisted in my network for a long time (not a new installation).
      My ComputerSystem Spec

  2.    #2

    Here ya go: Share Files and Folders Over a Network in Windows 10 | Windows 10 Tutorials

    Edit: Wanted to add that once you follow the tutorial, sharing the printer will be a no-brainer.

    Additional Edit:
    "4. Turn on network discovery for your private or public network.
    5. Turn on File and Printer Sharing for your private or public network.
    6. Turn on Public folder sharing if you want to share items in the C:\Users\Public folder."

    Even though it says Turn on for private or public network, I would only do it for Private, especially if it is a laptop. Just my $.02.

    7. Turn on or off password protected sharing for what you want.

    If you turn off "password protected sharing" you will have to have identical accounts on each machine you want to access. If you have it (password protected sharing) ON then you can store a separate credential in Credential Manager that matches a user/password on the machine you are trying to access.

    OOOOPs my bad. I got that backwards!!!! If turned on you will need identical accounts (or store the login in the credential manager if you don't want to create identical accounts - I've just always created identical accounts on my machines fwiw)! If off you don't! DUHHH - Sorry!!!
    Last edited by abenavraham; 30 Jul 2018 at 14:32. Reason: addeded comment
      My ComputerSystem Spec

  3.    #3

    abenavraham,

    Only thing I found was that the two services were not started automatically.

    The settings in the other tutorials were as depicted. I even turned sharing off and back on which didn't help.

    Turning on the two services listed did get the computers to show up in each other's network view.

    I then shared the Public folder in each computer to my user, which is the same on both computers.

    I'm going to give up for today and try some things Wednesday (out of town tomorrow).

    For what it's worth. I do share a hard TCP/IP addressed printer to each computer with no problems. That network printer is hardwired to the router and served via a TCP/IP port.

    My issue is that the network printer's color printhead is kaput and I need to print some color documents. Otherwise I would never have known that I couldn't print over the network to another host's local usb printer.
      My ComputerSystem Spec

  4.    #4

    What feedback do you get if you open a command prompt and type:
    net view \\machine_name
    where machine_name is the name of the machine you shared the USB printer from - i.e. if the PC is "bigrich001"
    type: "net view \\bigrich001" (without the quotes")?

    Is the printer listed under "Share name" as in the image below?
    Attached Thumbnails Attached Thumbnails netview.png  
      My ComputerSystem Spec

  5.    #5

    With the server computer "hpenvy" on and its printer too, here is both the graphic and command line views.

    Does not make sense to me, the computer shows up in the graphic view but the net view command gets an error 53. Alsp tried command view using IP with same result to eliminate name resolution.
    Click image for larger version. 

Name:	Graphic Network view.jpg 
Views:	2 
Size:	76.1 KB 
ID:	197835 Click image for larger version. 

Name:	Net view using IP.jpg 
Views:	25 
Size:	19.3 KB 
ID:	197836
      My ComputerSystem Spec

  6.    #6

    Which profile is active in Advanced Sharing Settings - Public or Private?

    Can you post a screenshot of the Advanced Sharing Settings (located at Network and Sharing Center -> Advanced sharing settings). Also if Public folder sharing is turned ON select Turn off Public fol... to turn it off Make sure "All Networks" is expanded.

    Do you have the same user/password account on both machines? Do any of them have blank passwords?

    Do you have ANY 3rd party Antivirus/Firewall software outside of Windows Defender?
      My ComputerSystem Spec


  7.    #7

    Also, what happens if you run the "net view \\hpenvy" command at a command prompt on that machine (hpenvy and not from MSI-H20)?
    What version(s) of Windows 10 are you running on each machine?
    Edit: I see the version of the one you posted in the screen shot - Is the other machine the same?
      My ComputerSystem Spec

  8.    #8

    Also since the OS of the machine you posted in the screenshot is the April update 1803, is SMBv1 enabled or disabled (in add/remove features)? 1803 will have it disabled by default. Does the other machine also have 1803, or is it an earlier build?
      My ComputerSystem Spec

  9.    #9

    One additional thing to try on the command line: type net view \\hpenvy.local to see what results you get. Error 53 I think is a Netbios name resolution issue and adding the .local I think uses Microsoft's implementation of mDNS (Zeroconf) which should bypass netbios if it is still active on either of your machines.
      My ComputerSystem Spec

  10.    #10

    abenavraham,

    I just logged on to update what I've found since and have not yet tried some of the suggestions you have been posting but you are in the right ballpark, even the right bleachers.

    I have been able to 'see' the printer. Although Windows Defender has file and print sharing "allowed" in the Private network settings it only works when I turn the Windows Defender firewall off for the Private network on the machine serving the printer. I turned off that firewall and installed the printer and printed to it with no problems. It stops working again as soon as I turn the firewall back on for the Private network on the server node.

    Both machines are running Win 10, Ver. 1803.

    I downloaded and ran the "Windows Firewall Troubleshooter" but it finds no problems with the firewall. Par for the course for Microsoft troubleshooters. I have worked on computers for 40 years and can count on one hand the number of times Microsoft actually found and fixed one of their problems. Such is life in the Microsoft world.
    Link: How to troubleshoot and fix Windows 10's firewall problems | Windows Central

    I assume it is safe to continue running with the Private network firewall turned off so that is my "workaround" unless you have a better suggestion? What say you?

    Thank for your help thus far!
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Iím running Windows 10 Pro 64 bit, fully patched with 16Gb RAM; I performed a full wipe clean install just 25 days ago. Other than this issue, everything is working perfectly on this computer. This system is not on a domain, and there is no group...
I have scoured the Networking and Sharing portion of this Win 10 Forum for an answer to my issue but have not found anything that works. We have a peer to peer network, with one Win 10 machine (acting as server - which we call server) which...
I have so far avoided using Windows ID login (except on a sacrificial VM I use for Windows Insider(*)) as I can no longer access the SMB shares that I have set up. Is there any way for the two to co-exist? I can't get my head round using SMB...
I can't access my laptop which is using a Microsoft account from my Desktop using a local account. Both running Windows 10 Pro X64. I'm using workgroup, not homegroup. I know I've read of people making this work but I'm not having any luck...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:19.
Find Us