Windows 10: Setting static IP via commandline: "the parameter is incorrect" error Solved

  1.    01 Jul 2018 #1

    Setting static IP via commandline: "the parameter is incorrect" error


    Could someone tell me specficially what is wrong with the following command? It looks to me to be concordant with the instructions I'm trying to follow:

    Code:
    C:\Windows\system32>netsh interface ip add dns name="Ethernet" static 8.8.8.8 index=2
    The parameter is incorrect.

    For reference, the following worked just fine:

    Code:
    C:\Windows\system32>netsh interface ip set dns name="Ethernet" static 192.168.1.1
      My ComputerSystem Spec

  2.    01 Jul 2018 #2

    For secondary dns
    netsh interface ip add dns name="Ethernet" 8.8.8.8 index=2
      My ComputersSystem Spec

  3.    01 Jul 2018 #3

    I see, it was "static" which shouldn't be there. I don't get why it's meant to be in the other command but not this one but okay, thanks!
      My ComputerSystem Spec


 

Related Threads
hi, my girlfriends computer recently locked her out, we where ****ing around with trying to delete the windows.old folder after a recent update(wouldn't let us because of missing ownership) so she logged out and when she wanted to login again then...
It all began when I was trying to get Firefox to open a downloaded Word .doc file. Firefox absolutely refused to realize that I had Word installed. So I did what I usually do when Firefox is obstinate about opening a file; I tried to locate...
Hi All, My first post! A couple of weeks ago when I turned my PC on and clicked one of drives I received a message that "This Folder Is Empty". I found this solution after a google search: 1.diskpart 2. list disk 3. select disk {number} 4....
I have a desktop computer that was upgraded from Windows 7 to Windows 10 Pro. When I try to run CMD as Administrator, I receive "The environment is incorrect." error message. I get the same error if I try to run other Windows applications (in...
Please help! I am using am iMac with Bootcamp running Win 7. I have just upgraded to Win 10 with no problems. Except I can now not read my 2 x WD USB external drives. I am getting "the parameter is incorrect" error. In disk management it says the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:22.
Find Us