Windows 10: Network adapter missing from device manager Acer Aspire E1-570

  1.    30 Jun 2018 #1

    Network adapter missing from device manager Acer Aspire E1-570


    Hi,

    in morning i had left my PC in perfectly working condition but in the evening when i checked my wifi router was blasted (don't know why) & i had missing wifi & network adapters under device manager.

    I have solved wifi issue by installing acer support drivers hence my internet connectivity is back but i am not able to use ethernet port.

    Below are the snapshot of CPU-Z for all tabs:

    Click image for larger version. 

Name:	CPU.png 
Views:	16 
Size:	27.5 KB 
ID:	194079

    Click image for larger version. 

Name:	Memory.png 
Views:	16 
Size:	18.0 KB 
ID:	194080
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 10,689
    Windows 10 Pro x64 Build 1803
       30 Jun 2018 #2

    Hi balvinder. Welcome to the TenForums @balvinder

    Maybe you could expand on your router was blasted? Did you need to replace it?

    Was your device wired to router when it blasted?

    If you have a removal battery please power down, disconnect mains, remove battery and hold power on for 20secs. Wait a few minutes, reassemble and see what device manager is reporting.

    In device manager do you have any devices with a yellow triangle (Unknown devices)?

    Please also check you bios to see if the lan adapter can be control from within.


    Ken
      My ComputerSystem Spec

  3. bro67's Avatar
    Posts : 4,932
    Mac OS High Sierra 10.13.5
       30 Jun 2018 #3

    CPU-Z does not show devices. You need to show a screenshot of Device Manager.
      My ComputerSystem Spec

  4.    01 Jul 2018 #4

    Hi,

    Thanks for reply.

    Well, it's my bad. i forgot to attach device manager screen shot. Here it is:

    Click image for larger version. 

Name:	device manager.png 
Views:	3 
Size:	98.9 KB 
ID:	194147

    Apart from this what i tried before posting to forum:
    - removed RAM multiple times
    - changed RAM to different socket
    - removed battery & plugged again
    - tried installing network driver from intel download center but error popup saying "no network adapter found."
    - re-installed bios drivers
    - visited Acer support website & tried installing LAN & WLAN drivers. Though i got little success here . my wifi started working
    - re-fresh installation of window after watching PC health report

    After all this sometimes post restart only ethernet icon shows near time point (right bottom) with red cross marked. clicking on that shows nothing (not even wifi). Again restarting solves this issue most of the times.

    To answer @Caledon Ken, yes my laptop was wired through ethernet port when my router blasted. though my laptop was on hibernate mode. I had to replace my wifi router to get the internet working. Apart from this my internet service provider was saying that his 5-6 switches were also blown. He had to replace all of them to get the internet service started. I can only guess that it was due to electricity fluctuation. Rest you all people are expert & guide me better.

    Thanks
    Balvinder
      My ComputerSystem Spec

  5. Caledon Ken's Avatar
    Posts : 10,689
    Windows 10 Pro x64 Build 1803
       01 Jul 2018 #5

    I would try resetting BIOS as last ditch effort. If CMOS Battery / capacitor is accessible I might even disconnect that.

    If you suffered an electrical surge there is a good chance your lan adapter died saving your laptop.

    Sounds like your connection is not ground at building entrance. You could try going after telco for sloppy installation.

    If you have wireless you could stay with that. If your device does not support AC speeds, and if your router does, you could purchase USB plug in to get a fast connection.

    You could also investigate USB to lan connection.
      My ComputerSystem Spec

  6. bro67's Avatar
    Posts : 4,932
    Mac OS High Sierra 10.13.5
       02 Jul 2018 #6

    What do you mean by "blasted"? If your router was hit by a surge, your ethernet port took a hit.
      My ComputerSystem Spec


 

Related Threads
So let me tell the truth. I had tried to install Ubuntu 18.04 along side windows as a dual boot system. i have done it before many times but this time was my bad luck and something gone wrong. after restarting i have welcomed with windows 10, i...
Webcam was working a week ago. Suddenly Skype cannot detect my web cam . I went to Device Manager , selected the web cam under Imaging devices , then uninstalled the driver . Then went back to Device Manager and scanned for hardware changes. Now...
Hello, Thank you in advancefor any help. I am senior who helps other seniors in this small townkeep their pc s operating as best I can. I have an HP laptopthat was reworked by a shop sometime ago. I updated this pc to WinAnniveresary Issue and...
I have an Asus X555Q laptop. I replaced the hard drive and installed Windows 10 with a USB drive. I did not have a restore option. I downloaded all the drivers from Asus, but no matter what drivers I use, they do not find my wireless adapter....
So originally I upgraded my mini PCI card and was trying to get that working... It was recognized in the device manager but not the network connections.. I could not see the adapter to use or enable/disable etc despite having the drivers up to date....

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:09.
Find Us