Windows 10: Unable To Access Screen Sharing Sites

Page 1 of 2 12 LastLast
  1.    28 Jun 2018 #1

    Unable To Access Screen Sharing Sites


    Hi,

    I'm trying to set up my daughter's laptop who's not at home. I decided that having a screen sharing program, such as join.me would be a good idea so that I can see what's going on over the distance from my computer. However, on neither computer can I access either of the two websites that I want: join.me or TeamViewer.

    I have tried it on both computers (Win 10 on mine, Ubuntu on hers) and on IE, Firefox and Chrome and I'm unable access them. What's going on?

    IE states:
    Cannot securely connect to this page
    This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.
    Try this:
    •Go back to the last page

    Firefox:

    Secure Connection FailedThe connection to join.me was interrupted while the page was loading.
    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the web site owners to inform them of this problem.
    Learn more…
    Report errors like this to help Mozilla identify and block malicious sites

    Chrome:

    This site can’t be reached
    The connection was reset.
    Try:Checking the connection
    Checking the proxy and the firewall
    Running Windows Network Diagnostics
    ERR_CONNECTION_RESET

    Matt
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 4,917
    Mac OS High Sierra 10.13.5
       28 Jun 2018 #2

    She needs to download Teamviewer and then allow you to access her machine. If she does not allow you to access it or her firewall blocks access, that is on her end. You also have to download teamviewer. Since she has Linux on her machine, Teamviewer actually runs in a emulation on Linux.
      My ComputerSystem Spec

  3.    28 Jun 2018 #3

    Sorry. May be I didn't make it clear. She can't even access the websites to download either join.me or TeamViewer - neither can I.

    Matt
      My ComputerSystem Spec

  4. bro67's Avatar
    Posts : 4,917
    Mac OS High Sierra 10.13.5
       28 Jun 2018 #4

    Something else is going on or you are using the wrong url. Teamviewer is your best one to use. Download TeamViewer | TeamViewer If you are using any kind of DNS that could block these types of websites, you need to then look at that by doing a ping of the website.
      My ComputerSystem Spec

  5.    29 Jun 2018 #5

    The web address you've supplied is " ... teamviewer.US ... ". I was trying " ... teamviewer.COM/EN ... ", which is where places like Wikipedia suggest. I can get onto your one, but still not onto the 'officially' suggested one. Why the difference?

    Also, why do you consider TeamViewer better than join.me, and does anyone else have any opinions? I used to use TV and then it got complicated in its UI and connectivity, so I switched to JM, but I have had a few problems with that one lately.

    Matt
      My ComputerSystem Spec

  6. bro67's Avatar
    Posts : 4,917
    Mac OS High Sierra 10.13.5
       29 Jun 2018 #6

    There is no com/en website for teamviewer. They use the .us. Ignore everything that wikipedia says. Teamviewer has become the one size fits all for those wanting a good secure solution.
      My ComputerSystem Spec

  7.    29 Jun 2018 #7

    Just to let you know, I tried on a completely different laptop and got through to COM/EN. It looked fine, but I didn't download anything.

    Out of all the websites and videos that I have looked at (maybe over thirty - most of them relatively current), almost all (all bar two - one of them this one, here) stated that the web address was COM/EN. This may not be the current (or correct) one, but it certainly exists for 'TeamViewer'.

    Matt
      My ComputerSystem Spec

  8.    29 Jun 2018 #8

    bro67 said: View Post
    There is no com/en website for teamviewer.
    Not true if you are in Europe like the OP (and me). Definitely the /en suffix exists and is valid. Perhaps in the US it isn't used? Who knows.

    This is where I downloaded it : https://www.teamviewer.com/en/download/windows/ and it is definitely the correct address. You can see if you click on the padlock in the browser address bar that it is a secure connection and the owner of the certificate is www.teamviewer.com

    Click image for larger version. 

Name:	Capture.PNG 
Views:	0 
Size:	38.8 KB 
ID:	193887

    Once it is downloaded you get (on Windows) a UAC (User Account Control) warning asking if you want to install it. This is also signed by their company as you can see in this picture:

    Click image for larger version. 

Name:	Capture2.PNG 
Views:	24 
Size:	16.8 KB 
ID:	193888

    I agree it sounds the best solution (it is the one I use although I use WebEx and others as well) and certainly the .../en download site is safe.
      My ComputerSystem Spec

  9. bro67's Avatar
    Posts : 4,917
    Mac OS High Sierra 10.13.5
       29 Jun 2018 #9

    Again, use the website that I posted for Teamviewer. There is no .com/en website for teamviewer.
      My ComputerSystem Spec

  10.    29 Jun 2018 #10

    Ix07: Thanks for this. Unfortunately, I cannot seem to access this site from my main computer (win10) or my daughter's (Ubuntu) (see the messages I get in the first post).

    Bro67: Can you explain why you think there is no .com/en/ for TeamViewer when there is clearly a web address that brings up TeamViewer? At least it does on my other laptop and, obviously, on very many other computers. If you have a good reason, I would certainly love to hear it (in all seriousness).

    Matt
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Access to Numerous Sites Denied in Browsers and Email
I have Firefox 57.0.2, Windscribe VPN and Malwarebytes Pro on this desktop. I used to be able to click on a link that I know is safe, but now, I cannot. Something is denying me access and I am more or less crippled. I'm a bit tired of this,...
I have a problem with UK Government sites on this computer. I have tried accessing and filing on the companies house site, and have today tried to file a tax return with HMRC. In both cases I have been able to log in, but when moving to the next...
I'm having this problem and few more for about 2 months, asked my ISP, they renewed my IP and everything, they say it's not their problem. I cannot login to most of my social network accounts because it opens the site in http instead of https IMO,...
Sites are unable to detect my OS. in Browsers and Email
I'm using Windows 10. I recently reset my PC so that I could re-install windows 10 thanks to an issue i was having with my WiFi. One day after doing that, I'm using my usual main browser, Opera, and sites with DOSArrest are giving me the "463...
Hi all, I'm sure I'm missing something really simple but so far I've been tearing my hair out trying to figure this out and have all but given up and was hoping someone here might be able to give me some advice? I currently have three PCs (Two...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:28.
Find Us