Windows 10: Computers not showing in network Solved

Page 1 of 2 12 LastLast
  1.    22 Jun 2018 #1

    Computers not showing in network


    I'm so very annoyed, I've been having this issue for many years now. I've sought help for many years now with no real fix.

    I go to File Explorer and Network and even though there is 3 computers all connected to the same router, all marked as private with sharing turned on....only 1 computer shows.

    I've done a Network Reset...I've restarted the computers...I've disconnected from wifi and reconnected to wifi...plugged both PCs directly into the router...I've run commands in command prompt...I've done practically everything I could find online.

    The one computer I'm trying to reach almost always doesn't show up...sometimes it does...it's usually hit or miss every time I turn on the computer.

    Both computers are running Windows 10 with the most current updates...Before they took homegroups away my problem was with that...I was hoping now that there is no more homegroups I wouldn't have problems anymore but I do

    I'm in need of serious help...I just want to be able to connect to the computers without constantly having issues.
      My ComputerSystem Spec

  2.    22 Jun 2018 #2

    Can you ping the PC via name or IP is NetBIOS running on all PC's try turning off ipv6 it's not used
      My ComputerSystem Spec

  3.    22 Jun 2018 #3

    Hey Arily,
    If you haven't already ... check the following 2 windows services on all your W10 PC's ...

    Function Discovery Provider Host - Running | Startup is Automatic (Delayed Start)
    Function Discovery Resource Publication - Running | Startup is Automatic (Delayed Start)

    Note: It can take a couple of minutes for the PC's to show up in File Explorer > Network
      My ComputersSystem Spec

  4.    22 Jun 2018 #4

    Ok I checked, Only Function Discovery Provider Host is Running and it says Startup Manual...

    So I change both services on all PCs to Automatic (Delayed Start)?
      My ComputerSystem Spec

  5.    22 Jun 2018 #5

    So I change both services on all PCs to Automatic (Delayed Start)?
    Yes ... and if you're not rebooting, make sure they are running.
      My ComputersSystem Spec

  6.    22 Jun 2018 #6

    Thank you, I'll post back if this works, I can already tell just setting the 1 to running made my computer finally pop up in the list...Now I have to go around and change like 5 computers...rofl

    Ok now I see the computers showing up but says cannot access with the Diagnosis button...However whenever I run diagnosis it always comes back and says it doesn't find any issues.
      My ComputerSystem Spec

  7.    22 Jun 2018 #7

    Ok now I see the computers showing up but says cannot access with the Diagnosis button...However whenever I run diagnosis it always comes back and says it doesn't find any issues.
    A lot of people are having that issue with 1803 (i.e accessing shares by \\PCNAME). You should be able to access them by \\IPADDRESS. If you can't access them by \\IPADDRESS, then something else is going on.

    Note:
    1. Running Diagnostics in this case is a waste of time.
    2. I would reboot all PC's (just for sanity check) and give them some time to see if you can access them by \\PCNAME.
    3. If that doesn't work, then disabling IPv6, might work for you.
    4. If all your PC's have Static IP's, you could just map them (i.e. map a network drive)
      My ComputersSystem Spec

  8.    22 Jun 2018 #8

    Thank you Eagle
      My ComputerSystem Spec

  9.    22 Jun 2018 #9

    You're welcome, let us know how things go.
      My ComputersSystem Spec

  10.    23 Jun 2018 #10

    Thanks!


    I have been searching for a solution to the disappearing network shares on our MS domain for over a month! I tried other tips but to no avail. Finally I can see all the network shares. Now if I can just get the NAS drives to show up as well I'll be set (WDs)
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Installed a new modem/router combo, now none of the local network computers show up under Network in Files Explorer. I have a Pro tablet, a laptop, and 2 desktops on the home network. I am "guessing" it has to do with some modem setting, not a clue...
Preface: I am running a laptop which I upgraded from windows 7 to windows 10. I also have a desktop that is still running windows 7. One of the hard drives on my desktop is shared, and I often-enough will copy files from my laptop to my desktop. ...
Windows Network does not show computers, but I have a batch file that will load them and log in. I have used Credential Manager to set up accounts and if I try to log into a computer from "Run", it still requests a password. Both these issues are...
As the title says. I can reach them by the quick access shortcuts I added before the upgrade but they don't show up in WE Network. Rebooting my WD MyCloud solves the problem until next time I reboot my Win10 c.
Hi everyone! Just got an ASUS ZenBook UX305 and am having trouble mapping network drives as I can't connect to the devices via explorer (either in the list in Network under "computers" or my manually browsing to the device name or the IP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:09.
Find Us