Cellular Disconnected Solved

Page 1 of 2 12 LastLast
  1. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
       11 Jun 2018 #1

    Cellular Disconnected


    I have a cellular modem in my Dell Precision 3520. I used it Friday without any problems at all. Today, as I'm at work, I cannot connect to AT&T's cellular network.

    When I click the network icon in the system tray, it shows my cellular connection as "AT&T (HSPA)" and then reads "Disconnected" underneath it. It shows 5 bars. If I open network properties and try to troubleshoot the adapter, it gives me a SIM2 error that says I need to enter a PIN code (there is no PIN code on the SIM card, but just for troubleshooting purposes I added one, still got the same error, and then ultimately removed it again).

    Things I have tried so far:
    • Toggling cellular on/off
    • Rebooted computer (several times)
    • Uninstalled and reinstalled the driver (twice)
    • System restore to the point where it was working the other day
    • Ejecting the SIM card and reinserting it
    • Verifying that data is turned on with my AT&T count
    • Enabling/disabling PIN code
    • Resetting network settings via command prompt
    • Creating a new APN (with phone, NXTGENPHONE, etc.)


    Any tips?
      My ComputerSystem Spec

  2. bro67's Avatar
    Posts : 5,035
    Mac OS High Sierra 10.13.5
       11 Jun 2018 #2

    if you are roaming and on ATT's network, contact them. If you have been making changes on the modem, it can cause issues and even possible that your modem is bad or the network is down.
      My ComputerSystem Spec

  3. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
    Thread Starter
       11 Jun 2018 #3

    I never thought about it being the network. The hospital has a tower/repeater they purchased for the hospital. I'm betting that's causing some problems. My iPhone X connects and can get data without problems though. I try to use the cellular connection because it's sometimes faster than the hospital's wifi system.

    I haven't made any changes to the modem. I turned on roaming this morning while trying to troubleshoot everything.

    Hopefully not a bad modem. Confusing that it shows 5 bars, so I'm hoping that it's not the modem.
      My ComputerSystem Spec

  4. bro67's Avatar
    Posts : 5,035
    Mac OS High Sierra 10.13.5
       11 Jun 2018 #4

    If the internal cellular repeater is causing it, get with the IT unit that runs the hospital and have them help diagnose what is going on. Roaming only works if you are not on a U.S. based network that does not have a roaming agreement with your carrier.
      My ComputerSystem Spec

  5. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
    Thread Starter
       11 Jun 2018 #5

    Wasn't the tower. Still doing it. I called AT&T and he said he sees it online.

    So now it's down to a hardware or firmware issue. Nothing has changed with my setup unless something was autoupdated. I would think a firmware issue would have been fixed with a system restore. Going to take the cover off the laptop in a bit and examine it.
      My ComputerSystem Spec

  6. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
    Thread Starter
       11 Jun 2018 #6

    I've popped out the SIM and put it back in. Took the cover off the bottom of the laptop and examined everything -- everything is still connected. I reset network settings from scratch. Still no connection.

    When I run the troubleshooter to diagnose the problems, it's giving me a SIM PIN2 error. I don't see where I have an option to enter it anywhere in Windows 10.
      My ComputerSystem Spec

  7. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
    Thread Starter
       11 Jun 2018 #7

    Weird, it started working again on its own. Not sure if I should rejoice or if I should be worried!
      My ComputerSystem Spec

  8. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
    Thread Starter
       08 Sep 2018 #8

    This has reoccurred after Windows updated the Sierra modem cellular driver. I'm going to get a new SIM card today to see if there is some issue with a previous PIN I had placed on it (and later removed).

    I haven't rolled back to a restore point yet, but I'm considering it.
      My ComputerSystem Spec

  9.    08 Sep 2018 #9

    ericnixmd said: View Post
    it's giving me a SIM PIN2 error.
    Note that isn't the same as PIN1 which is the 4 digit key you lock it with (or the PUK you use to reset a forgotten PIN). PIN2 it is another separate unlock code that lets you call a fixed set of numbers only.

    There is a lot of threads blaming sleep for the issue - I couldn't see any fix but replacing the SIM or trying it in another device (your iPhone for example) and accepting the settings seems to clear it according to here:

    Problem with Cellular (SIM PIN2) - Lenovo Community
      My ComputerSystem Spec

  10. ericnixmd's Avatar
    Posts : 270
    Windows 10 Pro for Workstations
    Thread Starter
       08 Sep 2018 #10

    New SIM card solved the problem. Not sure if the previous SIM card was damaged someway, if a previous PIN I placed on it (and later disabled) was causing the problems, or if it's a random event that a new SIM corrected it.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hello, I use a 3G SIM card to connect to network. Now suddenly it stopped automatically connecting to it. When I go to Network & Internet / Cellular / there are check boxes for connect automatically and allow roaming. It doesn't seem to...
Source: Device innovation opportunities in mixed reality, gaming, and cellular PCs - Windows Experience Blog
Hello Everyone, I hope you're all doing well :) I have a 2GB/month data connection on a ZTE USB 3G modem. When I connect, it shows up as a dialup connection in Windows 10, meaning that there is no way for me to make it a metered connection....
....... in my case the Mobile Hotspot turn on and off button is greyed out (see screenshot). https://www.tenforums.com/tutorials/46954-mobile-hotspot-turn-off-windows-10-pc.html 95087 Running this command : netsh wlan show drivers Shows:
I have a telstra dongle but the drivers still haven't been released for windows 10, I found a hotfix (see here: Telstra USB and Windows 10 Incompatibility - Telstra Crowdsupport - 485835) but because the computer doesn't have a wifi card or cellular...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:22.
Find Us