Windows 10: Can't see other devices in Network browser after 1803

  1.    19 May 2018 #1

    Can't see other devices in Network browser after 1803


    Hey,

    I have two machines that were updated to 1803, other than that I have few NVIDIA SHIELDs on the same network.

    On the first Windows machine I took the next steps and devices & computers re-appeared on my network browser. On the second machine no matter what I've tried, the other devices are missing.

    Here's what I've tried so far:

    1. Network reset
    2. Made sure Network Discovery is ON
    3. Uninstalled and reinstalled my SMB 1 stuff from "Windows Features". (Restarted Windows)
    4. Tried:
    pconfig /flushdns
    ipconfig /registerdns
    ipconfig /release
    ipconfig /renew
    netsh int ip reset
    netsh winsock reset
    5. Read about turning "Function Discovery Resource Publication" on but that wouldn't help in my case as I have non Windows devices that uses SMB that my Windows machine can't see.
    I should add that on the Windows machine that see all the other devices "Function Discovery Resource Publication" is also turned on.

    That's it. Computers and devices aren't seen. I can access them with \\192.... but they are not displayed in the Network Browser.

    I've read all about Microsoft removing homegroup in 1803 but because I made it work on one machine I hoped it would also work on the other.

    Any help would be appreciated.
      My ComputerSystem Spec

  2. Clintlgm's Avatar
    Posts : 832
    Win 10 pro Upgraded from 8.1
       19 May 2018 #2

    I'll assume that you have you P2P workgroup set up correctly with shares and the Security taps set with the proper permissions?
    I'll link you to this thread it covers all the different things that need to set correctly. Computers can't see each other after upgrade to 1803 Solved - Windows 10 Forums

    BTW I have 4 computers 3 on 1803 and one on 8.1 SMB 1 is turned off on all. They all communicate with each other and show up in computer/drives list and devices so it is possible
      My ComputersSystem Spec

  3.    19 May 2018 #3

    Thanks. I've gone through that thread without success. I can't turn off SMB 1 as my streamers around the house relay on it.
      My ComputerSystem Spec

  4. Clintlgm's Avatar
    Posts : 832
    Win 10 pro Upgraded from 8.1
       19 May 2018 #4

    Well I would follow that thread as its the most active and likely to come up with the solution
      My ComputersSystem Spec


 

Related Threads
Lost network after 1803 update in Network and Sharing
I have 2 PCs on a network Both are Windows 10 pro with 1803 update. They both worked fine on the network before the update. I get this error message on both PCs. 187548
I have 4 Computers that I successfully networked together (wireless I may add). Everything worked well until that latest update and now the Network is totally blown. I can understand the need for updates, but must Big Brother reset my Computers...
Restarted my computer to find i can no longer connect to network folders. I have a NAS system which shows up under Nwtwork Locations however i had two additional folders that lead to my NAS's Music folder and Movies folder. Those became...
Hello everyone, I have just updated my windows from 1703 to 1803, now I dont see my Hard disk and media WDplayer Live hub anymore. I have WDTVLive Hub connected and a harddrive. normally shows up in my windows explorer, without I have to install...
After the large recent update to Windows 10, my HP Pavilion dv7 laptop no longer will open USB storage devices like SD cards or USB harddrives. The device is recognized and appears in the file browser, but when I try to open it, it is forever in...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:34.
Find Us