Computers can't see each other after upgrade to 1803

Page 10 of 11 FirstFirst ... 891011 LastLast
  1. Ztruker's Avatar
    Posts : 10,230
    Windows 10 Pro X64 1909 18363.815

    Prefer IPv4 over IPv6 doesn't help with the connectivity problem, at least not for me. SO far nothing has helped.
      My Computers

  2. Posts : 4
    Windows 10

    For everyone's information

    Just had a client that got back to me with this from the accounting software people he uses acknowledging that microsoft have a problem

    Finally some answers

    Hope this info can help people get to the bottom of this issue.... apologies if this info is already available I haven't got time to go through the whole thread

    With regards to your re-occurring data corruption issues you have encountered recently, we've found that Microsoft have confirmed that they have received multiple reports of problems accessing database servers from within applications after updating Windows 10 to the latest version 1803. This same issue is being reported in DataFlex, VB6, VB.NET, Delphi, and other languages as well.

    The Version 1803 issue in detail

    It appears that Microsoft has introduced a bug or security feature that prevents applications started from SMB v1.x network shares from making network connections. This means that applications started from these environments can’t open a connection to a database server. In fact, they can’t perform any other types of network calls either.

    This problem most commonly occurs when Windows 10 clients access a custom application from a mapped drive on Windows Server 2003. Unfortunately, there doesn’t appear to be a way to upgrade Windows Server 2003 to use a newer version of the SMB protocol. The only workaround in this environment is to copy the application executable to a local disk and run it from there.

    We’ve also seen this occur where clients have a Linux-based NAS that they use via a mapped drive to start their application. On most of these devices, it’s possible to upgrade the version of the SMB protocol that is served by the NAS.

    There are also some reports that in this same scenario (executable started from SMBv1 share), command line parameters are not always accessible within the application. We haven’t yet confirmed this ourselves, but we’re closely watching these issues and will update this post if and when more information becomes available.

    How to fix the issue

    Update 2018-05-15: There have been multiple reports that installing Avast Free Antivirus seems to fix the issue points to the issue being related to a Windows Defender engine update that was pushed out with Version 1803. By installing an alternate antivirus, Windows Defender is disabled, resolving the issue. This might be a stopgap measure for companies stuck on a Windows Server 2003 setup.

    For newer versions of Windows Server or Linux, upgrading from SMB v1.x to SMB v2.x or v3.x also fixes the issue. There's been no official word on the reason for this change, so it's still possible that it is a bug rather than a new security measure.

    Update 2018-06-04: Microsoft has acknowledged this issue. They haven’t outright called it a bug, but it is being treated as a “hot issue”. This is a term Microsoft has used for over a decade to refer to breaking issues that are not yet rectified. Most people being affected by this issue have settled on upgrading the version of SMB used on their system. Unfortunately, many are stuck on Windows Server 2003 for a variety of reasons. For these, running their software locally seems to be the easiest solution. A powershell script can be used that copies the executable locally and then runs it and cleans up after the app has closed (you’ll need to adjust the network path and executable name to make this work for you):

    powershell -Command "Copy-Item '\\vmxp\test\putty.exe' $env:TEMP ; Start-Process -FilePath ($env:TEMP + '\\putty.exe') -WorkingDirectory '\\vmxp\test\' -Wait ; Remove-Item ($env:TEMP + '\\putty.exe')"

    This only works where there is a single monolithic executable though, and can cause issues in some applications. YMMV. We will continue to update this blog post as new information, workarounds, or finally a solution becomes available.

    Update 2018-06-13: User Murray3 has discovered how AVG/Avast! fixes the issue. Apparently it’s related a File System Filter Driver which is part of the mechanism that antivirus applications use to do realtime scanning of files. The workaround that Murray3 has developed unfortunately requires making use of copyright protected files from the Avast! installer, so we can’t advise this workaround as a permanent solution, but if you’re in a pinch…

    But even more encouraging is that Microsoft has now acknowledged that a fix is currently in the works:

    Hopefully we’ll have a permanent fix from Microsoft in the next few weeks.

    Update 2018-06-26: As promised, Microsoft has released an update to fix this issue. In our internal testing it completely rectifies the issue.

    Based on the above this suggests that the following Windows update should correct this issue,

    Further to the above, can you please answer the following points:
      My Computer

  3. DrSysop's Avatar
    Posts : 214
    Microsoft Windows 10 Pro 64-bit Version 1809

    So there is no fix for this yet? I am going to roll back to 1709 as I cant share any folders & having same issue after 1803 installed.
      My Computer

  4. Ztruker's Avatar
    Posts : 10,230
    Windows 10 Pro X64 1909 18363.815

    Correct, there is no fix yet.
      My Computers

  5. noquiexis's Avatar
    Posts : 19
    Inspiron 530: Windows 7 (64), XPS 8920: Windows 10 (64)

    On another topic, I detailed how my Windows 7 computer can 'see' my Windows 10 computer, but cannot read from or write to any of the Windows 10 shared directories ("folders"). The Windows 10 computer has full read/write access to my Windows 7 shared directories. This condition started with some Windows Update that came in after I posted my last message on this topic (Reply #69 on 17 May 2018). On the topic linked above, I found it necessary to block one user after a very snotty reply. This is a help forum, not a berate forum.

    It is an annoyance to only do file sharing from one of the computers, even though they are in the same room and hardwired on Ethernet cable. My 'solution' was to just use the Windows 10 computer for file sharing.

    In the light of this most recent information, I have to wonder if Microsoft is ever going to pull their head out and make Windows as good as it was back in the days of Windows 95. Home Networking was a breeze back then.
      My Computer

  6. Ztruker's Avatar
    Posts : 10,230
    Windows 10 Pro X64 1909 18363.815

    Agreed. In my opinion this is the most serious problem Microsoft has with Windows 10 right now. It affects everyone who has more than one computer and wants to share data between them yet there has not been a single mention anywhere that they acknowledge it's a problem or that they are working on a fix.
      My Computers

  7. Posts : 984

    Early in this thread someone mentioned Function Discovery Resource Publication, and said that it should be set to Automatic, and then started.

    Well, it's set to manual on both Windows 10 computers here (one laptop, one desktop, both on wired networking). And it's not running on either one.

    I had never before even heard of Function Discovery Resource Publication. Yet we have no problem sharing.

    I can mount shares in both directions.
    I can run VNC viewer on either one and "see" the other.
    I can run rsync to copy files from the laptop to the desktop.
    I can ssh from either box to the other.

    All without Function Discovery Resource Publication turned on.
    So is Function Discovery Resource Publication really relevant?
    If so, please explain how and why?
      My Computer

  8. Ztruker's Avatar
    Posts : 10,230
    Windows 10 Pro X64 1909 18363.815

    Set to Automatic or not, running or not, sharing still doesn't work for me consistently. Some time it does, some times it doesn't. Some times I can see the other computers, some times not. Nothing I've tried. and I've tried every suggestion I've seen, has made any difference.
      My Computers

  9. DrSysop's Avatar
    Posts : 214
    Microsoft Windows 10 Pro 64-bit Version 1809

    There is a 1803 OS bug with sharing between PC's. If you need to use that only way for now is to roll back to 1709 by downloading the ISO & install over 1803 & your HomeGroup will return also & no more issues till they fix this problem.
      My Computer

  10. f14tomcat's Avatar
    Posts : 47,373
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)

    DrSysop said:
    There is a 1803 OS bug with sharing between PC's. If you need to use that only way for now is to roll back to 1709 by downloading the ISO & install over 1803 & your HomeGroup will return also & no more issues till they fix this problem.
    Not quite that drastic a measure is needed. Maybe some tips and hints here would help. Rich has probably been thru it, and all the other posts, too. Just sharing it with you, in case you need.

    P.S. - Homegroup is not going to be fixed or come back. It's dead. Removed. Gone.

    Share Files and Folders Over a Network in Windows 10 | Windows 10 Tutorials
      My Computers

Page 10 of 11 FirstFirst ... 891011 LastLast

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:40.
Find Us

Windows 10 Forums