Progressively Slower Internet Despite Many Attempts to Resolveth Issue

Page 2 of 2 FirstFirst 12

  1. Posts : 9
    Windows 10 64 Home
    Thread Starter

    Thanks again for the comments.

    I have attached a couple of interesting graphs - CPU activity and Disk C activity during a very slow internet download via Firefox. To do this, I have to open Task Manager and the Performance tab before starting the download - otherwise I cannot get the Task Manager to open.
    When the internet download stalls - or almost - so does the Task Manager's update process - ie the graphs stop moving right to left - or at least hesitate for long periods like 15 or 20 seconds. Once the download completes - if it does - the CPU and Disk C activity remain high for about another 30 seconds before settling at lower levels. If I close Firefox, the disk and CPU activity also remain at a high level for about 30 seconds before reducing. The system disk (C) activity in presumably far too high. The disk is a Samsung SDD PM830 mSATA 256GB.

    Click image for larger version. 

Name:	Disk1.jpg 
Views:	25 
Size:	124.2 KB 
ID:	187940

    Click image for larger version. 

Name:	CPU.jpg 
Views:	25 
Size:	143.0 KB 
ID:	187941
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 13,717
    Windows 10 Pro x64 Build 1809

    Sorry for the delayed response.

    Since you have a Samsung does it use the Samsung Magician and if so have you run it to see what it says?

    Is TRIM enabled?

    Is there a Samsung driver fro your device?

    How much free space is there on C: ?

    I think you also have a V: partition, is it in use?
      My ComputerSystem Spec

  3. Posts : 9
    Windows 10 64 Home
    Thread Starter

    Thanks again for the comments.

    I have installed Samsung Magician and run a performance benchmark on the SSD (C drive). The results were 508MB/s read and 250Mb/s write - which I think is OK. Magician also "stronly recommended" the message contained in the image below - which I do not really understand.

    Click image for larger version. 

Name:	samsung_magician.jpg 
Views:	1 
Size:	146.4 KB 
ID:	188646

    TRIM is enabled.

    The SSD driver must at least be a suspect in all this. The update driver system in Windows reports that the most appropriate driver is already installed, but it has a date of 21/06/2006 - which seems ancient. I have not been able to update it because I cannot find an updated version for this disk. However, I have just unearthed a "firmware upgrade" for the disk. Current firmware on the PC is version CXM13D1Q whereas the suggested upgrade has version number CXM03D1Q with a date aof 2016. The verion number seems to have decreased! - worrying? Anyway, I have yet to discover how to upgrade the SSD firmware.

    There is 87GB free space on the SSD.

    I don't know the purpose of the V partition but I have a vague recollection that it was automatically created by a backup system a long time ago.

    I'm somewhere near the limits of my understanding with the firmware issue and the above message from Magician, but I feel we might be getting closer to the basic problem. I hope so.

      My ComputerSystem Spec

  4.    #14

    21/06/2006 just means that a generic, Microsoft-supplied driver is running. Here's a Microsoft Developer post that explains why this is: Why are all Windows drivers dated June 21, 2006? Don The Old New Thing.
      My ComputersSystem Spec

  5. Caledon Ken's Avatar
    Posts : 13,717
    Windows 10 Pro x64 Build 1809

    You are looking at driver for disk drive, mine is the same.

    The driver it is referencing is the storage controller, Intel IRST driver.

    I followed link and it is version 16.xx.....

    I'm trying to find your device PM830 and it is not listed on Samsung site. I see it in your screen print from Magician so I know it is right.

    Your driver is not that much out of date. Do you have a backup of your system as an image with boot disk to apply image.

    Magician would do the firmware update, or it should. There should be an update button. Updating firmware can cause data loss so you also need image backup for this.

    What BIOS is on your system. Try option 3 from this link.

    Several post back I had mentioned running those commands one at a tile to determine what is being cleared. Have you tried that.
      My ComputerSystem Spec

  6. Posts : 9
    Windows 10 64 Home
    Thread Starter

    OK, thanks for all replies once again. I appreciate the trouble people have gone to in order to help.

    Yes, BIOS is up to date, and I did try running the commands you kindly suggested.

    I think (!!!) that I have now solved this problem but I have to wait a few more days to be absolutely confident. I found a Dell "update" that just uninstalled the Intel Rapid Storage technology software. When I restarted the PC - Bingo! It now runs as fast as I would expect given the limitations of my 7MB connection. When I look at the C disk (SSD) activity while loading a web page it is now just a blip of activity over a couple of seconds. Previously the disk showed 100% activity for up to one minute when loading the same web page.
      My ComputerSystem Spec

  7. Caledon Ken's Avatar
    Posts : 13,717
    Windows 10 Pro x64 Build 1809

    Hey that is great news. Thanks for posting your solution.
      My ComputerSystem Spec

  8. Posts : 9
    Windows 10 64 Home
    Thread Starter

    Not such great news unfortunately! The PC was fine for about 24 hours and then I did a large upload - about 1GB. After that, it was back to its impossibly slow self once again. The upload went well, much faster than recently, but processing large quantities of data, seemingly in more or less any manner - even off-line, seems to bring the problem of slow internet back.

    However, there does appear to be a difference now. The disk C (SSD) activity during a webpage load is now quite modest, whereas it was 100% for an extended period before I uninstalled IRST. Nevertheless, the CPU activity is still very high for quite a long period for every (slow) webpage load.

    I'm guessing that the IRST was causing a significant problem but that a further significant problem has yet to be found.
      My ComputerSystem Spec

Page 2 of 2 FirstFirst 12

Related Threads
I had to do a fresh install because of a windows update glitch and now my internet speed went from 80-90mbps down and 15mbps up to 12 down and 6 up. I have updated all my internet drivers through device mgmt, restarted it to see if it needed it to...
i have a AC600 wifi adapter and a ASUS rt-ac1200g+ router, we pay for 100mbps down. i can hit 30mbps on the wifi adapter but when i try ethernet it is locked at 10mbps at full duplex which is really weird. i have tried cat5e/6/7 but all does the...
Despite "Network & Internet Settings > Dial up" shows the status "connected" , the yellow icon with exclamation point (! ) on task bar shows the opposite , there is neither access to internet and nor navigation. I have to disconnect and...
Hi all. I have a weird problem with my internet connection. After i had instaled win 10, my interned slowed down. Before i had speed around 50 mbps (old result under) Now my speed is 10-15 mbps - no more....
I have a desktop pc in room 1 which up until now has been connecting fine to the internet via WiFi from the router (DrayTek Vigor2710ne) in room 2. I was getting acceptable speeds using WiFi but in an effort to see if I could get a faster...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:17.
Find Us