I have a QNAP NAS box set up in RAID5 with 6 Shared folders. I have 3 computers, 2 of which have no problem mapping drives to all 6 folders (1 workstation runs W7Pro & the other W10Pro). My 3rd workstation (running W10Home) can map 5 of the 6 shared folders. The 6th shared folder it refuses to connect, asking for a new user name & password each time I try to connect (other user names don’t work either). The error message tells me to disconnect any existing mappings and try again (paraphrasing).

I have disconnected all the other shared folders, rebooted and tried again. It still won’t map the shared folder. All 6 of the shared folders on the NAS were created at the same time with the same properties and permissions.

All 3 computers are set up identically, with identical settings for network (other than static ip addresses), credentials, user access, services, anti-virus software. I am thinking it is a ‘feature’ of Windows 10 Home. If I can’t get it solved in the next 4 days, I will upgrade to W10 Pro.