First Windows Update, now WiFi not working properly Solved

Page 1 of 2 12 LastLast
  1.    08 Apr 2018 #1

    First Windows Update, now WiFi not working properly

    Hi everyone!

    I noticed some months ago that Windows Update was not working properly. While fully connected to the internet, it told me: "we cannot connect to the updateservice ..." Looking at my internet connection, I noticed that inside Windows Settings it told me that I was not connected, while the WiFi icon in the taskbar showed an active connection. When clicking on the WiFi symbol, it showed my SSID with the words 'Connected, Secure'.

    In an attempt to solve this issue, I searched on some forums and tried some changes in the register and commands (like ipconfig /flushdns and netsh winsock /reset). Eventually I decided to reset the network via Windows Settings, after which my WiFi did not appear at all anymore.

    Connected to the ethernet, I downloaded the latest drivers of my WiFi-adapter (Intel Dual Band Wireless-AC 3160), and installed these. After restarting my computer, at first the WiFi did not work, but after a view minutes it just popped up randomly and started working. Now, every time I restart my computer, the WiFi-adpater is not available at first (it shows the ethernet sign with a red cross in the taskbar), and appears after a few minutes.

    Is anyone familiar with this phenomenon? How do I fix this WiFi-problem, and (after that) the Windows Update problem? It might be interesting to add that Microsoft Store did not work either at first, but when I updated the computer manually about a month ago (via the Microsoft Catalogue), this started working again.

    I hope anyone can help me!
      My ComputerSystem Spec

  2.    08 Apr 2018 #2

    You could try removing your WiFi adapter in Device Manager and restarting your computer. This should reinstall the driver.
      My ComputerSystem Spec

  3.    08 Apr 2018 #3

    Thanks for the quick reply! I have tried this again (I had already tried this, sorry for not telling!), and it still gives me the ethernet sign with a red cross for a minute or two after restarting (even after restarting twice!). Any other suggestions? For me, it feels like it reinstalls the drivers after every reboot..,
      My ComputerSystem Spec

  4. Clintlgm's Avatar
    Posts : 910
    Win 10 pro Upgraded from 8.1
       08 Apr 2018 #4

    Go to the manufactures website either your computer or the Lan Card and from there support website download there the latest driver for your LAN or Wi-Fi Card. some hardware devices do not play well with windows native drivers
      My ComputersSystem Spec

  5.    09 Apr 2018 #5

    Thanks for your suggestion! I deleted the newest Intel ProSet/Wireless Software, deleted the drivers via Device Manager, restarted, installed the old driver from the manufacturer's website (from 2015...!), restarted again, but the problem persists: it takes about 2 minutes before the WiFi symbol appears in the task bar. And Windows Update still tells me it cannot connect to the updateservice...
      My ComputerSystem Spec

  6.    09 Apr 2018 #6

    For the Windows update problem, try the update troubleshooter.

      My ComputerSystem Spec

  7.    09 Apr 2018 #7

    Running the Windows Update Troubleshooter, I get error message 0x803C0103. Googling this error message, I see the suggestion of running a system scan (sfc /scannow). This does not result in any integrity violations ("Windows Resource Protection did not find any integrity violations"). I also see the suggestion of running a clean boot. Doing this prevents my WiFi from coming up at all (I guess there's a service doing this, that is now disabled), and after manually reinstalling the WiFi driver so that I have an internet connection, Windows Update still cannot connect to the updateservice.
      My ComputerSystem Spec

  8.    09 Apr 2018 #8

    See I suggest you skip the troubleshooter step, since you've already done that.

      My ComputerSystem Spec

  9.    10 Apr 2018 #9

    Thanks for sending the link. I have gone to every single step that is stated on the website, but nothing has changed. I am now on the most recent version of Windows by manually updating, but still the WiFi symbol appears after only two minutes (so strange!) and Windows Update still does not work.
      My ComputerSystem Spec

  10.    10 Apr 2018 #10

    Update: I solved the WiFi being delayed by going to services.msc and setting the WLANAutoConfig service to Automatic (this was set to Manual for some reason). Windows Update still cannot connect to the updateservice
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
Hi there I have a folder / key in Regedit that I want to delete -- have given all privileges Exit regedit enter regedit again -- previous entry STILL in the registry -- same after reboot/ How do I SAVE changes -- if this tool is broken...
After the Anniversary update (version 1607 via Windows Update), Search doesn't work properly. (I have re-started again). If I enter a search term ("Restore") on search bar next to the Start Button I get Best match: "Recovery, Control Panel" at the...
I have a HP beatsaudio laptop, it has just installed the windows 10 anniversary update, due to the location of my office I use a wireless extender since this update has installed I cannot get any internet connection via this, if I diagnose this...
Hi All, I have been battling an issue with Windows 10 every night for the last 2 weeks. I apologise for the long post but will try to provide as much detail as possible. Initially I had a critical error warning which stopped me accessing the...
start not working properly after update in Windows Updates and Activation
After i have installed the last set of updates, i can no longer left click on start. When i click on the option to choose start up apps, everything is greyed out.

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:11.
Find Us