Windows 10: NAS / Linux users and Spring update edition SMB1 settings changed Solved

  1.    07 Apr 2018 #1

    NAS / Linux users and Spring update edition SMB1 settings changed


    Hi folks

    Ms in the Spring edition update (1803) have changed the SMB settings again -- there's no option this time (thankfully) to "auto disable SMB1" but you have to enable it and re-boot. Then sharing works again (BOTH WAYS)

    I think Ms were a bit too hasty in trying to kill of SMB1 - loads and loads of NAS servers and Linux distros still use it although some newer kernels have got support for SMB3 - I haven't got that working yet so I'm just leaving well alone --it's not critical files I need to share just some data and multi-media stuff.

    I've currently got 2 NAS servers (Linux servers) and the Spring edition Windows machine on network currently -- all computers now can see and access each others shares.

    Click image for larger version. 

Name:	smb.png 
Views:	1 
Size:	50.8 KB 
ID:	183772

    Click image for larger version. 

Name:	smb1.png 
Views:	0 
Size:	91.9 KB 
ID:	183773

    Cheers
    jimbo
      My ComputerSystem Spec

  2.    07 Apr 2018 #2

    Mine has the option to use SMB 2 and 3 and I've set it to use 3.
      My ComputersSystem Spec

  3.    07 Apr 2018 #3

    Hi there @swarfega

    In SAMBA conf I've tried it with setting SMB level to 2 / 3 on my servers but doing that after re-starting SAMBA I don't see any work groups so I just set it back and it's working fine. Remote TV's / amazon fire TV box also doesn't see files when SMB level set in SAMBA on the servers. I use KODI on my remote amazon fire TV to access multi-media on the server - no need for any streaming software on the server either. For Audio the DAC's in the latest amazon fire TV are very good too and can also go into a decent amplifier for music etc.

    I'm using CENTOS rel 7.2 which still has a rel 3 rather than rel 4 kernel but it's so stable I just leave it as it's just a file server and internet gateway. I'm messing around with a couple of other things for servers but the old boxes I'm running I'm just leaving until they drop dead !!! I don't run any applications on them - apart from some test VM's.


    ..............................


    ======================= Global Settings =====================================

    [global]
    ; max protocol = SMB3
    # can set it to SMB2 if you want experimental SMB2 support.
    #
    workgroup = WORKGROUP
    server string = Samba Server Version %v

    ; max protocol = SMB2

    log file = /var/log/samba/log.%m
    max log size = 50
    security = user
    passdb backend = tdbsam
    name resolve order = bcast host lmhosts wins

    load printers = yes
    cups options = raw


    ...............................................

    Cheers
    jimbo
      My ComputerSystem Spec

  4.    07 Apr 2018 #4

    I wonder if you might have more luck with other distros.
      My ComputersSystem Spec

  5.    07 Apr 2018 #5

    swarfega said: View Post
    I wonder if you might have more luck with other distros.
    Hi there

    Probably but these things run 24 hrs a day and never a problem -- am picking up a couple of boxes to replace these later this weekend with faster CPU's etc so I'll experiment then -- currently if I hose up family's access to Netflix, Sport channels, Amazon Prine etc -- my life won't be worth living !!!!!!!!

    Cheers
    jimbo
      My ComputerSystem Spec

  6.    07 Apr 2018 #6

    lol gl
      My ComputersSystem Spec

  7. Brink's Avatar
    Posts : 32,244
    64-bit Windows 10 Pro build 18242
       07 Apr 2018 #7
      My ComputersSystem Spec

  8.    07 Apr 2018 #8

    Should you not enable smb1 for security risk?
      My ComputersSystem Spec

  9. Brink's Avatar
    Posts : 32,244
    64-bit Windows 10 Pro build 18242
       07 Apr 2018 #9

    You would want to disable SMB1 to prevent a security risk.

    However, if your devices only support SMB1, you're stuck for now unless you can update or buy new devices that support SMB2 or SMB3 (recommended).
      My ComputersSystem Spec

  10.    07 Apr 2018 #10

    Ah got it. NAS connects with SMB3.
      My ComputersSystem Spec


 

Related Threads
Hi folks easiest install ever (did as a VM) However Network is broken -- it can't see any non Windows servers (can via IP address but doesn't work from file explorer. First screen shot is current running windows - finds and can access all...
Changed Windows Update Assistant Settings REDUX in Windows Updates and Activation
I am not sure regarding the etiquette of creating a new post similar to one I had before but I thought it best to separate a particular question from that previous post. Original post: ...
So I was perfectly fine earlier this month running 1703 (new notebook 12/17) even though 1703 I believe came out in April 2017 until MS hijacked (it turns out they did this to almost EVERYBODY) a few weeks ago and unceremoniously installed 1709....
Hey guys, my windows (10) was updated by himself and a lot of my settings were changed. Some I fixed and some I failed too. Can you help me change it back? I search for solution on the tutorial form but didnt find. 1. My colour settings were...
Solved October 2016 Cumulative Update Changed Settings in Windows Updates and Activation
Windows 10 Pro x64 laptop had updates set to automatically download and then notify. (Still using v. 1511 build 10586 due to continuing reported issues with 1607.) No problems with any updates prior to Oct 2016. Oct 11 cumulative update...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:04.
Find Us