Windows 10: Why 'Refused To Connect' ?

Page 1 of 2 12 LastLast
  1.    23 Mar 2018 #1

    Why 'Refused To Connect' ?


    I have a win10 machine.

    It has two adapters - one onboard ethernet and one plugin usb wifi.

    Both adapters are enabled and both seem to be working fine.

    The wifi is allowing internet access and here I am writing this via it.

    The ethernet has a wifi camera plugged into it and Wireshark looking at the traffic.

    Wireshark reports the camera at 10.0.0.126 asking who has 10.0.0.138 which would be the gateway it was configured to expect.

    And when I send a ping Wireshark shows that ping as going from 10.0.0.100 to the camera at 10.0.0.126 and getting a reply from it.

    (10.0.0.100 is the address I gave the adapter in IPv4 config earlier today. I gave a mask of 255.255.255.0 and provided no Gateway address nor DNS addresses. Because I am uncertain about what I should provide. )

    So all that looks fine to me.

    But if I ask my browsers to go to 10.0.0.126 they report that it 'Refused to Connect'.

    Still get the same result if I disable the wifi adapter in an attempt to force the browsers to use the ethernet adapter. Because I'm non too clear on how that bit works.

    But it doesn't help.

    What am I doing wrong? Any networking experts here can put me straight?
      My ComputerSystem Spec

  2.    23 Mar 2018 #2

    Is the camera wired or wireless? Can you ping from the command line, irrespective of what Wireshark sees? You might find this TomsHardware thread helpful: Not able to access ip camera within network - Networking.
    HTH,
    --Ed--
      My ComputersSystem Spec

  3.    23 Mar 2018 #3

    It is not quite clear the way I've written is it?

    What's happening is a wifi camera - a wireless camera - is plugged in via ethernet. So it's currently both.

    I don't know how to say it clearly and succinctly, I wish I did.

    Plugged into a pc, not a router.


    Yes I ping from the command line.in the usual manner. Wireshark just shows me that ping.

    I'll check that thread, thanks.

    Hmm. Didn't help.

    Just moved the camera to a different computer and tried it there. (Different ethernet cable). Still can't connect but can ping and Wireshark shows the camera as sending out query packets as usual. Different error message this time though:

    Unable to connect

    Firefox canít establish a connection to the server at 10.0.0.126.

    There's a possibility, of course, that the camera is broken somehow.

    Opera said this:

    This site canít be reached

    10.0.0.126 refused to connect.



    So I think I'm wrong in my interpretation of those error messages. They probably simply mean they can't even reach the thing rather than they reach it and handshake protocols fail or somesuch.

    But it pings okay:

    C:\WINDOWS\system32>ping 10.0.0.126

    Pinging 10.0.0.126 with 32 bytes of data:
    Reply from 10.0.0.126: bytes=32 time<1ms TTL=64
    Reply from 10.0.0.126: bytes=32 time=1ms TTL=64
    Reply from 10.0.0.126: bytes=32 time<1ms TTL=64
    Reply from 10.0.0.126: bytes=32 time<1ms TTL=64
    Last edited by abrogard; 23 Mar 2018 at 18:15.
      My ComputerSystem Spec

  4.    23 Mar 2018 #4

    If you just have a cable from the camera to the PC you may need a different pinout on that cable. It's called a "crossover cable" and it's explained here in this geekstogo.com forum post: Direct Connections with RJ45 crossover lead - Networking. I'll bet that's what you need to fix this issue.
    HTH,
    --Ed--
      My ComputersSystem Spec

  5.    23 Mar 2018 #5

    Well that's a good thought, Ed, but unfortunately it wouldn't be the case this time.

    All my cameras were originally set up by me in this way using the standard cables I have lying around. I have never used a crossover cable to connect to them.

    Note the connection is good insofar as a ping.
      My ComputerSystem Spec


  6. Posts : 8,031
    10 Home x64 (1803) (10 Pro on 2nd pc)
       23 Mar 2018 #6

    abrogard said: View Post
    What's happening is a wifi camera - a wireless camera - is plugged in via ethernet. So it's currently both.
    The camera has two network connections, there's nothing wrong in doing that. But each should have its own independent IP address, and they should be different addresses. If the camera is configured to use the same IP address for both its Ethernet and WiFi connections it won't work properly.

    This is what the command ipconfig shows for my PC when it is using both Ethernet and WiFi connections. Note the different IP addresses.

    Click image for larger version. 

Name:	Ethernet and WiFi together.JPG 
Views:	12 
Size:	43.2 KB 
ID:	182127
      My ComputersSystem Spec

  7.    23 Mar 2018 #7

    Hi...

    Yes, they do have different IP addresses. The two connections: The router via wifi and the pc via Ethernet.

    The camera itself has only one IP address. This address has been discovered by watching the Wireshark log of traffic when it was plugged in.

    It sent a query : 'who has 10.0.0.138 please tell 10.0.0.126'. i.e. 'tell me' i.e. I am 10.0.0.126

    That's how I find the IP for an unknown camera.

    You can see the ethernet adapter has been given an IP in the 10.x.x.x range by me to match the IP of the camera.
    The wifi adapter retains the original 192.168.x.x address it has always had ( and which is the subnet the internet router is on, of course)

    Click image for larger version. 

Name:	image.png 
Views:	12 
Size:	20.2 KB 
ID:	182128
      My ComputerSystem Spec


  8. Posts : 8,031
    10 Home x64 (1803) (10 Pro on 2nd pc)
       23 Mar 2018 #8

    What make and model is the camera?
      My ComputersSystem Spec

  9.    23 Mar 2018 #9

    It is a foscam clone.

    Looks like these: An original fi8908w and a clone side by side ~ Gadget Victims
      My ComputerSystem Spec


  10. Posts : 8,031
    10 Home x64 (1803) (10 Pro on 2nd pc)
       23 Mar 2018 #10

    abrogard said: View Post
    As a clone, did it come with any software? The genuine Foscam FI8908W came with their IP Camera Tool for setting it up. Their Quick Installation Guide is here: https://www.foscam.es/descarga/Camara_IP_FI8908W_Quick_installation_guide_for_Windows.pdf

    The genuine Foscam software is available here: http://www.foscam.eu/index.php/produ...chments/v/284/
      My ComputersSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I have a FIVE tasks scheduled to run daily. They worked correctly on Windows 8.1. When I converted to Windows 10, they do not work. I get the error message "The operator or administrator has refused the request (0x800710E0)". Why won't they...
I was asked to download update, using win 10. Did that. everything worked fine. MS pass word worked fine. Went to go off line, close edge and it refused to close. Left computer on for hours, went back pressed on key, still the same problem. so...
has anyone a hint what this problem could solve: I have 4 computers in my lan. 1 win10, 1 win 7, 1 win2008 and a macbook with os 10.6 i want to establish a rdp session from macbook to win10. Result: no connect (but i can ping and telnet on port...
Solved Refused to Post after XMP Setting in BIOS in PC Custom Builds and Overclocking
Hi, Yesterday, I installed all mobo and other drivers plus various supporting software in my new build (#2 in spec with BIOS 1801). Four in the morning, all was done and I decided to end by going into BIOS to set the memory according to its 1200...
Network Connections Refused in Network and Sharing
Testing 2 PC's with 10 on a network of 24 users. Both machines were running 7 and updated prior to the upgrade. Both have reset network connections to some strange IPV6 setting including ## signs, wiping out the IPV4 settings. Now they wont allow...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 13:14.
Find Us