Windows 10: Network Issue

Page 1 of 2 12 LastLast
  1.    06 Feb 2018 #1

    Network Issue


    Both PCs are Win10 home 1709 16299.214

    PC1 can not see PC 2 unless I type the IP address of PC2 into File Explorer -> Network \\192.168.1.110 and all the shared folders are there. nothing shows while browsing the network if that makes sense?

    I am not using the Windows Homegroup.

    PC 2 sees both PCs and shared folders and works perfectly.

    thanks for any ideas.

    Edit: I just noticed SMBv1 was not installed on PC1. It is installed on PC2.

    I thought that was some sort of security issue and removed from Win10?

    going to shut down both PCs after enabling and see what happens.
    Last edited by mingus; 06 Feb 2018 at 22:00.
      My ComputerSystem Spec

  2.    06 Feb 2018 #2

    Hey mingus,
    For comparison ... Check both PCs to see if SMBv1 is installed. SMBv1 might have gotten uninstalled on PC1. If it's installed on PC2 and not PC1, then you can try re-installing it on PC1.
    Control Panel > Programs & Features > Turn Widows Features On & Off > SMB 1.0/CIFS File Sharing Support
    Click image for larger version. 

Name:	smb1.png 
Views:	22 
Size:	14.5 KB 
ID:	175935
      My ComputersSystem Spec

  3.    06 Feb 2018 #3

    SMBv1 was not installed on PC1. I set it up like this with Automatic Renewal unchecked, and Setup PC2 the same - all 3 were checked on PC2.

    shut down both and now working. Thank you. I followed the thread below.

    If it's a security risk and removed in latest Win10 version, why does it need to be installed?

    thanks again


    Edit: I guess I spoke too soon? now not able to browse either way unless I type the IP addresses of the PCs.

    I noticed SMBv1 was unchecked on PC1? checked them. rebooted. the same thing, now able to see the network PC unless I type the IP address. Thanks, Bill!

    Thanks for the help.
    Last edited by mingus; 06 Feb 2018 at 22:39.
      My ComputerSystem Spec

  4.    06 Feb 2018 #4

    If it's a security risk and removed in latest Win10 version, why does it need to be installed?
    SMBv1 was patched by MS, so the risk is low IMO, but you don't have to use SMBv1. You can use SMBv2 only and map a network drive. The Computer/Master Browser (which handles showing network shares) is tied to SMBv1, so when it's uninstalled network shares don't show in File Explorer > Network.

    Note: I havn't tested this lately, but I think you can leave SMBv1 installed, but disable it and still have network shares show in File Explorer > Network ... see link below for all the commands.

    https://support.microsoft.com/en-us/...in-windows-and
      My ComputersSystem Spec

  5.    06 Feb 2018 #5

    Why is it they showed up for 10 minutes and disappeared?

    strange how SMBv1 came unchecked and when I checked them nothing seems to install. I rebooted and SMBv1 is still installed, but no shares showing either way now?

    I'll look at the link you posted.

    thanks
      My ComputerSystem Spec

  6.    06 Feb 2018 #6

    Hmmm, that is a bit strange, not sure what happened
      My ComputersSystem Spec

  7.    06 Feb 2018 #7

    I shut both PCs down, restarted and working again?

    Thanks again, definitely learned something tonight.
      My ComputerSystem Spec

  •    06 Feb 2018 #8

    Your Welcome ... glad it's working for you
      My ComputersSystem Spec

  •    06 Feb 2018 #9

    Hey mingus,
    FYI ... If you want to test the two scenarios for SMBv1 & SMBv2 from that link I posted. All that stuff basically boils down to the following.

    Note: If you're not sure what the following does and how to undo it or you're just not comfortable doing it .... Then DON'T DO IT

    Note: This assumes that SMBv1 is installed ... if it's not then it will throw errors.

    Run PowerShell as Administrator and copy/paste the following

    Enable SMBv1 and SMBv2 ...
    Set-SmbServerConfiguration -EnableSMB1Protocol $true
    Set-SmbServerConfiguration -EnableSMB2Protocol $true
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
    sc.exe config mrxsmb10 start= auto
    sc.exe config mrxsmb20 start= auto
    sc.exe config browser start= auto

    Disable SMBv1 and Enable SMBv2 ...
    Set-SmbServerConfiguration -EnableSMB1Protocol $false
    Set-SmbServerConfiguration -EnableSMB2Protocol $true
    sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
    sc.exe config mrxsmb10 start= disabled
    sc.exe config mrxsmb20 start= auto
    sc.exe config browser start= disabled

    Reboot PC after running either of the above.
    Last edited by Eagle51; 06 Feb 2018 at 23:56.
      My ComputersSystem Spec

  •    06 Feb 2018 #10

    Click image for larger version. 

Name:	smbv1_reg.jpg 
Views:	3 
Size:	109.7 KB 
ID:	175944


    Will this change anything in the registry? maybe PC1 isn't really enabled at this point? can not see from PC2 now.

    I have never messed with PowerShell. seems straightforward. thanks.
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    Network Connection Issue? in Network and Sharing
    Something strange is happening here. I am able to connect to the internet/RDP/DB on my server, receive ping requests, but it's showing an exclamation mark on the network icon and when I view the network information it says: Unknown: The...
    Solved Odd Network issue in Network and Sharing
    1 x Desktop and 2 x laptops, 64 bit. Anniversary update done on all 3 machines. I now cannot access one of the laptops - network path not available , error code 0x80070035. Laptop in question has full internet access AND can access both desktop...
    Having a network issue in Network and Sharing
    Hi All, I have Windows 10 Pro (latest) on my main computer and Windows Home (latest) on my laptop. I also have ESET Smart Security on both. For some reason now I cannot access either way. I can see the laptop under Network on the main...
    Network Adapter Issue in Network and Sharing
    I have 2 adapters in my PC. One is to connect Internet and the other is for the Local Network. My problem after installing Windows 10 is - All my local connection are try first through the Internet Adapter and reports failed. For example If i...
    After installing Windows 10 the wired Ethernet adapter is missing from the device manager. I found similar threads in the forum but most of the answers concern downloading of drivers for the adapter. My question is how do I download the adapter. One...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 19:55.
    Find Us