EDIT: I rebooted the Win 10 PC and now the permission stick. I do not remember ever seeing that was needed.

I am on a Win 7 64 bit PC, wirelessly networked to a Win 10 Laptop PC.

I can see the other PC (at last) and can take data from it to my machine. But I can't send data to the other PC in any form: by editing a file, by copy and paste, etc.

I am logged in as Nick, with a password and Admin status (I assume: in all the setup mess I cannot remember if I was asked, although I have set up a passworded User called Nick on the Win 10 machine). So I have given that user Full Control (which seems to include Ownership) of the C: folder. In case I am NOT logged on as Nick, but just a User, I gave everything Full control. When I gave Full Control to simple Users, there were some errors in some sub-folders, but Full Control still shows.

I tried a batch file in Cmd Prompt that says :
SET DIRECTORY_NAME=C:\TAKEOWN /f %DIRECTORY_NAME% /r /d yICACLS %DIRECTORY_NAME% /grant administrators:F /tPAUSE

This ran successfully, but made no difference.

I tried turning off Passworded File Sharing in All Networks _and_ Private Networks: that seemed to actually _stop_ me from even loggng on to the Win 10 machine (??).

I know it sounds as if I have not tried many things, but this all took a lot of shuffling back and forth and learning _how_ to do each thing and so on.

I would vastly appreciate any help.

Nick