Windows 10: Windows updated - Map network drive can't find my computer Solved

  1.    06 Jan 2018 #1

    Windows updated - Map network drive can't find my computer


    Got the new update (Build 16299.192), went to map a folder on my computer and Browse for Folder did not list my computer or the Ubuntu computer, only my wife's is listed. The mapped drives I already have work just fine but if I want to add another folder and they are not showing up.
      My ComputerSystem Spec

  2. Berton's Avatar
    Posts : 5,289
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       06 Jan 2018 #2

    Similar problem, suddenly over last couple of days my NAS drives can't be mapped and File and Printer Sharing won't turn on. They do work fine on other computers with same update.
      My ComputerSystem Spec

  3.    07 Jan 2018 #3

    Might be the SMBv1 Uninstalled by Update 1709 issue?

    https://support.microsoft.com/en-us/...r-version-1709


    It certainly isn't a "friendly" write up that is for sure .....written for IT Pros I think but I found I only needed the SMB1.0 Client re-enabled for things to be fine again after playing with different settings.

    T.D.L :
    FCU disables and removes SMBv1 after 15days if it hasn't been used, (eg turning on my old Synology NAS i found I couldn't connect to do a backup), But you can turn it back on in:

    Control Panel>Programs and Features>Turn Windows Features on and Off>SMB 1.0/CIFS and checking just the SMB1.0 Client box worked for me.

    Once you do this Win10 will no longer disable it automatically as it assumes you need it, if you it turned back on.

    AFAIK this issue with SMBv1 was mainly related to WinXP and is not an issue on Win10 , so personally I was not worried about turning it back on.

    Or if you need pics ? .....do the reverse of this article
    How to Disable SMBv1 and Protect Your Windows PC From Attack


    For Others to try 1st Per Microsoft ..........

    Explorer Network Browsing

    The Computer Browser service relies on the SMBv1 protocol to populate the Windows Explorer Network node (also known as "Network Neighborhood"). This legacy protocol is long deprecated, doesn't route, and has limited security. Because the service cannot function without SMBv1, it is removed at the same time.

    However, if you still have to use the Explorer Network in home and small business workgroup environments to locate Windows-based computers, you can follow these steps on your Windows-based computers that no longer use SMBv1:


    1. Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them to Automatic (Delayed Start).
    2. When you open Explorer Network, enable network discovery when you are prompted.

    All Windows devices within that subnet that have these settings will now appear in Network for browsing. This uses the WS-DISCOVERY protocol. Contact your other vendors and manufacturers if their devices still don't appear in this browse list after the Windows devices appear. It is possible they have this protocol disabled or that they support only SMBv1.

    Note We recommend that you map drives and printers instead of enabling this feature, which still requires searching and browsing for their devices. Mapped resources are easier to locate, require less training, and are safer to use. This is especially true if these resources are provided automatically through Group Policy. An administrator can configure printers for location by methods other than the legacy Computer Browser service by using IP addresses, Active Directory Domain Services (AD DS), Bonjour, mDNS, uPnP, and so on.
    Last edited by Kbird; 07 Jan 2018 at 15:47.
      My ComputerSystem Spec

  4. sml156's Avatar
    Posts : 665
    Microsoft Windows 10 Pro 64-bit
       07 Jan 2018 #4

    I spent a hour or two trying to figure out why I could not see one of my computers, I finally gave up and reminded myself why it is a good idea to give my computers and all devices a static IP either via DHCP or manually set on the device itself.

    it's pretty easy to just type in file explorer \\192.168.200.101 or whatever IP of the computer I want to connect to and map the drive that way.
      My ComputerSystem Spec

  5.    07 Jan 2018 #5

    Kbird said: View Post
    Might be the SMBv1 Uninstalled by Update 1709 issue?
    Control Panel>Programs and Features>Turn Windows Features on and Off>SMB 1.0/CIFS and checking just the SMB1.0 Client box worked for me.
    Thanks Kbird! Looks like that was the problem, now all computers show up in "Browse for folder".
      My ComputerSystem Spec

  6.    07 Jan 2018 #6

    rboppy said: View Post
    Thanks Kbird! Looks like that was the problem, now all computers show up in "Browse for folder".
    Great News :) , thanks for following Up so Others know it works too...
      My ComputerSystem Spec


  7. Posts : 1
    Windows 10 Insider Preview
       30 Jan 2018 #7

    Kbird,

    It worked for me, just once. One map. On the second the same problem: nothing happened. And now the service is "ON". Any ideas?
    Im just trying to map some folders from WD My Cloud. In the past it wasnt a problem. Im using a Windows 10 Insider Preview.
    Thanks.

    Click image for larger version. 

Name:	Capturar.PNG 
Views:	1 
Size:	67.8 KB 
ID:	174776
      My ComputerSystem Spec

  8.    30 Jan 2018 #8

    I only have the SMB Client Enabled , I don't think SMB Direct has an effect as I don't seem to have it on all Computers...

    I have also set one Computer to be the Browse Master and to Maintain a List of Computers on the Network , use the computer (or NAS if it has the Option) that is always on.... I use an old Laptop which can not be turned off as it is very hard to reboot due to MBoard Issues, Please see the Attached WordPad file for instructions for that.

    Master Browser Fix.zip

    Click image for larger version. 

Name:	9.JPG 
Views:	3 
Size:	229.9 KB 
ID:	174782
      My ComputerSystem Spec


 

Related Threads
did a backup several days ago using restore backup when ancient laptop was running as if new. An old problem returned so I wanted to see if a restore would fix it. restore gave the message, "windows could not find a backup for this computer"
Hello All, I am having trouble finding a network path. I rent a room in a row home & Live on the 3rd floor. On the 1st floor is our living room, I am attempting to access my external hard drive thats connected to my desktop in my bedroom via my...
Hi everybody! Sorry for crossposting this from the Drivers and Hardware forum, but after a bit of investigation I found out that this forum could be more appropriate for the question. I remember with Windows 7 and 8 I used to be able to discover...
I'm so upset...here's what happened: After around a week of not checking for updates, I did it yesterday (I assume its the latest update), and found out it was scheduled to be installed today at 8.15am. So I continued using my computer...and for...
Hello, last night I upgraded to win 10 home from win 7. However, I noticed that I was unable to use the Start Menu Search function or open the start menu and found out I was only connected to my Local Area Connection (Realtek PCIe GBE Family...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:45.
Find Us