Windows 10: Samba connectivity

Page 1 of 2 12 LastLast
  1.    02 Jan 2018 #1

    Samba connectivity


    I'm still working with a problem I've mentioned here before: my Windows boxes have lost connectivity to my Samba box since adopting Win 10. There are dozens of flavors of this problem discussed online, and dozens of solutions, none of which have worked for me.

    Describing what goes on in two of my hosts, GILGAMESH (Win 10 Pro) and ABELARD (Fedora Linux):

    GILGAMESH: Full Internet connectivity via router. Can SSH into ABELARD via PuTTY. Can FTP into ABELARD via WS-FTP. Host ABELARD appears in File Explorer->Network. Clicking on its icon produces error 80070035, network path not found. This PC->Add a Network Location gives same result.

    ABELARD: Has Samba 4.7.3 aboard, with two shares configured for access by the Win machines. Filesystem, including the shares, is accessible from GILGAMESH via FTP, but not via Samba.

    Samba access was normal until the Windows machines were switched from Win 7 to Win 10.

    smb.conf file attached. Suggestions?
    rj
    Samba connectivity Attached Files
      My ComputerSystem Spec


  2. Posts : 384
    Ubuntu 18.04, win 10 pro
       03 Jan 2018 #2

    Did you change smb.conf after installing win 10?

    Why you have:

    hosts allow = 127. 192.168.1. ? <- seems wrong anyway this can surely cause problems try to comment it it may work then

    Does a folder named /buraid exists in fedora?

    ; browseable = yes <- why commented ?

    It seems you're playing a bit with smb.conf maybe without knowing what you're touching,

    is smb1 enabled or disable in win 10?
      My ComputerSystem Spec

  3.    03 Jan 2018 #3

    I've made numerous changes in trying out the various "solutions" I've found online.
    "hosts allow = 127." dates back to when the system was working. "192.168.1." was a recent attempt to enable all the hosts on my network.
    Yes, /buraid is the share that I've been using all along for backups, and it was accessible before this problem arose. It is still accessible from Windows via PuTTY or FTP.
    The browseable line has been commented out since before the problem: no change there.
    SMB 1 is turned on in Windows, with its automatic removal turned off.
      My ComputerSystem Spec


  4. Posts : 384
    Ubuntu 18.04, win 10 pro
       03 Jan 2018 #4

    Have you tried to connect with file explorer from windows with:

    smb://192.168.xxx.xxx <- in linux

    //192.168.xxx.xxx <- what is fedora's lan address ?
      My ComputerSystem Spec

  5.    03 Jan 2018 #5

    Yes: no response if I do that in the filename ribbon. If I go to This PC->Add a network location and enter that, I get "The folder you entered does not appear to be valid." If i double-click on host Abelard's icon in the "Computer" block I get error 80070035, network path not found.
      My ComputerSystem Spec


  6. Posts : 384
    Ubuntu 18.04, win 10 pro
       03 Jan 2018 #6

    have you removed 192.168.1. ?

    what is fedora's lan address ?
      My ComputerSystem Spec

  7.    03 Jan 2018 #7

    Yes, I've removed 192.168.1.
    Abelard, the Fedora host, is 192.168.1.13. Gilgamesh the Win 10 host, is 192.168.1.111.
      My ComputerSystem Spec


  8. Posts : 384
    Ubuntu 18.04, win 10 pro
       03 Jan 2018 #8

    Ok can only give you some advices at this point

    commend all "host allow"
    make sure the shared folder have right permissions youre using a folder in root would try something in your home folder
    make sure the windows user is also a smb user in linux
      My ComputerSystem Spec

  9.    03 Jan 2018 #9

    OK, I've commented out the host lines. Full permissions are present in the shares, and the user is the same in both machines. Bear in mind this system was working perfectly until the switch from Win7 to Win10.
    I've stripped most of the boilerplate comments out of smb.conf and attached the current version.
    Samba connectivity Attached Files
      My ComputerSystem Spec


  10. Posts : 384
    Ubuntu 18.04, win 10 pro
       04 Jan 2018 #10

    [buraid]
    path = /buraid
    read only = no
    browseable = yes
    guest ok = yes
    create mask = 0664
    valid users = youruser

    and to try simple case:

    [sharedir]
    path =/home/youruser/sharedir
    read only = No
    valid users = youruser


    of course you have to restart smb or the sytem after saving the file.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Unable to See Samba Share in Network and Sharing
Hi everyone, I'll try to keep it short. I have a headless ubuntu server that has a samba server. It's connected to the network with a cable (not wifi) and has a static IP. My desktop (also wired with static IP) is unable to see the samba share at...
SAMBA and Windows 10 in Virtualization
Hi there I know a load of people have Linux as a VM on a Windows 10 Host (and the other way around too). Samba will often yield strange results with W10 if you don't set up the smb.conf file correctly to work with W10. This should also fix...
Acessing Windows 10 FROM Samba in Network and Sharing
Hi there Accessing shared W10 files from Samba sometimes cause problems such as Timeout on server or not being able to acess the files although entering a SMB:\\Ipaddress will usually work where IPADDRESS is the address of the Windows machine. ...
win10 VPN samba Android in Network and Sharing
yo dudes! im so i got a little project going on here and its not going well. I have my win10 pc at home and i want to access my network shared hdd's from my android when im out and about. I am using Total Commander on my Android. I can browse...
Network Samba Problems Please Help in Network and Sharing
ok here is my situation. I reformatted clean install on my desktop. Had some hiccups but everything ok. I use in the living room this streaming box from element company,love this box. Anyway after i share with everyone this folder for movies,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:33.
Find Us