Internet speed problem with 1 Giga broadband


  1. Posts : 19
    Windows 10 Pro 64-bit
       #1

    Internet speed problem with 1 Giga broadband


    Happy holidays to all!
    I've recently been upgraded to a 1 gigabyte broadband connection. We have two PCs connected by LAN. One of them achieves 800 Mbps download and 100 Mbps upload, which is within the ISP parameters, while my Lenovo T450s laptop only achieves 100-450 Mbps download and 100 Mbps upload. I've tried different cables (both Cat 5e) to no avail.
    Any tips?

    Thanks in advance
      My Computer


  2. Posts : 19,243
    W11+W11 Developer Insider + Linux
       #2

    That laptop may not have a Gigabit LAN but only 10/100.
      My Computers


  3. Posts : 5,203
    Windows 11 Home
       #3

    Try TCP Optimizer and set it to: 100+Mbps - Optimal - Apply Changes.
      My Computer


  4. Posts : 19
    Windows 10 Pro 64-bit
    Thread Starter
       #4

    Thank you to both, I've checked and the laptop DOES have Gigabit Lan.
    I've discovered that the problem seems to lie with Kaspersky anti virus. If it's paused, I get full speed.
    I've tried TCP Optimiser but it actually slows it down (with Kaspersky paused).
    I'll see what Kaspersky says...
      My Computer


  5. Posts : 6,981
    windows 10
       #5

    Check all browsers do they have a proxy set a lot of AV run a proxy to scan data which will slow connection
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:26.
Find Us




Windows 10 Forums