I've been struggling to get the search on Outlook 2016 fully functional. After unchecking and checking Outlook 2016 from Indexing Options and checking "Allow this file to have contents indexed" for the main .ost and each .pst, I was able to get the search working for the .ost (which is rather big). It took 2-3 hours to index more than 100k items.

But when I select a pst file (an archive) and start searching, Outlook almost immediately says "no result", regardless of the number of e-mails shown in that particular folder. Even if it's only one e-mail and I try to search it, it shows "no result".

I'm rather stuck. I've searched A LOT on the internet in the last couple of days and I don't understand why windows is acting up like that.

On a different note (or maybe not), the taskbar search (cortana) never worked for domain users when I searched options within the Control Panel or within Settings (there were a few exceptions). In order to fix this, I copied a folder called windows.immersion.some_string in the C:\Users\username\AppData\Local\Packages and I overwrote the one belonging to the domain user that I was having the problem with. After a reboot it worked just fine. I'm not sure if this is related to the whole outlook indexing problem, but this seemed the only solution that could solve immediately this problem.

Any suggestions?