Office 365 programs: Application unable to start correctly 0xc0000142

Page 2 of 2 FirstFirst 12

  1. Posts : 26,929
    Windows 10 (Pro and Insider Pro)
       #11

    Great to hear
      My Computers


  2. Posts : 16
    Windows 10
    Thread Starter
       #12

    Yes I was quite happy not to need to complete reinstall of Windows.
      My Computer


  3. Posts : 628
    Windows 10 PRO 64Bit
       #13

    I just started getting this 0xC0000142 code whenever I tried to start an office application, Outlook, Excel, etc. I tried a lot of suggestions and finally used the online repair option. It basically downloaded and re-installed the whole package. Everything is working again.

    AK
      My Computer


  4. Posts : 16
    Windows 10
    Thread Starter
       #14

    alkaufmann said:
    I just started getting this 0xC0000142 code whenever I tried to start an office application, Outlook, Excel, etc. I tried a lot of suggestions and finally used the online repair option. It basically downloaded and re-installed the whole package. Everything is working again.

    AK
    Hi AK,

    Glad to hear that you got your problem solved. In my case, the Office 365 error was related to my manual deletion of Windows.Old, so I had to do a Windows repair rather than an Office repair. But there could be multiple causes of the error code 0xC0000142.

    Thanks

    Brad
      My Computer


  5. Posts : 439
    Windows 10
       #15

    I have had the same problem recently, Office 2019, Windows 10 2004. Apparently solved it by re-registering the DLLs with the comand

    for %i in (%windir%\system32\*.dll) do regsvr32.exe /s %i

    run in Administrative mode.

    My first "solution" was to restore an image of the OS (Windows) partition. This worked, but only temporarily. The problem returned after several days.
      My Computer


  6. Posts : 222
    win10 20H2
       #16

    just to add an experience - i just got the same problem/0x0000142 error code. i did the Quick Repair option and fortunately for me it worked. no idea what caused this, i'm guessing it's one of the "we're adding features" things i got recently. i kinda prefer features that don't break the product, buy hey ho.
    quick edit - Office 2016 Pro for me, got it as part of the home user scheme.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:35.
Find Us




Windows 10 Forums