Latest Office Updates for Windows

Page 30 of 31 FirstFirst ... 2028293031 LastLast
  1. Brink's Avatar
    Posts : 42,106
    64-bit Windows 10 Pro for Workstations build 18980
    Thread Starter
       #291
      My ComputersSystem Spec

  2. hTconeM9user's Avatar
    Posts : 2,702
    Windows 10x64 Home Version 1903 (Build 18362) 356
       #292

    Just received this everything seems to be working ok
      My ComputerSystem Spec

  3. Brink's Avatar
    Posts : 42,106
    64-bit Windows 10 Pro for Workstations build 18980
    Thread Starter
       #293
    Last edited by Brink; 3 Weeks Ago at 12:22.
      My ComputersSystem Spec

  4. Brink's Avatar
    Posts : 42,106
    64-bit Windows 10 Pro for Workstations build 18980
    Thread Starter
       #294
    Last edited by Brink; 3 Weeks Ago at 19:07.
      My ComputersSystem Spec

  5. Brink's Avatar
    Posts : 42,106
    64-bit Windows 10 Pro for Workstations build 18980
    Thread Starter
       #295
      My ComputersSystem Spec

  6. Brink's Avatar
    Posts : 42,106
    64-bit Windows 10 Pro for Workstations build 18980
    Thread Starter
       #296
      My ComputersSystem Spec


  7. NMI's Avatar
    NMI
    Posts : 232
    Windows 10 Pro, Version 1903
       #297

    I get an error on this one (30088-28) although the last one (previous post) was fine. Anyone else?
      My ComputerSystem Spec

  8. johngalt's Avatar
    Posts : 2,084
    Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build
       #298

    I didn't have it so I forced a check for updates, and it found it and installed it - Word ran without any problems after.
    @NMI - what have you tried in terms of troubleshooting this new build?
      My ComputersSystem Spec

  9. NMI's Avatar
    NMI
    Posts : 232
    Windows 10 Pro, Version 1903
       #299

    johngalt said: View Post
    I didn't have it so I forced a check for updates, and it found it and installed it - Word ran without any problems after.
    @NMI - what have you tried in terms of troubleshooting this new build?
    Thanks. I restarted, then ran Quick and Online Office repairs but still got the same error trying to install that latest Insider update.

    So then I uninstalled and reinstalled Office which would then update OK. But I'm steering clear of Insider updates now for a while.

    In the process, I did "upgrade" from 32-bit to 64-bit Office; which I'm finding uses slightly more disk space but significantly less CPU.

    I've been getting frustrated with Insider releases lately due to delayed release notes (and none for Windows Insider Release Preview).
      My ComputerSystem Spec

  10. hTconeM9user's Avatar
    Posts : 2,702
    Windows 10x64 Home Version 1903 (Build 18362) 356
       #300

    just been updated to this version of Office 64 Bit 2016 & Office 365 Insider! Version 1909 (Build 12001.20000 Click-to-run) so far every thing seems to be working ok
      My ComputerSystem Spec


 
Page 30 of 31 FirstFirst ... 2028293031 LastLast

Related Threads
I want to perform a Repair Install and would like to use the latest version of Windows 10 Professional 64 bit.
After installing the Anniversary Update, I checked some of the Windows Update settings. I found that the "Give me updates for other Microsoft products when I update Windows" is now unchecked and further more it is also grayed out so I cannot recheck...
All Store App Updates and Microsoft Updates can now be found in this Thread. This is to make it easier for members to find once an App has been updated or upgraded, also for any member to add their own that they find in the store to add. This...
Solved Windows 10 Latest Updates Issue in Windows Updates and Activation
Hello, Not sure why no one has tried to help me??? I have a HTPC that I build myself, it was running Windows 8 and Upgraded to Window 10. Everything was working good and fine until the last Automatic Windows 10 updates that were installed....
Solved bad_pool_header after latest windows 10 updates in Windows Updates and Activation
After the windows 10 update was installed today on my machine, I keep getting the bad_pool_header error message. I have tried to do all the options (except a system restore) & it keeps going back to the same error message. I am currently running...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:46.
Find Us