Common Faults / Fixes List

Page 3 of 5 FirstFirst 12345 LastLast

  1. Posts : 2
    Windows 10 Pro

    I own Asus N56VZ laptop with Windows 7 Ultimate, recently I upgraded to Windows 10 and is working all fine after the upgrade. One thing continue to poke me is that this entire upgrade process took me around 12 hours . As per Microsoft advise it should accomplish within 1~2 hrs. normally. Does anyone have idea what could have caused this? During installation I opted to "keep all files and apps". After the installation I had to manually update the drivers & utilities, mainly touchpad driver update.
      My Computer

  2. Posts : 8
    Windows 7/10/Ubuntu

    Hello everyone! This is my first post and made this account for the sole purpose of making said post. That being said, I've lurked your community for some time as quite a few of my Google searches pointed me to the sevenforums in the past and I have a feeling that they will direct me here for answers to my Windows 10 questions going forward.

    I recently (3 days ago) was able to complete my Win7SP1 to Win10 upgrade after trying to do so since the release date. The issue I ran into was so "obscure" that even after finding the solution there were no Google results (or Bing) that answered the problem. This will be my attempt to document what I ran into so that other's facing the same problem may come upon it and be able to resolve their own. From the beginning...

    There are 3 daily use computers in the house. My desktop (Win7, AMD FX-8350 4.3Ghz 8core, AMD HD7800, 16GB, 128GB SSD, 2TB HDD), My Wife's desktop (Win7, HP Generic Branded system), and our mutual HP Laptop(Win8.1).
    I had previously reserved Win10 on the laptop and my desktop. When upgrade day came I was delighted that our laptop had been given the go-ahead and installed it quite easily. The process took about 45 minutes and sped up remarkably once I remembered to plug it in. I was disappointed though when my desktop was not approved for the first wave and sought to "work around that". I came across the articles stating you could make a DVD or USB Key to perform the upgrade anyways. I made the USB Key, started the process and was met with everyone's favorite message "Something went wrong." SUPER frustrating when you have technical prowess and get such a vague message. Windows Update presented the error C1900208.

    I searched for hours trying to find something that represented anything that might shed light as to why it wouldn't work and wound up conceding that perhaps my video card drivers were not up to snuff. AMD had just released a new version of Catalyst and MOM.exe failed at startup every time. Uninstalled my video card drivers. Disconnected everything "extra" on my system, connected a generic keyboard and mouse. Same error. I gave up for a couple of days and enjoyed some Xbox One streaming on the laptop while "Microsoft worked out their bugs".

    I came across a post/article that pointed to the "Allow Upgrade" registry entry during that time and decided to give it another go. The change to the registry allowed me to perform the upgrade using Windows Update. For the first time on this computer I felt like I was making progress. I got the black upgrade screen and everything screamed along... Around 80% it hit "Configuring Settings" and it seemed like someone kicked my system in the virtual nuts. It ground to a slow crawl and proceeded to crawl up to 83% over the next 2 DAYS. I couldn't go without my desktop any longer and forcefully turned the computer off to reboot. "Restoring your previous version of Windows" appeared and about 20 minutes later I was back to Win7. I tried multiple techniques to try and get past this.

    I started by removing everything that wasn't necessary for the computer to operate. I disconnected my USB devices, extra monitor, and even speakers. I uninstalled most of my drivers. I even went so far as to disconnect my internal DVD drive. Every time I performed the upgrade it slugged at the same point. In the meantime, after getting back to Win7 the Windows Update screen would present a new error number 80240020. Again, the Internet was not much help in finding a solution that I hadn't already tried. (Mind you, I was not about to go dredging through extensive registry hacks.)

    That brings us to 3 days ago. Building computers is something I've always taken pride in. I remember back when I set this computer up it was my first system to have a SSD and was very excited at the performance boost it provided. It was an article about the latest 16TB SSD being released to market that triggered the memory of building this computer and the one DISTINCT change I had made to it after installing Win7 Pro. I had moved my /Users folder from my C: to my D: drive in an effort to keep from thrashing my SSD.

    The process I used was extremely straight forward. I used Robocopy to move my /users folder from C: to D: (E: to D: on my system in recover mode) then created a "Hard Symbolic Link" on my C: drive to trick Win7 into thinking it was still there. Every time Windows accessed C:\Users\* it was there, but the data instead went to D:\Users\*. Great for storing EVERYTHING, bad for Upgrading Windows as it does not appear that they took this into consideration when making the upgrade software.

    I "cleaned up" my C/D:\Users folder of any "extras" like movies, music, documents, etc and simply moved them out of the folder to reduce it's size down from 240GB to around 6GB. I then booted the system from my Win7 DVD and reversed the process I did when I installed Win7. I started by deleting my Symbolic Link using rmdir C:\Users. I then performed a Robocopy /MIR /XJ D:\Users C:\Users and waited 10 minutes for everything to copy over. After a quick reboot back to Win7 I started the upgrade again. 20 minutes.... 20 MINUTES later I was booting into Win10 for the first time on my desktop computer.

    My next "project" is to see if I can recreate my symbolic link to again regain that storage space on my SSD and move everything back to where it started. To those of you that are still reading this, I thank you for your time, I appreciate your patience, and I hope that this information comes in handy to you one day.

    TLDR: I moved my /users folder from C: (SSD) to D: (HDD) and the Win10 upgrade fouled out on "Configuring Settings" around 80% with Error Codes C1900208 and 80240020. I moved it back to C: and the upgrade when perfect.
    (TLDR - Too Long, Didn't Read)
      My Computer

  3. Posts : 5
    Windows 10 Pro

    Yeah, it seems the Windows 10 installer just can't handle symbolic links or junctions.
      My Computer

  4. linw's Avatar
    Posts : 1,934
    win 10 Insider

    Great effort guys - thank you.

    But, please, if you are asking for help, use another thread as this is for solutions not problems.
      My Computers

  5. Posts : 8
    Windows 7/10/Ubuntu

    dynamichael said:
    Yeah, it seems the Windows 10 installer just can't handle symbolic links or junctions.
    Do you know if I'd be able to move my /users/ folder back to my regular HDD and use a symbolic link again? It's okay if you don't know as I don't plan on attempting it for another couple of weeks when the personal/work life calms down again.
      My Computer

  6. Posts : 5
    Windows 10 Pro

    Shamalanana said:
    Do you know if I'd be able to move my /users/ folder back to my regular HDD and use a symbolic link again? It's okay if you don't know as I don't plan on attempting it for another couple of weeks when the personal/work life calms down again.
    I've only ever moved individual profile folders off the system drive. Here's how I do it...

    - Create a temporary admin account, reboot, and log into it
    - Move (not copy) the target profile to its new destination
    - Use mklink or LinkShell or whatever to create the directory symbolic link C:\Users\<profilename> pointing to its new location
    - Set the owner of the link and the target profile folder to SYSTEM (not sure if this is needed)
    - Reboot, sign in to the moved account, delete the temp admin account

    ... So when I re-install or upgrade the OS, I do the following...
    - Create a temporary admin account, reboot, and log into it
    - Delete the symbolic link (using explorer, not a command line)
    - Rename the actual profile folder on the other drive. I usually just add ".original" to it or something
    - Log back into the account I just unlinked (this will create a new set of folders, files, and settings, so as not to confuse the installer)
    - Run the re-install or upgrade
    - Once finished, perform the aforementioned steps for moving the newly created profile off of the system drive (so now there are two, e.g. D:\John and D:\John.original)
    - Set ownership of the contents of the old profile to the newly created account
    - It's now possible to log into the new account, but I suggest performing the next step first...
    - Selectively move content from the old folder into the new one. Don't move everything, though, as this will copy over system files that will screw up the new account.

    It's generally safe to move anything that's visible (Documents, Pictures, Music, etc) assuming you don't have explorer set to display system files. The one exception is AppData. This isn't marked as a system folder, but you don't want to simply move it from the old account to the new one. Instead, you'll have to go into each of its subfolders (Local, LocalLow, Roaming) and pick-and-choose what to move over. Generally speaking, it's safe to move folders from 3rd party vendors (e.g. Adobe, Mozilla, Google) but be careful with Microsoft. Folders related to specific applications are usually okay (Word, Excel, StickyNotes) but if it looks like it's related to the OS, or you're not certain what it is, don't move it. Alternately, you could ignore AppData and it won't hurt a thing. In fact, I'd suggest avoiding it entirely unless there is some specific configuration data that you are otherwise unable to reproduce.
      My Computer

  7. Posts : 2
    Windows 7 and 10

    I had problems on 3 out of 5 PCs. I was unsuccessful in getting one PC past the second boot phase in setup. It would begin configuring then BS and revert back to Windows 7. In the end, I solved that by formatting and reinstalling Windows 7 SP1 and fully updating it before trying again to install from the USB Win 10 installation media.

    The second problem PC wouldn't run the install program from either USB or DVD created from the .iso. After nearly a day of deleting the temp ($WS and $BT Windows?) installation folders, clearing the contents of the SoftwareDistribution downloads folder and repeatedly running Windows Update it suddenly showed me the "Your Update is Ready" message and installed. Not sure what happened there but I assume a patched update took care of the problem.

    The last PC, similar to the one above, would not run the install media from USB or DVD. Multiple KB error codes led to many "fixes", however nothing worked. Spent days on that one. Finally, not wanting to do a full format / reinstall I tried a repair "In Place Upgrade" with Windows 7, then fully updated with Windows Update. After that, just like the PC above Windows Update downloaded and prompted me to install. In the end, success.
    Both of these machines had been running their Windows 7 installations for about 4 years or more.

    TLDR: Try a Windows 7 / 8 Repair or In place upgrade to fix your current installation if you're having problems. Worked for me, twice.
    Last edited by eikaiwamax; 20 Aug 2015 at 22:32.
      My Computer

  8. Posts : 10
    Windows 10 Pro

    Has anyone had any trouble with RAID0 & Windows 10? With Windows 7, I had a dual RAID0 array (90gb ssd x2 for OS, 1tb HDD x2 for apps & data). It worked fine when I did the auto-upgrade to 10, but I had issues when I tried to do the reset. I have a thread on my issue here, if anyone has ideas or information on this. Thank you.
      My Computer

  9. Posts : 1

    I get the loading screen for a few seconds then black. i treid many things from the forums but still hangs up. I don't even get cursor but if I connect second monitor cursor shows up there with black screen.
    Several dats in.
    Any options? Remeber that I do not get anything so no control panel etc.
      My Computer

  10. Posts : 2
    Windows 10

    Rivergoat said:
    Re: Admin Rights/Ownership of Folders

    Through some further research, it appears that it is a flaw with OneDrive. As soon as I disabled the OneDrive feature, no more prompts about the permissions to the affected folders. I have read where many are experiencing this, and that MS is becoming aware of the complaints. I think we can expect a patch dealing with this in the near future.
    Disabled One Drive. Took ownership of everything on the drive. Still have access problems that cause program & file update problems.
      My Computer

Page 3 of 5 FirstFirst 12345 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:40.
Find Us

Windows 10 Forums