Page 1 of 2 12 LastLast
  1.    2 Weeks Ago #1
    Join Date : Aug 2015
    Escondido
    Posts : 35
    windows10

    Need help in changing BIOS settings from legacy boot to UEFI boot.


    After running MBR2GPT on my system with a successful completion, I realized that I don't know how to change the BIOS from legacy to UEFI, resulting in the inability to boot the GPT'ed system. I was running Windows 10 Creator on an MBR system using an MSI H61M-E23 (version 2) motherboard. I made the mistake of thinking that setting the boot mode to UEFI would be easy - I tried setting the first boot device to UEFI, but that did not work. The system does not boot - all I get is a blinking cursor. Any help would be appreciated.
      My ComputerSystem Spec
  2.    2 Weeks Ago #2
    Join Date : Jul 2015
    Posts : 9,403
    Windows 10 Pro

    Look for a setting to enable/disable CSM mode and disable it.
      My ComputerSystem Spec
  3.    2 Weeks Ago #3
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,152
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Hit DEL to enter the BIOS, go to Boot tab, set the UEFI-HD/SSD id in box 1. Set "Windows Boot Manager" in box 2. Hit F10 to save and exit.
    Click image for larger version. 

Name:	boot.png 
Views:	8 
Size:	96.3 KB 
ID:	161729
      My ComputerSystem Spec
  4.    2 Weeks Ago #4
    Join Date : Aug 2015
    Escondido
    Posts : 35
    windows10
    Thread Starter

    First, thank you for your quick responses. Unfortunately, neither response provides me with a solution.

    There is no CSM mode provided in my version of the BIOS (Aptio setup utility).

    The options menu provided for Boot Configuration are: USB Hard Disk, Hard Disk: Sandisk Ultra II, USB CD/DVD, USB floppy, Network, Bev, UEFI, Disabled. I have no choice of 'UEFI-HD/SSD' (1), only 'UEFI'. And I do not have 'UEFI Boot Drive BBS Priorities', instead the only choice I have is 'CD/DVD Rom Drive BBS Priorities'. BTW, when I choose 'UEFI' for 1st boot, at boot, the system flashes the logo and returns to the BIOS's main menu. I have the same version of the Aptio setup utility (version 2.10.1208) and my Bios Version is E7680IMS V10.14.

    Even though the MBR2GPT utility presented a successful completion, now I am questioning that. Is there some sort of 'offline' validation of the GPT'ed system that I can perform ??
      My ComputerSystem Spec
  5.    2 Weeks Ago #5
    Join Date : Jul 2015
    Posts : 9,403
    Windows 10 Pro

    You can boot the computer from a recovery USB flash drive like Kyhi's recovery tools and we can look at the disk layout.
      My ComputerSystem Spec
  6.    2 Weeks Ago #6
    Join Date : Aug 2015
    Escondido
    Posts : 35
    windows10
    Thread Starter

    While waiting for a response, I brought up Diskpart to take a look at the partition layout and noticed when doing a 'detail disk' on the system disk, 'Boot Disk' was flagged as NO in the provided information. I will take your suggestion re Kyhi's recovery USB.

    Can I use diskpart to set the EFI partition as active ?????
      My ComputerSystem Spec
  7.    2 Weeks Ago #7
    Join Date : Oct 2014
    New Jersey
    Posts : 1,387
    Windows 7 Pro x64 Windows 10 Pro x64

    Why did you change it ? There was no need to.
      My ComputersSystem Spec
  8.    2 Weeks Ago #8
    Join Date : Nov 2013
    Houston
    Posts : 2,115
    3-Win-7Prox64 2-Win10Prox64

    Quote Originally Posted by NavyLCDR View Post
    Look for a setting to enable/disable CSM mode and disable it.
    Hi,
    Not an expert as you but disabling CSM I'm pretty sure will make a system not boot anymore :/
      My ComputersSystem Spec
  9.    2 Weeks Ago #9
    Join Date : Aug 2015
    Escondido
    Posts : 35
    windows10
    Thread Starter

    This question is for AddRam - I'm not sure what your question addresses. Did I change what ?

    As for ThrashZone, The BIOS setup utility does not even mention CSM.
      My ComputerSystem Spec
  10.    2 Weeks Ago #10
    Join Date : Jul 2015
    Posts : 9,403
    Windows 10 Pro

    Quote Originally Posted by ThrashZone View Post
    Hi,
    Not an expert as you but disabling CSM I'm pretty sure will make a system not boot anymore :/
    Disabling CSM mode only disables booting from legacy BIOS MBR partitioned drives. It forces booting in UEFI more only.

    And on a GPT drive for UEFI booting, there should be an EFI System Partition that is formatted as FAT32 to boot from, but therr is no active partition.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Custom Boot Logo Windows 10 UEFI Boot Method? (Non-Legacy)
Is there currently any way to configure a custom boot logo for UEFI booting? I can only find methods for Legacy users, but no luck with UEFI. I'm kind of new to custom boot logos, so if anybody could give me some information as to if it's...
Customization
Solved Cannot boot into UEFI BIOS or Boot Menu
Belarc reports UEFI: American Megatrends Inc. P11-B2 Operating System: Windows 10 Home (x64) Version 1511 (build 10586.494) Installed: 4/27/2016 5:58:22 AM Servicing Branch: Current Branch (CB) Boot Mode: UEFI with successful Secure Boot. ...
Performance & Maintenance
Solved I have installed windows 10 in Legacy boot instead of UEFI
I'd like to change it to UEFI because it boot faster than legacy. But whenever i change it it shows no bootable device. Also i would like to ask what's the difference between the two
General Support
Ubuntu Boot option still available in UEFI BIOS after Dual Boot
Recently I played around with dual booting Linux Mint on my system. I decided that I would delete it for the present as I have other things to focus on. However, after deleting partitions and fixing my MBR to only boot windows my UEFI BIOS still...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:54.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums