Windows 10: 1703 - 1709 update fails, "could not configure on computer's hardware" Solved

Page 2 of 3 FirstFirst 123 LastLast
  1.    25 Oct 2017 #11

    Someone suggested I try upgrading via a USB drive, unfortunately same error at 43%, only difference this time when I rolled back it also showed an error on the desktop:


      My ComputerSystem Spec


  2. Posts : 3,459
    3-Win-7Prox64 2-Win10Prox64
       25 Oct 2017 #12

    Hi,
    Post a disk management screen shot sounds like you don't have enough free space left for the windows old folder to be created :/

    You might also disable secure boot as well and see if that helps seeing it failed first boot.
      My ComputersSystem Spec


  3. Posts : 8,157
    10 Home x64 (1803) (10 Pro on 2nd pc)
       25 Oct 2017 #13

    Placebo said: View Post
    Someone suggested I try upgrading via a USB drive, unfortunately same error at 43%, only difference this time when I rolled back it also showed an error on the desktop:
    The error code helps a lot.

    Code
    0xC1900101 - 0x30018

    Cause
    A device driver has stopped responding to setup.exe during the upgrade process.

    Mitigation
    Disconnect all peripheral devices that are connected to the system, except for the mouse, keyboard and display.
    Contact your hardware vendor to obtain updated device drivers.
    Ensure that "Download and install updates (recommended)" is accepted at the start of the upgrade process.
    https://docs.microsoft.com/en-us/win...upgrade-errors
      My ComputersSystem Spec

  4.    26 Oct 2017 #14

    ThrashZone said: View Post
    Hi,
    Post a disk management screen shot sounds like you don't have enough free space left for the windows old folder to be created :/

    You might also disable secure boot as well and see if that helps seeing it failed first boot.
    181gb free on a 255gb ssd so definitely not that :) Wasn't even aware I was secure booting, I'll look into that thanks :)

    Bree said: View Post
    Thanks, I've tried with every single USB item disconnected so can't be that. All drivers are installed and up to date, the only one that isn't is the SATA driver as I'm using the default one due to the performance supposedly being better.
      My ComputerSystem Spec

  5.    26 Oct 2017 #15

    Disabled secure boot, fast boot, set to clean boot, removed all anti-virus/malware and VPN apps, disabled internet, tried everything, nothing works for my PC for whatever reason, guess I have no choice but to clean install
      My ComputerSystem Spec


  6. Posts : 31,389
    64-bit Windows 10 Pro build 18219
       26 Oct 2017 #16

    A clean install may be your best option at this point.
      My ComputersSystem Spec

  7.    26 Oct 2017 #17

    Yeah and at the end of the day I'm a firm believer that a clean install every now and then is good for the soul system
      My ComputerSystem Spec

  8.    27 Oct 2017 #18

    Registered so I could post a fix here (short of reimaging). Issue appears to be caused by IISAdmin service. Workaround is to open Control Panel > Programs and Features > Turn Windows features on or off and disable Internet Information Services (and everything within it) before upgrading.

    https://social.msdn.microsoft.com/Fo...cingdeployment


    God forbid Microsoft would test the update on installations that run a web server before pushing it to the entire world.
      My ComputerSystem Spec


  9. Posts : 8,157
    10 Home x64 (1803) (10 Pro on 2nd pc)
       27 Oct 2017 #19

    IRC 129 said: View Post
    Registered so I could post a fix here (short of reimaging). Issue appears to be caused by IISAdmin service.
    Welcome to TenForums @IRC 129, and thanks for the info.

    As it happens, I have IIS turned off so I can run Wampserver instead - perhaps that's why I've not seen this problem?
      My ComputersSystem Spec

  10.    27 Oct 2017 #20

    I've no idea if that would have worked for me but thanks for posting anyway, maybe it will help someone in the future.

    Nothing worked so I ended up doing a clean install only keeping my personal files, was the only option that would ever complete, now in 1709 and on the tedious task of installing everything again and returning to their previous state!

    I'll click solved as for me I guess it is.
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
My system fails when doing "Feature Update For W10 Version 1703". It says "You can't install windows on a USB Flash Drive During Setup". I am not trying to instally on a Flash Drive. I had an external harddrive and a printer in USB ports, but...
A while back I successfully upgraded my Windows 7 to Windows 10, and then reverted back to Windows 7, with no problems. Today, I created a new partition and attempted to do a clean install of Windows 10, using a flash drive. Install failed, with the...
I finally managed to get my laptop running on Windows 10. All was fine, running build 10240 (RTM, Threshold 1). But then the Windows Upgrade assistant informed me that I'm on an outdated version of Windows 10 and that I should update. Apparently...
I just updated my laptop from the original version of Windows 10 to Version 1211 (build 10586.11) and have a strange issue with my USB ports. The USB 3.0 port works as expected. However, I attempted to create a recovery drive on thumb drive using...
I just purchased a Seagate external drive as a backup for my computer. Without me doing anything the "Safely Remove Hardware and Eject Media" icon in the lower part of my computer screen now says "Open Devices and Printers" which is where it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:28.
Find Us