Windows 10: Unable to reinstall to previous system partition (GPT) Solved

  1.    18 Oct 2017 #1

    Unable to reinstall to previous system partition (GPT)


    I tried to reinstall Windows to my existing system partition (I would like it to make one of those Windows.old folders). When I select the system partition, I get the error:

    Windows Setup

    Windows cannot be installed on this disk. The selected disk is of the GPT partition style.


    This is a bit stupid since Windows made this partition during the original Windows installation. My motherboard has UEFI.

    When I press Shift + F10 to being up the console and use diskpart to try to convert the disk to MBR, I get:

    Virtual Disk Service error:
    The specified disk is not convertible. CDROMs and DVDs are examples of disks that are not convertible.


    The disk in question is an SSD.

    I really would like to proceed without deleting the existing partition because then I'd have to find a way to copy the contents of the disk and enough space to copy the contents to, just in case I later need something I left in a program folder or whatever.
      My ComputerSystem Spec

  2.    18 Oct 2017 #2

    To get a windows.old folder implies doing in in-place upgrade. To do that you would run setup.exe on your windows install media from inside Windows. Booting from install media, as you seem to be doing, would be for a clean install.

    Which are you really after?
      My ComputerSystem Spec

  3.    18 Oct 2017 #3

    Thanks for your response. I tried installing whilst running Windows and the installation failed with a vague error message. I then tried the 'Refresh' function after which my PC boots to a black screen so attempting to install from within my old Windows installation is long longer an option.
      My ComputerSystem Spec


  4. Posts : 1,664
    Windows 7 Pro x64 Windows 10 Pro x64 Creators Update
       18 Oct 2017 #4

    Are you booting from a UEFI installer ?
      My ComputersSystem Spec

  5.    18 Oct 2017 #5

    I don't think so. I was presented with two options for the same disk and one had UEFI written in it. I thought it was a bug. It certainly isn't explicit what adding 'UEFI' to the partition name means when selecting what partition to boot from. Looked like a bug to me. Thanks. I went back and selected the UEFI alternative and it seems to be working in the expected manner (and said it would create a Windows.old folder).
      My ComputerSystem Spec


 

Related Threads
Greetings! This is my first problem post here on TenForums and it is a frustrating one. To make a long story short, I installed Windows 10 on my notebook, leaving a large amount of unallocated space available for a future Linux install. Windows...
Unable to reinstall DropBox in Software and Apps
I was having some DropBox syncing issues so I uninstalled it. Now when I try to reinstall it, nothing happens; the install package will not launch. It's not running in Task Manager. I've tried re-downloading it with same results. I've been in...
My laptop was upgraded to Windows 10 around a year back and for the most part has been behaving itself - except for one occasion when a restore was needed to get things working again. This resulted in 2 folders on the C: drive: Windows.old and...
I have a Thinkpad now running Windows 10 which a Lenovo tech says needs a fresh install. After checking the BIOS OS note he says it shows Windows 8 as the original OS so to do a fresh install he will send me Win 8.1 recovery disks which I must first...
Deleting previous windows partition in Installation and Upgrade
Hi, I just upgraded my laptop from windows 8 to win 10. The free upgrade of course did not delete my files from window 8 so I went ahead and installed windows 10 on to my USB and booted from it for a clean install. While installing win 10 however...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:41.
Find Us